Subject: [art] [Technical Errata Reported] RFC6902 (6351)

From: RFC Errata System <[email-masked]>
Date: Wed, 9 Dec 2020 03:19:42 -0800 (PST)

The following errata report has been submitted for RFC6902,
"JavaScript Object Notation (JSON) Patch".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6351

--------------------------------------
Type: Technical
Reported by: Palle Cogburn <[email-masked]>

Section: GLOBAL

Original Text
-------------

Corrected Text
--------------

Notes
-----
If the patch elements included a property "previous" that contained the original value in case of an operation such as "remove" for instance, it would be easy to create the reverse operation - "add". In that way the path elements can be used as audit records and it is easy to revert a path or even a part of a patch, so the document is back to a previous version. All you have to do is apply the reverse patch and also add those elements to the audit trail.
Is this something to consider adding to this document or is it an implementation detail?

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC6902 (draft-ietf-appsawg-json-patch-10)
--------------------------------------
Title               : JavaScript Object Notation (JSON) Patch
Publication Date    : April 2013
Author(s)           : P. Bryan, Ed., M. Nottingham, Ed.
Category            : PROPOSED STANDARD
Source              : Applications Area Working Group APP
Area                : Applications
Stream              : IETF
Verifying Party     : IESG

---

From: Julian Reschke <[email-masked]>
Date: Wed, 9 Dec 2020 13:05:19 +0100

Am 09.12.2020 um 12:19 schrieb RFC Errata System:
> ...

This is a feature request, not an erratum...

Best regards, Julian

---

From: Ned Freed <[email-masked]>
Date: Wed, 09 Dec 2020 05:56:52 -0800 (PST)

Maybe I'm missing something, but I don't see any actual error that needs to
be corrected. Nor do I see it as an actual deficiency, so my recommendation 
is to reject.

				Ned

> If the patch elements included a property "previous" that contained the
> original value in case of an operation such as "remove" for instance, it would
> be easy to create the reverse operation - "add". In that way the path elements
> can be used as audit records and it is easy to revert a path or even a part of
> a patch, so the document is back to a previous version. All you have to do is
> apply the reverse patch and also add those elements to the audit trail.

> _______________________________________________
> art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/art

---

From: Claudio Allocchio <[email-masked]>
Date: Wed, 9 Dec 2020 15:23:44 +0100 (CET)

> be corrected. Nor do I see it as an actual deficiency, so my recommendation

I also see "all empty fields" in the report ... (!?), too. It is just the 
note which does no actually report an "error" in the RFC itself.

confused....

>> "JavaScript Object Notation (JSON) Patch".

------------------------------------------------------------------------------
Claudio Allocchio             G   A   R   R          [email-masked]
                         Senior Technical Officer
tel: +39 040 3758523      Italian Academic and       G=Claudio; S=Allocchio;
fax: +39 040 3758565        Research Network         P=garr; A=garr; C=it;

      PGP Key: https://www.cert.garr.it/servizi/informazioni-su-pgp-keys

---

From: Barry Leiba <[email-masked]>
Date: Wed, 9 Dec 2020 10:34:44 -0500

Hi, Palle.

Welcome to the IETF, and thanks for your comments about the JSON Patch RFC 6902.

As others have noted, your comments are not in scope for errata
reports, which are meant to collect errors in the documents, things
that were actual errors at publication and that would have been fixed
at that time had the working group or document authors noticed them --
they were just missed.  What you've reported is a feature suggestion,
not an erratum, and we will be rejecting it as an errata report.

That said, I understand that folks who aren't experienced with how the
IETF works often do not know where to bring such suggestions, and
errata reports can seem like the right way to approach us.  Let me
suggest that you re-formulate your report as a suggestion for
improvement/extension to JSON Patch, and post that suggestion for
discussion on the mailing list of the former JSON working group
<[email-masked]>.  That mailing list is still open, and folks
interested in JSON issues are still subscribed.  If there is enough
interest, it's possible to publish an update or extension to JSON
Patch.

Barry Leiba, ART Area Director

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 10 Dec 2020 08:30:16 +1100

Also - we're collecting ideas for a revision of JSON Patch at:
  https://github.com/json-patch/json-patch2

Cheers,

> On 10 Dec 2020, at 2:34 am, Barry Leiba <[email-masked]> wrote:
> 
> Hi, Palle.
> 

--
Mark Nottingham   https://www.mnot.net/