Subject: [Asdf] 2020-12-14: virtual interim meeting starting in 15 minutes

From: Michael Richardson <[email-masked]>
Date: Mon, 14 Dec 2020 08:47:52 -0500

Hi, the agenda as posted did not include the webex link.
The IETF datatracker does know it.  Here is the complete agenda:

---

# ASDF -- AGENDA for Virtual interim meeting

## Info

Meeting: ASDF WG, Virtual interim, 1400-1530 UTC, Dec 14th, 2020

Location: Webex  https://ietf.webex.com/ietf/j.php?MTID=m0d089a7c8ac2d5a188c733c8107cb390

Chairs: Michael Richardson and Niklas Widell

Etherpad/CodiMD: https://codimd.ietf.org/notes-asdf-2020-12-14

===========================

## Agenda

1. Note Well.  https://www.ietf.org/about/note-well/

2. Logistics for Meeting.

	2a. CodiMD for notes https://codimd.ietf.org/notes-asdf-2020-12-14

	2b. Webex https://ietf.webex.com/ietf/j.php?MTID=m0d089a7c8ac2d5a188c733c8107cb390

	2c. Agenda bash

3. WG status update (Chairs - 10 min)

	 3a. Welcome and discussion of WG proceedures

4. SDF 1.1

	4a. Issues

5. W3C Web of Things collaboration (to be confirmed)

6. AOB?

===========================

## Meeting material:

draft-ietf-asdf-sdf https://datatracker.ietf.org/doc/draft-ietf-asdf-sdf/

SDF overview (from virtual interim) https://youtu.be/_8i6X4AxuOk (17 minutes)

===========================

---

From: Michael Richardson <[email-masked]>
Date: Mon, 14 Dec 2020 16:45:11 -0500

Uploaded presently at:
  https://github.com/ietf-wg-asdf/asdf-working-group-notes/blob/main/meetings/minutes20201214.md

please send pull-requests with edits.
Niklas and I will upload to datatracker later this week.

## Info

Blue sheet:
1.   Michael Richardson
2.   Niklas Widell
3.   Ari Keränen
4.   Barry Leiba
5.   Carsten Bormann
6.   Francesca Palombini
7.   Kaz Ashimura (W3C)
8.   Kunihiko Toumura
9.   Michael Koster
10.   Nigel Davis
11.   Tomoaki Mizushima
12.   Wouter van der Beek
13.   Michael Lagally
14.   Klaus Hartke
15.   Sebastian Kaebisch

## Agenda

	2c. Agenda bash

slides: https://datatracker.ietf.org/meeting/interim-2020-asdf-02/materials/slides-interim-2020-asdf-02-sessa-slides-for-2020-12-14-asdf-virtual-interim-00

     [slides 6, 7, 8, 9]
    Questions:
    Michael Koster quite a bit of external input to the model (4+ named).
    So the requirements that were collected were very broad, but we need to finish the language before we can ask them to come back and contribute models.
    Discussion about RFC vs Implementation Draft.

4. SDF 1.1

	4a. Issues
	https://github.com/ietf-wg-asdf/SDF/issues/3
    https://github.com/ietf-wg-asdf/SDF/issues/4
    ACTION: create wiki page on what the different ecosystems are dealing with converation to/from SDF.
    MK: mapping files (leverages JSON pointer).... also inline extension points.
    WvdB: already a web page: https://onedm.org/terminology/
    "pressure test" now needed.

    https://github.com/ietf-wg-asdf/SDF/issues/7    - sdfRef issue
    "This thing is like that thing, but this restriction does not apply"
    How can we set that part to "null"?
    _What if you do it the other way around? Then it is an extend!_
    Subtypes vs overrides.
    Declaration vs Definition distinction.
    CB: When you say "override"... would it be okay to define RGB, and then override...with a different colour scheme? (Answer NO)
    When say motor speed 0..255, but then restrict to 0..50.
    Convention that override is only used for subtyping, new type should be a subtype.
     thus, we don't need to set qualities for null.

    https://github.com/ietf-wg-asdf/SDF/issues/2
    https://github.com/ietf-wg-asdf/SDF/issues/5
    enum and anyOf
    and mixes!

    Data Model vs Info Model
    The problem is reusing syntax from data modelling to do information modelling.
    YES: sdfChoice:  https://github.com/ietf-wg-asdf/SDF/pull/8

    . o O ( what MCR hears is that pure JSO pointer has to be extended, so no common code )
    SK points to: https://github.com/w3c/wot-thing-description/issues/997
    consensus proposal: do not deprecate JSON Schema ORG ENUM, but *do* include solution for MK need.  Will go into #8.

https://github.com/roman-kravtsov/sdf-object-converter

Kaz mentios the [W3C liaison table for IETF](https://www.w3.org/2001/11/StdLiaison#IETF) and suggests further discussin by email.

6. AOB?
 - discussion about liason needs.
 -

## Meeting material:

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide