Subject: RE: [Asrg] 6. Proposals - rDNS and DNS considerations

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Tue, 2 Dec 2003 18:17:36 -0800

> Thanks. This is great stuff.
> 
> One comment, though:
> > 	To get a DNS resource record assigned we have to have an (IETF)
> > standard. It is possible that the DNSEXT working group 
> could act quickly,
> > this seems to mean order of 18 months to be realistic. That 
> is not going to
> > be acceptable. It is not like we get a record type 
> assignment and then get
> > to work with it.
> 
> Due to the threat caused by spam it might happen that the 
> DNSEXT working
> group could speed up things. However this would IMHO require that the
> proposal is a stable and practicable solution with a high 
> probability of
> success. QTYPE is two octets and I don't think DNS will take large
> damage if it turns out that one TYPE has been "misassigned" ;-)

Thats not the issue. The issue is control. If they hand out a QTYPE and we
define a domain name hack they lose control of the future of DNS
development.

I think spam is a major issue. But DNSEXT is a group where you can say 'if
the spec does not work in dotcom because it is too big the answer is to
reduce the size of dotcom' and not get laughed at.

		Phill

_______________________________________________
Asrg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/asrg

---

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Wed, 3 Dec 2003 06:57:15 -0800

> Hallam-Baker, Phillip wrote:
> > Following on on the rDNS track I did some investigation on 
> the rDNS and DNS
> > side. The following issues were raised off list:
> > 
> > 1) Is rDNS stable enough to depend on?
> > 	Maybe. The quality of the data registered for North America and
> > European zones is 'reasonable'. It is not great but not 
> ridiculous. The
> > quality of the data in the Asian zones is not at all good.
> > 
> > 	One issue to consider is that some of the NICs have 
> been proposing
> > to kill rDNS since "nobody uses it and it is no damn use".
> > 
> 
> Are you refering to the regional registries (RIPE, APNIC, etc.)?

Yes, but I can't be more specific.

The feeling I got was that we are in a use it or loose it situation. IF we
define a compelling use of the reverse DNS to help control spam and that
becomes a killer application then the reverse DNS probably stays intact.

I made another call today and got some additional info on rDNS. There is
absolutely no problem putting TXT records in there. 

		Phill