Subject: Re: [Asrg] Filtering Header Draft Discussion

From: Danny Angus <[email-masked]>
Date: Thu, 21 Oct 2004 09:11:53 +0100

I'm not convinced, from first brief reading, what the benefit of all this
is.

"X-" exists to permit non-standard headers. Most users of "X-" use them for
either conveying proprietery information or for making a human readable
trace.

If there is a need for general interoperability around a topic proposing a
new header is not necessarily the most important step.

I don't get a clear and unambigous statement of requirements or
specifiaction for this functionality.

Don't get me wrong, I haven't had time to fully digest it, but on first
reading it seems to have a very large scope and it responds with a proposal
which is not currently supported by anyone.

d.

|---------+---------------------------->
|         |           Philip Miller    |
|         |           <[email-masked]|
|         |           et>              |
|         |           Sent by:         |
|         |           asrg-bounces@ietf|
|         |           .org             |
|         |                            |
|         |                            |
|         |           16/10/2004 06:09 |
|         |           AM               |
|         |                            |
|---------+---------------------------->
  >---------------------------------------------------------------------------------------------------------------|
  |                                                                                                               |
  |       To:       ASRG - Filtering Subgroup <[email-masked]>, ASRG <[email-masked]>                        |
  |       cc:                                                                                                     |
  |       Subject:  [Asrg] Filtering Header Draft Discussion                                                      |
  >---------------------------------------------------------------------------------------------------------------|

Hello, all!

I have a few days of relative free time, of which I plan to spend a fair
portion reviewing
and revising the draft. The current version can be found at
<http://millenix.zemos.net/asrg-filtering/>
in xml2rfc source, HTML, and TXT formats. The Subversion repository with
the XML source
can be found at
<http://millenix.zemos.net/repos/filtering/>

In particular need of work are the definitions of the fields that will be
standardized in
format. Proposals on how various types of scores should be expressed are
much desired

I'd like to talk to anyone who has comments on this in realtime at some
point in the next
4 days. I'll try to be online in the ASRG jabber channel as much as
possible, but
afternoon to evening of tomorrow (Oct. 16th) and Oct. 19th would be best.
If you can't or
don't want to discuss this in Jabber, but have thoughts, please email them
to the
Filtering Subgroup list.

Philip Miller

_______________________________________________
Asrg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/asrg

***************************************************************************
The information in this e-mail is confidential and for use by the addressee(s) only. If you are not the intended recipient (or responsible for delivery of the message to the intended recipient) please notify us immediately on 0141 306 2050 and delete the message from your computer. You may not copy or forward it or use or disclose its contents to any other person. As Internet communications are capable of data corruption Student Loans Company Limited does not accept any  responsibility for changes made to this message after it was sent. For this reason it may be inappropriate to rely on advice or opinions contained in an e-mail without obtaining written confirmation of it. Neither Student Loans Company Limited or the sender accepts any liability or responsibility for viruses as it is your responsibility to scan attachments (if any). Opinions and views expressed in this e-mail are those of the sender and may not reflect the opinions and views of The Student Loans Company Limi!
 ted.

This footnote also confirms that this email message has been swept for the presence of computer viruses.

**************************************************************************

_______________________________________________
Asrg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/asrg

---

From: Laird Breyer <[email-masked]>
Date: Fri, 22 Oct 2004 12:57:25 +1000

Danny,

> new header is not necessarily the most important step.

The document is a work in progress, which is attempting to summarize a number
of discussions which were had on the filtering list several months ago. 
Rather than present a finished document for discussion, the revisions are
being announced on the list to give people an opportunity to criticise it early.

Any thoughts you have on it, or on what you think general interoperability should
mean, are worth posting to the list. 
 
> specifiaction for this functionality.

Currently, the document has had a few people adding bits in several places, 
so it's a bit out of focus. One of the authors is currently streamlining
it to improve the focus, and a more readable copy should be available 
in the next few days. 

Please don't hesitate to post your thoughts on areas which are confusing or
seem out of touch. They may well be, but someone (you :-) needs to point it out.

Roughly speaking, there are two interrelated ideas. The first idea is
that a common header for filtering results, with key/value pairs 
will allow any software to read the output of any compliant filter. 
Some of the key/value pairs must have universal meanings, while other
pairs can be filter-specific. This removes the need for custom, filter specific
parsing of headers.

The other idea is that if different software ("downstream") can look at headers
added earlier in the message lifetime ("upstream"), then there are data 
integrity and trust issues which must be addressed, resulting in formalized
rules such as e.g.: "write a single header for each filter, not two or three
which must be combined to be meaningful".

-- 
Laird Breyer.