Subject: [Asrg] FeedBack loops

From: Franck Martin <[email-masked]>
Date: Wed, 12 Nov 2008 09:30:56 +1200 (ANAT)

http://www.mipassoc.org/arf/ 

I'm looking at feedback loops and I stumbled on this effort to standardise them. Apparently there is an Internet draft 

The current draft expires in December 2008: 
http://www.ietf.org/internet-drafts/draft-shafranovich-feedback-report-05.txt 

May be worth the support of this group? 
_______________________________________________
Asrg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/asrg

---

From: Franck Martin <[email-masked]>
Date: Wed, 12 Nov 2008 09:38:51 +1200 (ANAT)

Replying to myself.. 

I see John Levine is on it, so all seems under control. 

But I'm curious to know more on the feedback loops.

---

From: "J.D. Falk" <[email-masked]>
Date: Tue, 11 Nov 2008 14:53:42 -0700

> I see John Levine is on it, so all seems under control.

Yep, the future of that draft is being discussed on other IETF lists.

> But I'm curious to know more on the feedback loops.

What would you like to know?

---

From: Franck Martin <[email-masked]>
Date: Wed, 12 Nov 2008 10:04:31 +1200 (ANAT)

Well a bit of background. 

Is the ARF standard well accepted, I see AOL and a couple use them. I see also that hiding the user that reports the spam may not allow for the recipient of the report to act correctly. 

Are there any tools/library available around ARF, to 1) create these reports 2) parse/process them 

Any chance to have these tools build in in major MTAs ? Does it make sense? 

Could they be an after the fact fbl? let say I want to know if my email got delivered, query an mta, supplying some data like domain/sender IP, and the mta sends me any report over last few hours.. 

I think that's all to start a discussion 

Sorry for being a bit new in this field

---

From: "J.D. Falk" <[email-masked]>
Date: Tue, 11 Nov 2008 15:20:55 -0700

On 11/11/2008 15:04, "Franck Martin" <[email-masked]> wrote:

> Is the ARF standard well accepted, I see AOL and a couple use them. I see also
> that hiding the user that reports the spam may not allow for the recipient of
> the report to act correctly.

Very well accepted, yes.  Nearly every complaint feedback loop uses ARF.

> Are there any tools/library available around ARF, to 1) create these reports

http://wordtothewise.com/resources/arf.html has some.

> Any chance to have these tools build in in major MTAs ? Does it make sense?

I'm not sure what that would achieve.  The actual process is:

1. $A sends a message to $B
2. $B complains to $C (their ISP) about the message (example the "spam"
button in the Yahoo! Mail web UI)
3. $C encapsulates the message as ARF, and sends it to $A (if $A has signed
up to receive that feedback)

Lots of people want to make it more complicated, but it really is that
simple today.

> Could they be an after the fact fbl? let say I want to know if my email got
> delivered,  query an mta, supplying some data like domain/sender IP, and the
> mta sends me any report over last few hours..

No, ARF isn't (as far as I know) used for delivery reports.  It was created
for -- and is primarily used for -- user complaints, as described above.

---

From: Jose Celestino <[email-masked]>
Date: Wed, 12 Nov 2008 02:40:10 +0000

> Is the ARF standard well accepted, I see AOL and a couple use them. I see also that hiding the user that reports the spam may not allow for the recipient of the report to act correctly. 

I don't recall the specs but yes, it should be at least interesting to
have a uniq id, unrelated to the real reporting user, so that a
complaint can be tracked. Moreover it could be used to identify distinct
reports of the same spam/abuse if you, on the report receiving end of
ARF, decide to do automatic spam db feeding or blocking smtp-auth users,
for instance.

> Any chance to have these tools build in in major MTAs ? Does it make sense? 

No. This should be processed on the LDA/MUA I guess.

-- 
Jose Celestino | http://japc.uncovering.org/files/japc-pgpkey.asc
----------------------------------------------------------------
"One man’s theology is another man’s belly laugh." -- Robert A. Heinlein
_______________________________________________
Asrg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/asrg