Subject: Re: [Asrg] POSTAGE, was The fundamental misconception about paying for mail

From: John Levine <[email-masked]>
Date: 1 Dec 2008 14:27:07 -0000

>} coffee. But 98% of the cash that customers offer is counterfeit. How
>} would this affect the way that cashiers work? Would they just accept
>} all the cash and figure they'll call the cops when they find bogus
>} stuff?
>
>I suspect they'd make everyone pay in advance so they have time to
>confirm the cash is real, and then only provide service to those who
>have an account in good standing.  Then it may turn into a problem
>with identity theft, but that doesn't hit their bottom line.

Then 98% pay with fake versions of whatever it is that they give you
to say that you have an account.  Same problem.  This isn't a perfect
analogy, since at a donut store you rarely have 1000 people
simultaneously at 1000 counters trying to buy a donut with the same
card that has only 50 cents on it.

>} ... if your wonderful system rejects their fake stamps with 99%
>} accuracy, they try 100 times as often ...

>....  Let through unchecked anyone with a history of payment and
>throttle everyone else (to the point of quarantine without final
>delivery, if necessary) until you know their history.

That's what Turntide does, except for "history of wanted mail."
Why would "history of paying" be better?

R's,
John
_______________________________________________
Asrg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/asrg

---

From: Bart Schaefer <[email-masked]>
Date: Mon, 01 Dec 2008 08:24:03 -0800

On Dec 1,  2:27pm, John Levine wrote:
}
} Then 98% pay with fake versions of whatever it is that they give you
} to say that you have an account.  Same problem.

Well, no, it's not the same problem.  A fake version of an account ID
matches *somebody's* real account, so instead of 98% of the people
stealing directly from Dunkin, they're stealing from the other 2% of
the customers.  Or more likely, they're stealing from a credit card
company who has a few hundred billion units of the US Gov's attention.

} [...] at a donut store you rarely have 1000 people simultaneously at
} 1000 counters trying to buy a donut with the same card that has only
} 50 cents on it.

A donut shop also doesn't have gigabytes of cheap lobby space where it
can make all those customers wait for their donut until it knows how
much is left on the card.  I mean, really, is it that hard to require
that transactions on the same identity are serialized to within some
tolerance?  You can still parallelize on the number of identities.

Yes, the spammers can also still parallelize that way, but they are at
least limited to the number of identities that have paid accounts,
rather than being able to invent new identities at the flip of a bit.

} >....  Let through unchecked anyone with a history of payment and
} >throttle everyone else (to the point of quarantine without final
} >delivery, if necessary) until you know their history.
} 
} That's what Turntide does, except for "history of wanted mail."
} Why would "history of paying" be better?

Revenue stream to cover all the expenses of putting such a system
in place and running it.  Disincentive (if only indirectly through
negative feedback to the victims of theft) for the "unwanted."

Of course in a system where this was common, it'd be possible to be
a fraudulent "seller" instead of a fraudulent buyer, but it probably
be a little harder to do so untraced.
_______________________________________________
Asrg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/asrg

---

From: John Levine <[email-masked]>
Date: 2 Dec 2008 01:22:46 -0000

>company who has a few hundred billion units of the US Gov's attention.

Ah, my spam is OK because I stole the postage from Citigroup.  Well,
it's an interesting idea.

> I mean, really, is it that hard to require that transactions on the
> same identity are serialized to within some tolerance?

In a toy system, it's easy.  In an interestingly large system, it's
phenomenally difficult.  I get the impression you aren't familiar with
transaction systems or large databases.  Or for that matter, why the
double spending problem is a killer for micropayments.

>in place and running it.

How much revenue do you expect your postage system to generate?  How
much do you expect it to cost to run?  (Don't forget to account for
the 98% bogus transactions that generate no revenue.)  Do you have any
reason to expect that those numbers will be within two orders of
magnitude of each other?

R's,
John

---

From: Bart Schaefer <[email-masked]>
Date: Mon, 01 Dec 2008 23:16:19 -0800

On Dec 2,  1:22am, John Levine wrote:
}
} Ah, my spam is OK because I stole the postage from Citigroup.  Well,
} it's an interesting idea.

At the moment it's hard to get real enforcement because nobody can
attach an obvious direct cost to spam (despite all those estimates
of billions in lost productivity) and there are neither hordes of
voters nor big effective lobbies with holes in their wallets calling
for action.
 
} I get the impression you aren't familiar with transaction systems or
} large databases. Or for that matter, why the double spending problem
} is a killer for micropayments.

I apologize to everyone for allowing the conversation to get steered
back to this, because part of the point was to try to stop framing the
problem as one of micropayments.  Maybe that's in itself impossible.

Anyway, you're correct that micropayments are not my area of expertise.
Since this is a research group, here's a pointer to some research done
by someone else:

http://arxiv.org/abs/0802.0832

    The crucial observation is that it may be impossible, or very
    expensive, to prevent every possible double spending of a coin
    (i.e., a deterministic approach), but that it may very well be
    possible to prevent that a particular coin is double spent many
    times, using efficient randomised techniques. Even such a weaker
    guarantee limits the damage an adversary can do. In other words,
    the main paradigm shift is the realisation that double spending a
    single coin twice is not so bad, but spending it a hundred times
    should be impossible. Of course, such a probabilistic and limited
    security property may not be strong enough for the protection of
    'real' money. It may, however, be quite workable for currencies
    used to enforce fairness among P2P users.

} How much revenue do you expect your postage system to generate?

I don't know, and that's actually where I come back into agreement
with you and disagreement with Barry:  I'm not convinced that it
can produce enough revenue to interest anyone in deploying it.  It
was Gerald, I believe, who indicated an interest in separating the
discussion of a workable design from the assumption that no design
could possibly be worth the costs.
_______________________________________________
Asrg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/asrg

---

From: John Leslie <[email-masked]>
Date: Tue, 2 Dec 2008 09:12:20 -0500

> http://arxiv.org/abs/0802.0832

   This paper concerns early detection of double-spending in the case
where "the central bank" is not involved in the transaction. (If
you're curious how they do it, read the paper: it's simple enough.)

   Actual _prevention_ of double-spending is simple enough in the
case where the "central bank" _is_ involved. I claim it's even easier
in cases where the _issuing_ bank is involved. (We recognize, of
course that in international commerce it's politically difficult to
agree on a single "central bank", and thus it becomes expensive.)

   I would further claim that it would be simple enough, in the case
of ePostage, to have the receiving MTA specify a set of acceptable
issuing banks and ensure that each of them _could_ be involved at
the time of the transaction (which happens at SMTP time). This would
eliminate the double-spending problem between the only two parties
that must be able to interact without previous arrangement.

--
John Leslie <[email-masked]>
_______________________________________________
Asrg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/asrg

---

From: "Gerald Klaas" <[email-masked]>
Date: Tue, 2 Dec 2008 08:01:31 -0800

On Tue, Dec 2, 2008 at 6:12 AM, John Leslie <[email-masked]> wrote:

> And by decentralizing, it mitigates the giant database problem.

Thanks for the link,
Gerald

---

From: Bart Schaefer <[email-masked]>
Date: Tue, 02 Dec 2008 08:30:46 -0800

On Dec 2,  9:12am, John Leslie wrote:
}
}    I would further claim that it would be simple enough, in the case
} of ePostage, to have the receiving MTA specify a set of acceptable
} issuing banks and ensure that each of them _could_ be involved at
} the time of the transaction (which happens at SMTP time).

This is exactly where I was headed when I suggested that the SMTP
MAIL command could carry a parameter describing the bank(s) that
the sender supports, so the recipient MTA can match with its set
of trusted banks.
_______________________________________________
Asrg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/asrg

---

From: Barry Shein <[email-masked]>
Date: Mon, 1 Dec 2008 20:18:49 -0500

> card that has only 50 cents on it.

I will say that, having worked and grown up in retail, people who pass
phony bills try to find very busy cashiers to pass them thru.

A big problem at Coney Island food stands and similar, which can get
impossibly busy, were people who'd cut the corners off a $20 bill and
paste them onto a $1 bill. The $20 is still good (hand it in at the
bank, rule is usually >50% then ok), and the $1 gets accepted by the
busy cashier as a $20. And no print counterfeiting involved! Any idiot
with scissors and glue can try it tho I think it's as serious a crime
as any counterfeiting, or more serious than most people would call fun
anyhow.

And on and on. All kinds of con games, slight of hand, I could teach
you a few which really work but even better with a busy cashier.

But cryptography gives us a potentially 100% (ok, 99. with a lot of
9s%) certain identification of phony "bills", much like even an
average bill scanning machine would never be fooled by those clipped
corners, and a pretty good one can spot most any phony.

 > Why would "history of paying" be better?

I wouldn't use any "history of paying".

I would expect "history of fraud" to be of interest, particularly if
positive ID were required a la DKIM or similar.

-- 
        -Barry Shein

The World              | [email-masked]           | http://www.TheWorld.com
Purveyors to the Trade | Voice: 800-THE-WRLD        | Login: Nationwide
Software Tool & Die    | Public Access Internet     | SINCE 1989     *oo*
_______________________________________________
Asrg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/asrg