Subject: [Asrg] spf2.0

From: Franck Martin <[email-masked]>
Date: Tue, 24 Feb 2009 21:47:48 +1200 (FJT)

I have been looking around, but it seems I cannot find a TXT record that has spf2.0 they are all v=spf1 

This seems strange to me. I know that SPF is part of SenderID but then... So is SenderID really deployed or it is just SPF?

---

From: "Chris Lewis" <[email-masked]>
Date: Tue, 24 Feb 2009 08:48:09 -0500

> has spf2.0 they are all v=spf1

dig -t txt ebay.com

---

From: Steve Atkins <[email-masked]>
Date: Tue, 24 Feb 2009 08:12:01 -0800

> that has spf2.0 they are all v=spf1

ebay.com and paypal.com are the two I can think of (though paypal.com  
seem to have broken their DNS a little right now).

>
>
> This seems strange to me. I know that SPF is part of SenderID but  
> then... So is SenderID really deployed or it is just SPF?

SenderID is dead. The only group that every liked it was Microsoft /  
Hotmail, and even they don't publish it. Any records you see are  
mostly just fossil relics of an earlier era.

Cheers,
   Steve

---

From: Richard Rognlie <[email-masked]>
Date: Tue, 24 Feb 2009 11:30:46 -0500

> mostly just fossil relics of an earlier era.

And one SenderID/SPF issue that you *will* run into is that...

The Sender ID spec tells you that if you see a v=spf1 record, you should
treat it as though it were spf2.0/mfrom,pra when, in fact, if *should*
be treated as though it were spf2.0/mfrom.  any assumption of "pra" is
not necessarily a valid read of the sending domains wishes.

-- 
 /  \__  | Richard Rognlie / Sendmail Ninja / Gamerz.NET Lackey
 \__/  \ | http://www.gamerz.net/~rrognlie    <rrognlie at gamerz.net>
 /  \__/ | Creator of [email-masked]
 \__/    |                Helping reduce world productivity since 1994

---

From: Franck Martin <[email-masked]>
Date: Wed, 25 Feb 2009 06:42:29 +1200 (FJT)

And you have to submit your SPF record to MS CIDF database otherwise MS does not even read it from the DNS. Is that a joke?

Yes senderID is truly dead.

----- Original Message -----
From: "Steve Atkins" <[email-masked]>
To: "Anti-Spam Research Group - IRTF" <[email-masked]>
Sent: Wednesday, 25 February, 2009 4:12:01 AM (GMT+1200) Auto-Detected
Subject: Re: [Asrg] spf2.0

Cheers,
   Steve

_______________________________________________
Asrg mailing list
[email-masked]
http://www.irtf.org/mailman/listinfo/asrg

---

From: Jeff Macdonald <[email-masked]>
Date: Tue, 24 Feb 2009 15:38:24 -0500

>not necessarily a valid read of the sending domains wishes.

that is why we use spf2.0/pra records for our clients (in addition to
v=spf1 records). So I think as long as MS abuses v=spf1 records,
SenderID lives....

-- 
Jeff Macdonald
[email-masked]