Subject: [Atlas] Charter Text

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 6 Feb 2018 09:08:21 +0000

Application Transport LAyer Security (ATLAS)
============================================

# Charter for Working Group

## Background

The Transport Layer Security (TLS) protocol has been a hugely successful security protocol and it is used by developers to secure connection-oriented as well as connection-less transport protocols. Under the hood, both TLS and DTLS consist of sub-protocols, namely the handshaking protocols and the record protocol. The handshaking protocols offer an authenticated key exchange protocol that establishes the necessary keys and parameters for protecting application data via the record protocol. Years have been spent in improving both protocols and particularly the more sophisticated handshaking protocols. The IETF TLS working group published many extensions and ciphersuites so that TLS can be customized for different environment. This flexibility and the availability of source code is appreciated by developers writing web applications, smart phone apps, and also for securing backend communication. With the need to secure embedded devices communicating with the cloud-based infrastructure TLS and DTLS has even found traction in the Internet of Things (IoT) community.

## Problem Statement

TLS and DTLS sit between the transport layer, such as TCP and UDP, and the applications. Hence, TLS and DTLS offer protection of application traffic exchanged between the endpoints of the transport layer. There are, however, deployments where security protection needs to be applied beyond these two transport layer endpoints. Use cases include deployments where proxies terminate connections along the path or where devices transmit data first over a non-IP transport, such as Bluetooth Smart, before IP communication starts at the smart phone towards a cloud-based infrastructure.

While application layer security mechanisms already exist, such as CMS, JOSE, and COSE offering protection of application data those are focused on one-shot message exchanges.
Securing one-shot payloads, such as firmware updates in an IoT context (such as work done in the IETF SUIT working group), is therefore outside the scope of this work.

There is a need to offer application layer security for communication that is session based, i.e., where communication establishment is followed by an exchange of an arbitrary number of application data.  This application layer security mechanism requires authentication of the endpoints, and a modern a key exchange protocol. The result of a positive handshake will lead to the establishment of keying material and negotiated algorithms for confidentiality, integrity and replay protection of application data.

The TLS protocol has also been used in environments not initially anticipated by the TLS authors, such as in EAP-TLS/EAP-TTLS for network access authentication where the TLS handshake is carried over EAP payloads. Furthermore, with DTLS-SRTP the DTLS handshake has been used to establish security associations for protecting RTP. As such, there is also a precedence for embedding TLS in "applications" (whereby EAP would be here the network access authentication application).

## Goal of this Group

This group will develop specifications that define embeddings for different application protocols, such as CoAP, HTTP, and Bluetooth Smart. Such embeddings come with appropriate security considerations. The group will also work on specifications that describe how to deriving keying material for protecting application payloads using JOSE and COSE.

This group will maintain a close relationship with the TLS working group as well as with relevant application and IoT-relevant working groups in the IETF.

# Milestones

May 2018    Adopt "Architecture and Use Case" document as WG item

Jun 2018    Adopt "Application Layer TLS Embedding in HTTP" specification as WG item

Jun 2018    Adopt "Application Layer TLS Embedding in CoAP" specification as WG item

Jun 2018    Adopt "Application Layer TLS Embedding in Bluetooth Smart" specification as WG item

Oct 2018    Submit "Architecture and Use Case" document to the IESG for publication as an Informational Standard.

Nov 2018    Submit "Application Layer TLS Embedding in HTTP" specification to the IESG for publication as an Proposed Standard.

Nov 2018    Submit "Application Layer TLS Embedding in CoAP" specification to the IESG for publication as an Proposed Standard.

Nov 2018    Submit "Application Layer TLS Embedding in Bluetooth Smart" specification to the IESG for publication as an Proposed Standard.

# References:

Currently available proposals include:
- draft-schmertmann-dice-codtls-00
- draft-bhattacharyya-dice-less-on-coap-00
- draft-garcia-core-app-layer-sec-with-dtls-record-00
- draft-friel-tls-atls-00

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 6 Feb 2018 10:48:00 +0100

I still believe Jun 2018 is an impossible target, more so for BLE work. (and it's not "smart" any more). 

Sent from mobile

> On 6. Feb 2018, at 10:08, Hannes Tschofenig <[email-masked]> wrote:
> 
> _______________________________________________
> Atlas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/atlas

---

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 6 Feb 2018 09:49:54 +0000

Hi Carsten,

What would you consider to be realistic targets?

Ciao
Hannes

Btw, my understanding is that the Bluetooth marketing group started initially with the Bluetooth Smart term. Then, they changed it to Bluetooth Low Energy. In the end they changed it back to Bluetooth Smart since devices are not just only focusing on the low energy aspect.

From: Carsten Bormann [mailto:[email-masked]]
Sent: 06 February 2018 10:48
To: Hannes Tschofenig
Cc: [email-masked]
Subject: Re: [Atlas] Charter Text

On 6. Feb 2018, at 10:08, Hannes Tschofenig <[email-masked]<mailto:[email-masked]>> wrote:
Application Transport LAyer Security (ATLAS)
============================================

## Background

## Problem Statement

## Goal of this Group

# Milestones

# References:

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.
_______________________________________________
Atlas mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/atlas
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 6 Feb 2018 14:49:36 +0100

> What would you consider to be realistic targets?

Let’s see.

March — start work
April — get some level of consensus on what we are trying to do (“requirements”), not necessarily in a document, but on the mailing list.
May — create a common straw man to look at, get wider community input
June — flesh out the straw man so it does indeed cover the above objectives
July - spend some time on security analysis, process editorial input
August — WGLC, process WGLC comments
September — ship to IESG.

This is still a bit optimistic (e.g., it assumes: we can draw a straightforward arc from existing drafts such as CoDTLS to the solution we agree upon; we don’t run into major security snafus), but at least it’s not impossible.

(The really hard part will be linking the TLS security properties to the application security objectives; I’m assuming here that we only address the cases where this is trivial and instead leave the interesting cases as an exercise for industry and future incarnations of this WG.)

Grüße, Carsten

> IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you. _______________________________________________
> Atlas mailing list
> [email-masked]

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 6 Feb 2018 15:43:22 +0000

I think HTTP is not something to work on, as HTTPS exists and this will only cause confusion.  Something more applicable might be SNMP or CoAP.

From: Carsten Bormann <[email-masked]>
Date: Tuesday, February 6, 2018 at 4:48 AM
To: Hannes Tschofenig <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [Atlas] Charter Text

## Background

## Problem Statement

## Goal of this Group

# Milestones

# References:

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.
_______________________________________________
Atlas mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/atlas<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_atlas&d=DwMCaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=njNAxyrfzDwrzrtyETvuLKnCTuH_KmwAYxNHvQM_F68&s=fgZeowldfUecrs7gFM2PNjqexSlQKvtnJ2gHYZ8Hhhk&e=>

---

From: "Owen Friel (ofriel)" <[email-masked]>
Date: Tue, 6 Feb 2018 16:26:19 +0000

ATLS over HTTPS is one of the key use cases we are trying to address, specifically for bootstrapping trust in middleboxes, which is a problem we encounter today.

https://tools.ietf.org/html/draft-friel-tls-atls-00#section-3.1

From: Atlas [mailto:[email-masked]] On Behalf Of Salz, Rich
Sent: Tuesday 6 February 2018 15:43
To: Carsten Bormann <[email-masked]>; Hannes Tschofenig <[email-masked]>
Cc: [email-masked]
Subject: Re: [Atlas] Charter Text

From: Carsten Bormann <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, February 6, 2018 at 4:48 AM
To: Hannes Tschofenig <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Atlas] Charter Text

## Background

## Problem Statement

## Goal of this Group

# Milestones

# References:

---

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 6 Feb 2018 16:32:50 +0000

Rich, HTTPS solves different problem than ATLS. I hope the use cases in the most recent draft version make this clearer.

Ciao
Hannes

From: Owen Friel (ofriel) [mailto:[email-masked]]
Sent: 06 February 2018 16:26
To: Salz, Rich; Carsten Bormann; Hannes Tschofenig
Cc: [email-masked]
Subject: RE: [Atlas] Charter Text

From: Atlas [mailto:[email-masked]] On Behalf Of Salz, Rich
Sent: Tuesday 6 February 2018 15:43
To: Carsten Bormann <[email-masked]<mailto:[email-masked]>>; Hannes Tschofenig <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Atlas] Charter Text

## Background

## Problem Statement

## Goal of this Group

# Milestones

# References:

---

From: Phil Hunt <[email-masked]>
Date: Tue, 6 Feb 2018 09:12:07 -0800

For good or bad, gatewaying (UDP-based to IP-based) seems to be a big part of IoT architecture. Having an end-to-end app-layer solution seems like a strong use case.

Phil

Oracle Corporation, Identity Cloud Services Architect
@independentid
www.independentid.com <http://www.independentid.com/>[email-masked] <mailto:[email-masked]>

> On Feb 6, 2018, at 8:26 AM, Owen Friel (ofriel) <[email-masked]> wrote:
> 
> https://tools.ietf.org/html/draft-friel-tls-atls-00#section-3.1 <https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dfriel-2Dtls-2Datls-2D00-23section-2D3.1&d=DwMGaQ&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=mNoVTryfwAw76glrLzdY2boQ-bCd4p9Wa8Udh57pm10&s=RWs5oDEW5er44FUuUXuenwCLEPu3VvTemssVLKLYxFw&e=>
>  
>  
> From: Atlas [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Salz, Rich
> To: Carsten Bormann <[email-masked] <mailto:[email-masked]>>; Hannes Tschofenig <[email-masked] <mailto:[email-masked]>>
> Cc: [email-masked] <mailto:[email-masked]>
> From: Carsten Bormann <[email-masked] <mailto:[email-masked]>>
> To: Hannes Tschofenig <[email-masked] <mailto:[email-masked]>>
> Cc: "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
> On 6. Feb 2018, at 10:08, Hannes Tschofenig <[email-masked] <mailto:[email-masked]>> wrote:
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/atlas <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_atlas&d=DwMCaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=njNAxyrfzDwrzrtyETvuLKnCTuH_KmwAYxNHvQM_F68&s=fgZeowldfUecrs7gFM2PNjqexSlQKvtnJ2gHYZ8Hhhk&e=>_______________________________________________
> Atlas mailing list
> [email-masked] <mailto:[email-masked]>
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_atlas&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=mNoVTryfwAw76glrLzdY2boQ-bCd4p9Wa8Udh57pm10&s=r3eqU9_996MIVpWez-8B-KtrKPbqz1aIdlXB17zDYKw&e= <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_atlas&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=mNoVTryfwAw76glrLzdY2boQ-bCd4p9Wa8Udh57pm10&s=r3eqU9_996MIVpWez-8B-KtrKPbqz1aIdlXB17zDYKw&e=>

---

From: Phil Hunt <[email-masked]>
Date: Tue, 6 Feb 2018 11:18:40 -0800

By  this I am assuming ATLAS over COAP/DTLS gatewayed to HTTP/TLS. 

Phil

> On Feb 6, 2018, at 9:12 AM, Phil Hunt <[email-masked]> wrote:
> 
> www.independentid.com
> [email-masked]
>> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_atlas&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=mNoVTryfwAw76glrLzdY2boQ-bCd4p9Wa8Udh57pm10&s=r3eqU9_996MIVpWez-8B-KtrKPbqz1aIdlXB17zDYKw&e=
> 
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_atlas&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=3EEciKmhOOPIej7eP0FeKE7bCJmy4ShV0Uak-gy8Gjo&s=H4-7IQ5ACW3Cs_V0XA82SsZFd5ugLIk7rNsqqXUxNZk&e=