Subject: [atoca] More progress in the matter of cell broadcast PWS.

From: "'Mark Wood'" <[email-masked]>
Date: Fri, 18 Nov 2011 23:09:05 -0000

Friends,

I have just posted this comment on the ITU discussion list on issues
surrounding the use of cell broadcast for public warning systems. 

The question of how to tackle the issue of transmitting the message in more
than one language is now getting some serious traction. Of course cell
broadcast has its own protocol limitations which may not be relevant in IT
systems, but it is educating to follow their path of reasoning.

Mark wood 

==== quote ====

Friends,

Progress in the development of Cell Broadcast for public warning is moving
very rapidly. There is now updated information as to progress on the matter
of multiple language support. The next edition of the draft (recommendation
| supplement) should, in my view, reflect this. 

My informal information is that in the USA a need has been established to
transmit CMAS alerts in Spanish in Puerto Rico. Accordingly AT&T has
requested ATIS to provide a method for the transmission of public warning
messages in Spanish as a secondary language for the USA CMAS system. 

The proposal is now working its way through the ATIS and 3GPP and is
expected to carry rapidly due to support of almost 10 companies.

The outline of the draft proposal is the following;

     . A range of Message Identifiers (4370-4382) which is assigned for CMAS
in English and in EU-Alert for the local language.

     . A second range (4383-4395) which is copy of the first one is intended
for the additional language(s) defined by the coding scheme.

Messages that need to be displayed unconditionally will be broadcasted in
the first range and messages that are to be displayed conditionally are to
be broadcasted in the second range. The condition is the setting of the
language filter in the UE.

Any comments on this proposal?

Mark

=== unquote ====

Warm regards Mark Wood, DRCF.

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Sat, 19 Nov 2011 20:17:55 +0100

Looking at this in terms of more general language requirements (and reflecting what 3GPP have essentially agreed for cell broadcast alert systems):

1)	The sender categorises the type of message, and certain types of message can be elective (by the receiver) to display or otherwise render) and certain types are not. (Example from CMAS: presidential alerts are not elective and have to be displayed.)

2)	The sender can send in multiple languages. Languages can be mandatory or optional.

3)	Mandatory languages must be displayed to the user. There may be multiple mandatory languages. If the message type is allowed to be elective and turned off, then none of them is received, but if it is turned on all languages are displayed. (Note that in Cell broadcast, the messages are cycled round; we did not insert a requirement to display one first based on language preference in the phone because there was at least one comment that that would lead to a delay in displaying an alert. I suspect in general in cell broadcast there will only be one mandatory language in any cell area.)

4)	Optional languages can be displayed to the user subject to a user settable language filter. There may be multiple optional languages. If the message type is not elective, the language filter will still override the display or rendering. (In general it is assumed there will be at least one mandatory language to be displayed and therefore the user will still receive the non-elective message type in at least one language).

It should be noted that certain languages have multiple character sets. This has not been addressed specifically in Cell Broadcast public warning systems at the moment.

There is no explicit linking of language setting on the phone to the language filters mentioned above. That is not precluded but is up to the phone designer. In general MMI is not specified by 3GPP for cell broadcast systems.

Regards

Keith

________________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of 'Mark Wood'
Sent: 18 November 2011 23:09
To: [email-masked]
Subject: [atoca] More progress in the matter of cell broadcast PWS.

Friends,

I have just posted this comment on the ITU discussion list on issues surrounding the use of cell broadcast for public warning systems. 

The question of how to tackle the issue of transmitting the message in more than one language is now getting some serious traction. Of course cell broadcast has its own protocol limitations which may not be relevant in IT systems, but it is educating to follow their path of reasoning.

Mark wood 

==== quote ====

Friends,

Progress in the development of Cell Broadcast for public warning is moving very rapidly. There is now updated information as to progress on the matter of multiple language support. The next edition of the draft (recommendation | supplement) should, in my view, reflect this. 

My informal information is that in the USA a need has been established to transmit CMAS alerts in Spanish in Puerto Rico. Accordingly AT&T has requested ATIS to provide a method for the transmission of public warning messages in Spanish as a secondary language for the USA CMAS system. 

The proposal is now working its way through the ATIS and 3GPP and is expected to carry rapidly due to support of almost 10 companies.

     . A range of Message Identifiers (4370-4382) which is assigned for CMAS in English and in EU-Alert for the local language.

     . A second range (4383-4395) which is copy of the first one is intended for the additional language(s) defined by the coding scheme.

Messages that need to be displayed unconditionally will be broadcasted in the first range and messages that are to be displayed conditionally are to be broadcasted in the second range. The condition is the setting of the language filter in the UE.

Mark
=== unquote ====