Subject: Re: [atoca] WG adoption for draft-barnes-atoca-cap-mime

From: "Thomson, Martin" <[email-masked]>
Date: Thu, 3 Nov 2011 06:19:46 +0800

There is consensus to adopt this draft.

Once the submission lockout is lifted, the authors are requested to submit an -ietf- version of the draft.  There should be a milestone for it by then.

On 2011-10-19 at 16:05:34, Thomson, Martin wrote:
> This is a call for consensus on the adoption of 
> draft-barnes-atoca-cap- mime by the working group.
> 
> Please express your opinion on the following two points:
> 
>  a) If the work described by draft-barnes-atoca-cap-mime-01 is 
> something that the working group should do
> 
>  b) If draft-barnes-atoca-cap-mime-01 should be adopted by the working 
> group to address that need
> 
> The chairs will make a decision on this on the 2nd of October.

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Thu, 3 Nov 2011 00:32:20 +0100

Making that announcement with no reference to my objection, or even to respond to it, is inappropriate.

I may well take this further.

Regards

Keith

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Thomson, Martin
> Sent: 02 November 2011 22:20
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [atoca] WG adoption for draft-barnes-atoca-cap-mime
> 
> Once the submission lockout is lifted, the authors are requested to submit
> an -ietf- version of the draft.  There should be a milestone for it by
> then.
> 
> _______________________________________________
> atoca mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/atoca

---

From: Hannes Tschofenig <[email-masked]>
Date: Thu, 3 Nov 2011 09:57:44 +0200

I don't think there is any reason to threaten Martin. 
He has followed the process.

---

From: "Thomson, Martin" <[email-masked]>
Date: Fri, 4 Nov 2011 13:06:53 +0800

You raise concerns here more serious than the draft itself.

Regarding the viability of the working group:

If the working group is to stay open, then it needs contributions.  I'll concede that there haven't been many contributions to date, but is there anything in the recent submissions that has changed your mind on this point?

Regarding the draft itself:

It was my impression at least that draft-barnes-atoca-escape was intended to address the 'Addressing security, performance and congestion issues for alert distribution' milestone and that this draft was a direct requirement for that work.

It would also appear to be necessary for draft-rosen-atoca-cap, which, while there seems to be interest, there isn't sufficient interest to keep the draft alive.  I can see how you might draw the conclusion that there isn't interest in picking up pens given the state of this document.

On 2011-10-21 at 00:07:43, DRAGE, Keith (Keith) wrote:
> I don't think this should be a working group item.
> 
> ATOCA has a charter, and the main goals of that charter are currently 
> not being met by any current author deliverables. This deliverable in 
> no way advances that charter, and seems merely an attempt to hang 
> something that may be related on to an existing working group.
> 
> I think ATOCA either has to concentrate on its main charter, or close.
> I strongly suspect the later, seeing as noone seems that interested in 
> picking up the pen and producing stuff within the scope of the charter.
> 
> There is no reason by a mime type cannot progress outside a working 
> group, and indeed, most do.
> 
> Regards
> 
> Keith
[...]

---

From: Robert Sparks <[email-masked]>
Date: Fri, 4 Nov 2011 14:07:25 -0500

There was a rough roadmap sketched out at the Quebec meeting. Could we
get an update of that, including how the recent submissions contribute to it?

RjS

---

From: Brian Rosen <[email-masked]>
Date: Fri, 4 Nov 2011 15:49:06 -0400

I am in favor of moving this forward.  I'm not sure that we know what role SIP should play in the solution, but we DO know what the mime type is going to be used for, and it's a generally useful thing to have.  So, holding off on atoca-cap makes sense, holding off on the mime type doesn't.

Brian

---

From: Richard Barnes <[email-masked]>
Date: Fri, 4 Nov 2011 23:36:50 +0100

Robert,

<hat type="process"/>

A rough outline was sketched in Quebec, then refined in a design team.  The design team presented its thoughts at the ATOCA virtual interim in September.  I was the main presenter, and while I can't find them in any IETF repository, my slides are still on the web here:
<http://geopriv.info/atoca-interim-201109/atoca-design.pdf>

The design that was presented at the virtual interim proposed four documents:
1. Requirements
2. Secure alert format
3. "Distribution protocol" for medium-scale transmission between sources and "relays"
4. "Broadcast protocol" for large-scale transmission to end hosts

After some discussion on the call, this plan was revised to slice the last two documents differently, so we had roughly the following idea of milestones:
1. Requirements
2. Secure alert format
3. "Registration protocol" to allow for contact registration or alert service discovery
4. "Broadcast protocol" for large-scale transmission to end hosts

Hannes, Matt, and I have submitted documents that start to address these goals:
1. draft-ietf-atoca-requirements
2. draft-barnes-atoca-escape
3. draft-barnes-atoca-meta
4. draft-barnes-atoca-delivery

Returning to the topic at hand, draft-barnes-atoca-cap-mime is at the bottom of the dependency tree.  -delivery transmits alerts in the format of -escape, which comprises a MIME encoding of a CAP document.  So the idea was to go ahead and register the CAP media type so that that could be ready while we discuss the other things.  

<hat type="personal"/>

Plus, at the time, it seemed like a non-controversial idea :)  I don't think there's any disagreement in the group that CAP will be the basis for our alerts, and that we'll probably need MIME content negotiation, so creating a MIME type seems like a no-brainer to me.

--Richard

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Sat, 5 Nov 2011 01:00:51 +0100

Those concerns are incidental to the comment.

My comment is that working groups should focus on the tasks they are chartered to do.

If that task on which the working group is focussed happens to need a MIME type, then the working group should do it.

Otherwise the working group should not do that work but should leave it to one of the other submission routes, where it will probably get better and more effective review by the IETF community, than it would in a working group where it becomes at best a peripheral activity. For example on the other submission routes it would get a full 4 week IETF last call, whereas coming from a working group it would only get a two week IETF last call.

Yes one of those chartered items of ATOCA was to do some cap related work which could well use this MIME type. But at the moment I detect no focus of the working group in moving that work forward, and indeed the authors stated intent of separating it out was because the work it was embedded in was not succeeding in becoming work on which the working group was focussing. You as chairs put this work forward for a separate adoption presumably because you also considered it was currently impossible to move forward with the main CAP work.

As a result it fails to meet the criteria I have expressed above.

(At no point have I said that this document should not go forward, merely that putting it as a chartered item in this working group is not appropriate)

Please treat other comments about lack of focus in this working group on any work at all as an aside to the specific points I am making above, and which I had hoped I had made in my first mail.

Regards

Keith

> From: Thomson, Martin [mailto:[email-masked]] 
> Sent: 04 November 2011 05:07
> To: DRAGE, Keith (Keith); [email-masked]
> Subject: WG and draft-barnes-atoca-cap-mime
> 
> If the working group is to stay open, then it needs 
> contributions.  I'll concede that there haven't been many 
> contributions to date, but is there anything in the recent 
> submissions that has changed your mind on this point?
> 
> It was my impression at least that draft-barnes-atoca-escape 
> was intended to address the 'Addressing security, performance 
> and congestion issues for alert distribution' milestone and 
> that this draft was a direct requirement for that work.
> 
> It would also appear to be necessary for 
> draft-rosen-atoca-cap, which, while there seems to be 
> interest, there isn't sufficient interest to keep the draft 
> alive.  I can see how you might draw the conclusion that 
> there isn't interest in picking up pens given the state of 
> this document.
> 
>

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Sun, 6 Nov 2011 17:43:25 +0100

There were no threats here.

And as to the process being follows. Well all we have seen is the announcement from the chair. No rationale. No reasoning. No report of informal responses received outside the mailing list.

On the evidence we have on the mailing list it seems to have been taken more as a vote than a concensus building discussion. There is a distinction between consensus and rough consensus, and this certainly doesn't seem to have received consensus.

Luckily, the WG chairs now have to justify their position to the ADs, as the AD has to sign off any new charter item. I hope they are able to.

Regards

Keith

> From: Hannes Tschofenig [mailto:[email-masked]] 
> Sent: 03 November 2011 07:58
> To: DRAGE, Keith (Keith)
> Cc: Hannes Tschofenig; Thomson, Martin; [email-masked]; 
> [email-masked]
> Subject: Re: WG adoption for draft-barnes-atoca-cap-mime
> 
> > Making that announcement with no reference to my objection, 
> or even to respond to it, is inappropriate.
> > 
> >> From: [email-masked] [mailto:[email-masked]] On 
> >> Behalf Of Thomson, Martin
> >> Once the submission lockout is lifted, the authors are 
> requested to 
> >> submit an -ietf- version of the draft.  There should be a 
> milestone 
> >> for it by then.
> >> 
> >>> b) If draft-barnes-atoca-cap-mime-01 should be adopted by the 
> >>> working group to address that need
> >>>

---

From: "James M. Polk" <[email-masked]>
Date: Mon, 07 Nov 2011 13:38:19 -0600

I tend to agree with Keith here. The process rules haven't been 
followed within this WG on a number of issues, namely WG adoption of 
documents (now and with atoca-cap). I don't fully understand why 
atoca-cap isn't moving forward within this WG, even if its author is 
willing to put it on the back burner. The WG has this item as a 
chartered item, yet the WG isn't really working towards fulfilling 
that charter item, yet now wants to adopt another unchartered item. 
That isn't (close to being) right as far as how WGs should work.

IMO in order for draft-barnes-atoca-cap-mime to be adopted as a WG 
item, the WG requires rechartering first, or perhaps closed for a 
time. As it doesn't seem as if the WG wants to really work on the 
tasks at hand, rather it seems to give in to the (very) few who are 
willing to do anything and call that consensus.

That last sentence is sarcasm, however it does have a ring of truth 
to it... sad to say.

Regardless, this WG can't say they have "strong consensus" about 
anything, because not enough are participating (hence the comment 
about "perhaps the WG should close for a time").

James

At 10:43 AM 11/6/2011, DRAGE, Keith (Keith) wrote:
>And as to the process being follows. Well all we have seen is the 
>announcement from the chair. No rationale. No reasoning. No report 
>of informal responses received outside the mailing list.
>
>On the evidence we have on the mailing list it seems to have been 
>taken more as a vote than a concensus building discussion. There is 
>a distinction between consensus and rough consensus, and this 
>certainly doesn't seem to have received consensus.
>
>Luckily, the WG chairs now have to justify their position to the 
>ADs, as the AD has to sign off any new charter item. I hope they are able to.
>
>Regards
>
>Keith
>

---

From: Brian Rosen <[email-masked]>
Date: Mon, 7 Nov 2011 15:46:51 -0500

I don't agree.  We have a small group of people doing work, perhaps not at the speed you want, but they are producing ideas and documents that move the ball forward.  There are comments from a somewhat larger group that are helping.  That is pretty normal.  The pace is not so good.  

In this case, we have a fairly clear vision on parts of the problem, and more fuzzy ideas on others.  One thing we're all clear on is the need for the MIME type.

Brian

On Nov 7, 2011, at 2:38 PM, James M. Polk wrote:

> I tend to agree with Keith here. The process rules haven't been followed within this WG on a number of issues, namely WG adoption of documents (now and with atoca-cap). I don't fully understand why atoca-cap isn't moving forward within this WG, even if its author is willing to put it on the back burner. The WG has this item as a chartered item, yet the WG isn't really working towards fulfilling that charter item, yet now wants to adopt another unchartered item. That isn't (close to being) right as far as how WGs should work.
> 
> IMO in order for draft-barnes-atoca-cap-mime to be adopted as a WG item, the WG requires rechartering first, or perhaps closed for a time. As it doesn't seem as if the WG wants to really work on the tasks at hand, rather it seems to give in to the (very) few who are willing to do anything and call that consensus.
> 
> That last sentence is sarcasm, however it does have a ring of truth to it... sad to say.
> 
> Regardless, this WG can't say they have "strong consensus" about anything, because not enough are participating (hence the comment about "perhaps the WG should close for a time").
> 
> James
>