Subject: [atoca] Discovery mechanism

From: "Richard L. Barnes" <[email-masked]>
Date: Fri, 30 Mar 2012 13:32:40 +0200

Hey all,

As I said in the meeting today, I've put together a proposed mechanism 
for discovering alert servers.  Much like Brian said today, it's based 
on HTTP, but can bootstrap out of DHCP and/or LoST.

Alert Metadata Protocol (AMP)
<http://tools.ietf.org/html/draft-barnes-atoca-meta-01>

Reviews welcome!

Thanks,
--Richard

---

From: Art Botterell <[email-masked]>
Date: Fri, 30 Mar 2012 10:40:20 -0700

This strikes me as a very worthwhile project.  A couple of quick notes:

1) Might the definitions section include a definition for an "alert source"?  If only to disambiguate between the function of the AMP server and an actual alert "feed" or whatever?

2) If I'm reading this correctly it seems like all we're attempting so far is to get from a general domain to a specific alert source URL.  Useful, I suppose... although it seems much the same thing could be achieved by conventionalizing a prefix like "alerts." (on the pattern of "www." for http servers... but why stop there?  Wouldn't it be useful to enable folks to discover alert sources serving a geospatial location or polygon?  And/or sources that provide certain types of information, as per the CAP "category" element?

3) Does the proposed discovery mechanism provide information as to the specific protocol, access controls, etc. implemented by a particular alert source?  E.g., many of the interfaces are ATOM or RSS feeds, but some are in the form of various styles of web service queries.

4) I'm confused a bit... and maybe this is related to #3... by the inclusion of the Alert type message.  Is it intended that the discovery system also serve as a pub/sub broker for actual alerts?  Seems like that's a bit of a drift from the core... and IMHO, crucial... function of alert source discovery.  And possibly a bit of an overlap with what Google's doing at http://alert-hub.appspot.com/ ?

Apologies if I'm asking anything too ignorant here.  Again, I think the basic question of discovery mechanisms is really important.

- Art

On Mar 30, 2012, at 4:32 AM, Richard L. Barnes wrote:

> Hey all,
> 
> As I said in the meeting today, I've put together a proposed mechanism for discovering alert servers.  Much like Brian said today, it's based on HTTP, but can bootstrap out of DHCP and/or LoST.
> 
> _______________________________________________
> atoca mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/atoca