Subject: Re: 15 Minute Counts and Continuous Counts

From: Ken Chapman <[email-masked]>
Date: Fri, 29 Jan 1999 15:33:01 -0500

At 04:29 PM 1/29/99 +0000, Kaj Tesink wrote:
>Hi,
>
>During the Last Call process on the DS1/E1, DS3/E3 and SONET/SDH MIB I-Ds
>a comment was reiterated on whether the statistics in these MIBs can be
>represented through Counter32s (continuous counts).
>They are now all Gauge32s based on 15 minute measurements. 
>While recognizing that these MIBs have historically used the
>15 minute bucket approach the question was asked whether additional work
>on supplemental MIB(s) would be merited  that would use Counter32s.
>
>The purpose of this message is to sollicit views on this issue.
>In particular:
>a) whether Supplemental MIB modules should support Counter32 statistics

Yes

>b) if the answer to a) would be yes, whether the conformance statement
>   should mandate
>   i) both approaches
>   ii) either one of the approaches

ii

One further thought:  We should define a "generic" MIB for interval "gauges"
that allows different intervals (e.g. 24 hours).  It would then be able to
provide interval histories for ANY well defined counter.
Perhaps someone has already done some work on such a MIB?
================================================
Ken Chapman                 Argon Networks, Inc.
tel: +1-978-486-0665 x146   25 Porter Road
fax: +1-978-486-9379        Littleton, MA  01460
mailto:[email-masked]   http://www.Argon.com
================================================

---

From: Keith McCloghrie <[email-masked]>
Date: Fri, 29 Jan 1999 18:11:56 -0800 (PST)

> Perhaps someone has already done some work on such a MIB?

See the usrHistoryGroup in RFC 2021.

Keith.