Subject: Soft-PVC establishment

From: Italo Busi <[email-masked]>
Date: Tue, 12 Jan 1999 09:04:59 +0100

Hi all,

I would like to ask you something about soft-PVC establishment procedure.

Reading the documentation (documents [1], [2], [3] and [4]) I have understood that soft-PVC establishment requires different procedures in the intermediate switches, in the originating switch and in the destination switch.
We can consider for example the establishment of a soft-PVCC; the soft-PVPC case is analogous.

1) Intermediate Switch

                      ----------------
		      |              |
	      NNI     | Intermediate |     NNI
	O-------------|              |-------------O
             I/f a    |    Switch    |    I/f b
                      |              | 
                      ----------------

	Figure 1: An intermediate switch of the soft-PVC

Interfaces a and b are both NNI, as shown in Figure 1. We assume that the setup message comes in at I/f a and goes out at I/f b.
According to documents [1] and [2] at least two tables have to be configured:
- the VCL Table, to configure the VCLa in the i/f a and the VCLb in the i/f b
- the SVCC Table, to configure the switched cross-connection between VCLa and VCLb.
VCLa, VCLb and the cross-connection are configured by the switch itself during the call set-up process.
	VCLa is configured as "svcIncoming"
	VCLb is configured as "svcOutgoing"

2) Originating Switch

                      ----------------
		      |              |
	      UNI     | Originating  |     NNI
	O-------------|              |-------------O
             I/f a    |    Switch    |    I/f b
                      |              | 
                      ----------------

	Figure 2: Originating switch of the soft-PVC

Interface a (the calling endpoint) is UNI and interface b is NNI, as shown in Figure 2.
According to documents [1], [2] and [4] at least three tables have to be configured:
- the VCL table, to configure the VCLa and the VCLb
- the SVCC table, to configure the switched cross-connection;
- the soft-PVCC table, to configure the soft-PVC parameters (destination i/f ATM address, VPI/VCI at the destination UNI, ...)
The Network Manager (NM) configures the VCLa (in the VCL table) and the soft-PVC (in the soft-PVCC table). The switch by its own configures the VCLb (in the VCL table) and the cross-connection (in the SVCC table) during the setup procedures.
	VCLa is configured as "spvcInitiator"
	VCLb is configured as "svcOutgoing"

3) Destination Switch

                      ----------------
		      |              |
	      NNI     | Destination  |     UNI
	O-------------|              |-------------O
             I/f a    |    Switch    |    I/f b
                      |              | 
                      ----------------

	Figure 3: Destination switch of the soft-PVC

Interface a is NNI and interface b (the called endpoint) is UNI, as shown in Figure 3.
According to documents [1] and [2] at least two tables are needed:
- the VCL table
- the SVCC table
We are sure that the switch on its own configures the VCLa (in the VCL table) and the cross-connection (in the SVCC table) during the setup procedure.
	VCLa is configured as "svcIncoming"
	VCLb is configured as "spvcTarget"

It is not clear from the documentation WHO HAS TO CONFIGURE VCLb:  the switch or the NM ?
The NM has to send some kind of information to the destination switch in order to establish a soft-PVC ?

References:

[1] K. Tesink, "Definitions of Managed Objects for ATM Management"
    internet-draft (to replace RFC1695), draft-ietf-atommib-atm1ng-06
[2] F. Ly, "Definitions of Supplemental Managed Objects for ATM Management"
    internet-draft, draft-ietf-atommib-atm2-12
[3] ATM Forum, "PNNI 1.0", annex C "Soft-PVC Connection Procedures"
    af-pnni-0055.000
[4] ATM-Forum, "Soft-PVC MIB"
    af-pnni-0066.000 and the errata in the af-pnni-0081.000

Best Regards, Italo.

-----------------------------------------------------------------

 ----------------------   
 \                    /   Busi Italo
  \                  /    ALCATEL - TSD R&D
   \                /     ADM System Group
    \              /      
     \            /       E-mail: [email-masked]
      \          /        Tel. +39 039 686.9132
       \        /         Fax. +39 039 686.3590
        \      /          
         \    /           Date 01/12/1999
          \  /            Time 08:40:05
           \/

-----------------------------------------------------------------

---

From: Mickey Spiegel <[email-masked]>
Date: Tue, 12 Jan 1999 10:33:55 -0800

Italo,

See replies at the bottom.

> We can consider for example the establishment of a soft-PVCC; the soft-PVPC case is analogous.

[3] allows both behaviors.  You can support either one or both.  If
it is done via NM beforehand, use [1] to create the connection leg
and set the atmVclConnKind to spvcTarget.

> The NM has to send some kind of information to the destination switch in order to establish a soft-PVC ?

or it can be done automatically.

>     af-pnni-0066.000 and the errata in the af-pnni-0081.000

Mickey Spiegel