Subject: ATM address representation in ATM standard MIB

From: [email-masked]
Date: Tue, 27 Jul 1999 09:54:43 +0300

Hello ,

I have a question regrading the representation of an ATM address in the ATM MIB
(AtmAddr textual convention).

RFC 2514 states that the address semantics (E164 , NSAP etc.) are implied by the
octet string length.

My question is - how is the string  length determined ?
which character is used for marking the end of the string containg the address ?

Thanks,

Gil Bialik - System Engineer
ECI Telecom
[email-masked]

---

From: "C. M. Heard/VVNET, Inc." <[email-masked]>
Date: Tue, 27 Jul 1999 01:12:48 -0700 (PDT)

On Tue, 27 Jul 1999 [email-masked] wrote:

> Hello ,
> 
> I have a question regrading the representation of an ATM address in the
> ATM MIB (AtmAddr textual convention).
> 
> RFC 2514 states that the address semantics (E164 , NSAP etc.) are implied
> by the octet string length.
> 

The length is explicit.

Octet strings (like all SNMP object objects) are transmitted using the
type-length-value encoding defined in ISO 8825-1987 or ITU-T X.208-1988.

/cmh