Subject: RE: MIB usage for Tandem Connection Monitoring (G.707)

From: "Huynh, An-Ni (Anni)" <[email-masked]>
Date: Wed, 25 Apr 2001 16:03:25 -0400

Hi.
You can access the G.709 via this web page.
ftp://47.234.32.16/itu_to_ietf/SG15
the file name is g709-102.pdf
-------
I am the editor of the opticalMib draft.  At the ietf 50th meeting, 
I proposed how to model the TCM link for the optical interface.  
I extract the textand append it at the end this message.  The powerpoint
presentation file should be available at the proceeding.
Let me know if you want to receive a copy of that file.

----- Begin proposal (This is not the complete MIB table,
it is for illustrating how the MIB table be structured.)

otnODUkTConfigTable OBJECT-TYPE
    SYNTAX      SEQUENCE OF OtnODUkTConfigEntry  
    MAX-ACCESS  not-accessible
    STATUS      current
    DESCRIPTION
       "The list of OTN ODUkT interface entries."
     ::= { otnODUkT 1 } 

otnODUkTConfigEntry OBJECT-TYPE
    SYNTAX        OtnODUkTConfigEntry  
    MAX-ACCESS    not-accessible
    STATUS        current
    DESCRIPTION
       "An entry in the otnODUkTConfig table."
    INDEX   { ifIndex }
     ::= { otnODUkTConfigTable 1 }

OtnODUkTConfigEntry ::=
    SEQUENCE {
        
        otnODUkTLockSignalAdminStateSource  INTEGER,
        otnODUkTLockSignalAdminStateSink    INTEGER       
        }                               

otnODUkTTcmSinkTable OBJECT-TYPE
	    SYNTAX      SEQUENCE OF OtnODUkTTcmSinkEntry
	    MAX-ACCESS  not-accessible
	    STATUS      current
	    DESCRIPTION
	       "The list of OTN ODUkT interface entries."
	     ::= { otnODUkT 2 }
	-- The table is indexed by ifIndex, tcmId 
	....<snip>....
OtnODUkTcmSinkEntry ::=
	  SEQUENCE {
	        otnODUkTTcmId
Unsigned32,
	       otnODUkTTraceIdentifierAccepted               OctetString,
	       otnODUkTTraceIdentifierExpected               OctetString,
	        otnODUkTTimDetDisabled
TruthValue,
	        otnODUkTTimActDisabled
TruthValue, 
	        otnODUkTSinkCurrentStatus                        INTEGER,

	        otnODUkTSinkMode
INTEGER
	       } 

otnODUkTTcmSourceTable OBJECT-TYPE
	    SYNTAX      SEQUENCE OF OtnODUkTTcmSourceEntry
	    MAX-ACCESS  not-accessible
	    STATUS      current
	    DESCRIPTION
	       "The list of OTN ODUkT interface entries."
	     ::= { otnODUkT 3 }
	-- The table is indexed by ifIndex, tcmId 
	....<snip>....
OtnODUkTcmSourceEntry ::= 
	    SEQUENCE {
	      otnODUkTTraceIdentifierTransmitted            OctetString, 
	       otnODUkTSourceMode                                   INTEGER 
	      }

----End of proposal

Regards,
Anni

> ----------
> From: 	Dave Danenberg[SMTP:[email-masked]]
> Sent: 	Wednesday, April 25, 2001 2:51 PM
> To: 	AToM MIB
> Subject: 	MIB usage for Tandem Connection Monitoring (G.707)
> 
> Hello,
> 
> I was hoping someone could help me here. First of all, I was looking
> around the IETF web site for your email archive - where is it?
> 
> What I'm ultimately trying to find out is how to model a Tandem
> Connection Monitoring (TCM) link in a MIB. The TCM option I'm interested
> in is specified in G.707 Annex C.
> 
> I've looked at RFC 2558, and the objects in the SONET Path Tables are
> pretty much what I want. Are these the objects that you folks recommend
> using for TCM? If so, how is the tandem connection's ifIndex used in the
> interface stack?
> 
> Or - instead of trying to reuse the Path Tables in RFC 2558, is there
> another MIB designed more specifically for TCMs?
> 
> In draft-stewart-atommib-opticalmib-02, I saw a reference to "Optical
> Channel Data Unit Tandem Connection Sub-Layer Network (ODUkT) - G.709".
> By way of Stewart's references, this does not seem to be the same thing
> as G.707 Tandem Connection Monitoring. I tried to look at G.709, but ITU
> says it is not published yet.
> 
> Any help out there?
> Thanks,
> Dave Danenberg
> 
> Litchfield Communications Inc.
> www.litchfieldcomm.com
> 
> Princeton Building East
> 76 Westbury Park Rd
> Watertown CT 06795 USA
> 
> Tel: (860) 945 1573 x3180
> Fax: (860) 945 1578
>

---

From: "Dave Danenberg" <[email-masked]>
Date: Wed, 25 Apr 2001 16:27:22 -0400

Anni,

Thanks so much for your response. I have seen your slides and looked
through the MIB. From what I can see, the TCM you refer to is not the
same as the TCM in G.707 (though it could be so abstracted I don't
recognize it). Are you familiar with G.707 Annex C? It is based on using
the N1 byte in the Path overhead to manage the SONET path through
intermediate nodes. Btw, within G.707 there 2 other types of TCM (see
Annexes D and E). Each accomplishes the same things (more or less), but
with different mechanisms.

For your convenience here is an excerpt from Annex C...

The Tandem Connection sub-layer is an optional sub-layer which falls
between the multiplex section and path layers defined in this
Recommendation. This overhead sub-layer deals with the reliable
transport of path layer payload and its overhead across a network. It is
expected that the principal applications for Tandem Connection will be
in the inter-office network and that Tandem Connections will generally
not be used in applications such as the subscriber access network.

The N1 byte in the path overhead in each HOVC of the Tandem Connection
is defined as Tandem Connection Overhead (TCOH). Bits 1-4 of this byte
in each HOVC of the Tandem Connection are used to provide a Tandem
Connection Incoming Error Count (IEC), which is defined below. The
remaining four bits in byte N1 of the first VC-n within the Tandem
Connection are used to provide
an end to end data link.

--Dave

-----Original Message-----
From: Huynh, An-Ni (Anni) [mailto:[email-masked]]
Sent: Wednesday, April 25, 2001 4:03 PM
To: AToM MIB; Dave Danenberg
Subject: RE: MIB usage for Tandem Connection Monitoring (G.707)

Hi.

OtnODUkTConfigEntry ::=
    SEQUENCE {

otnODUkTTcmSinkTable OBJECT-TYPE
	    SYNTAX      SEQUENCE OF OtnODUkTTcmSinkEntry
	    MAX-ACCESS  not-accessible
	    STATUS      current
	    DESCRIPTION
	       "The list of OTN ODUkT interface entries."
	     ::= { otnODUkT 2 }
	-- The table is indexed by ifIndex, tcmId 
	....<snip>....
OtnODUkTcmSinkEntry ::=
	  SEQUENCE {
	        otnODUkTTcmId
Unsigned32,
	       otnODUkTTraceIdentifierAccepted
OctetString,
	       otnODUkTTraceIdentifierExpected
OctetString,
	        otnODUkTTimDetDisabled
TruthValue,
	        otnODUkTTimActDisabled
TruthValue, 
	        otnODUkTSinkCurrentStatus
INTEGER,

	        otnODUkTSinkMode
INTEGER
	       } 

	       otnODUkTSourceMode
INTEGER 
	      }

----End of proposal

Regards,
Anni

---

From: "Huynh, An-Ni (Anni)" <[email-masked]>
Date: Thu, 26 Apr 2001 11:48:38 -0400

Dave:

The TCM table in the opticalMib is for OTN system based on G.709.
I don't think it is applicable for TCM for SONET/SDH (G.707).

The major difference between SONET TCM and OTN TCM is
*	SONET/SDH TCM is to monitor a localized portion of a Path.  No
nested or overlap TCM
allowed.  There is only one level of Tandem connection defined at any TCM
termination.
*	OTN TCM allows up to 6 levels of tandem connections. (see one of
slide in the ppt.)
These tandem connections can be concatenated, nested (maybe overlap, tbd).

I have not gotten time to look at the RFC2558, if the objects in the SONET
Path meet
your needs.  But I don't think it is applicable for OTN TCM.
 
Regards,

Anni

> Sent: 	Wednesday, April 25, 2001 4:27 PM
> To: 	Huynh, An-Ni (Anni)
> Cc: 	AToM MIB

---

From: "Dave Danenberg" <[email-masked]>
Date: Thu, 26 Apr 2001 19:21:56 -0400

Anni/Leen,

OK - so is there any hope for me?  :)
That is, has anyone used RFC 2558 for G.707 SONET Path TCM? If so, how
is the ifStack constructed? If not, is there another MIB someplace that
handles G.707 TCM?

G.707 has been around since 1996, I would have thought that someone
besides me has run into this. Otherwise, I'll come up with something. :P

Thanx for your considerations - so far.

--Dave

-----Original Message-----
From: Huynh, An-Ni (Anni) [mailto:[email-masked]]
Sent: Thursday, April 26, 2001 11:50 AM
To: Mak, L (Leen)
Cc: Dave Danenberg
Subject: RE: MIB usage for Tandem Connection Monitoring (G.707)

Leen:
I agree.

Anni

> ----------
> From: 	Mak, L (Leen)
> Sent: 	Thursday, April 26, 2001 3:40 AM
> To: 	Huynh, An-Ni (Anni)
> Cc: 	'Dave Danenberg'; Mak, L (Leen)
> Dave is right: STM TCM (G.707) is really different 
> from OTN TCM (G.709). If he needs a MIB for STM
> TCM, I think an OTN TCM MIB cannot be used as is.
> But as I am not an MIB expert I leave it to you to judge 
> that.
> 
> Leen.
> 
> > From: Dave Danenberg [mailto:[email-masked]]
> > Sent: Wednesday, April 25, 2001 22:27
> > To: Huynh, An-Ni (Anni)
> > Cc: AToM MIB
> > > using for TCM? If so, how is the tandem connection's ifIndex used
in
> > the
> > > as G.707 Tandem Connection Monitoring. I tried to look at G.709,
but
> > ITU