Subject: Re: DS1 and DS3 MIB bugs (Fwd)

From: David Fowler <[email-masked]>
Date: Wed, 13 Jun 2001 23:48:24 -0400

Since I've agreed to edit again, I can collect things.  I'm only aware of a
couple things at the moment, but I will take this one and others people send.
I'll post a summary prior to submitting new drafts.

Regards,
David

Erik Nordmark wrote:

> Is there somebody collecting a list of work for these MIBs?
>
>   Erik
>
> >----------------Begin Forwarded Message----------------<
>
> Date: Tue, 8 May 2001 09:33:30 -0400
> From: "Chapman, Ken" <[email-masked]>
> Subject: DS1 and DS3 MIB bugs
> To: "'Thomas Narten'" <[email-masked]>, "'Erik Nordmark'"
> <[email-masked]> Cc: [email-masked]
>
> Who do I report this bug to?
> In both the DS1 and the DS3 MIBs, the dsx1FracIfIndex/dsx3FracIfIndex have a
> SYNTAX of INTEGER (1..'7fffffff'h);
> however, the DESCRIPTIONs state "If no interface is currently using a
> channel, the value should be zero."
> So, the SYNTAX should be INTEGER (0..'7fffffff'h).
>
> This should be fixed before the MIBs are elevated to Draft Standard.
>         Ken
>
> ++++++++++++++++++++++++++++++++++++++++++++++
> Ken Chapman           Unisphere Networks, Inc.
> Tel: +1-978-589-0288  10 Technology Park Drive
> Fax: +1-978-589-0800  Westford, MA 01886
> Email: [email-masked]
> ++++++++++++++++++++++++++++++++++++++++++++++
>
> >----------------End Forwarded Message----------------<

---

From: Subrahmanya Hegde <[email-masked]>
Date: Thu, 14 Jun 2001 10:55:40 -0700

David
I have following requests.

1. If possible, we would like to have following enums in dsx3LineType object

    ds3cbitadm
    ds3cbitplcp
    e3g832adm
    e3g751adm
    e3g751plcp
    ds3m23adm
    ds3m23plcp

2. If possible, would like to have following object

    dsx3InternalEqualizer OBJECT-TYPE
     SYNTAX  INTEGER {
                 use(1),
                 byPass(2)
             }
     MAX-ACCESS  read-write
     STATUS  current
     DESCRIPTION
        "This variable indicates whether the internal equalizer is being
         used or bypassed. Set this value depending on the line equipment
         to which the receiver is attached.
         Possible values are :

          use(1)      : Use the internal equalizer
          byPass(2)   : bypass internal equalizer(use external equalizer).
                        This option allows easy interfacing of the
                        device into systems already utilizing the external
                        equalizers."
     DEFVAL { use }

Thanks
Subra

---

From: "Brian Teer" <[email-masked]>
Date: Thu, 14 Jun 2001 15:24:45 -0400

With respect to the proposed dsx3InternalEqualizer object, isn't use of the
DEFVAL clause restricted to objects with MAX-ACCESS of read-create?

Brian

> -----Original Message-----
> From: Subrahmanya Hegde [mailto:[email-masked]]
> Sent: Thursday, June 14, 2001 1:56 PM
> To: David Fowler
> Cc: Erik Nordmark; [email-masked]; subrah
> Subject: Re: DS1 and DS3 MIB bugs (Fwd)
>
>
> David

---

From: Subrahmanya Hegde <[email-masked]>
Date: Thu, 14 Jun 2001 13:25:48 -0700

Brian
  Thanks for clarifying it. You are right.

Subra