Subject: Call for implementation experience on RFC 2558: SONET MIB

From: "Faye Ly" <[email-masked]>
Date: Wed, 12 Sep 2001 11:31:01 -0700

Hi,

The chairs of the AToMMIB working group would like to issue another
implementation experience call on RFC 2558: SONET/SDH MIB.

We didn't receive any report from the last call and your help will
be greatly appreciated.  Please repond to [email-masked] or
directly to the list.

We are specically looking for:

1. Have you implemented RFC 2558/1595?
2. If yes, what is the implemented objects/tables compared to the
attached compliance statements? 
3. Are you willing to publish the name of your company in the
implementation experience report?

Again thank you very much for your help in advancing the RFC to
the Draft Standard.

sonetCompliance2 MODULE-COMPLIANCE
    STATUS  current
    DESCRIPTION
            "The compliance statement for SONET/SDH interfaces."

    MODULE  -- this module
        MANDATORY-GROUPS { sonetMediumStuff2, sonetSectionStuff2 }

        OBJECT      sonetMediumType
        MIN-ACCESS  read-only
        DESCRIPTION
            "Write access is not required."

        OBJECT      sonetMediumLineCoding
        MIN-ACCESS  read-only
        DESCRIPTION
            "Write access is not required."

        OBJECT      sonetMediumLineType
        MIN-ACCESS  read-only
        DESCRIPTION
            "Write access is not required."

        OBJECT      sonetMediumCircuitIdentifier
        MIN-ACCESS  read-only
        DESCRIPTION
            "Write access is not required."

        OBJECT      sonetMediumLoopbackConfig
        MIN-ACCESS  read-only
        DESCRIPTION
            "Write access is not required."

        OBJECT      sonetSESthresholdSet
        MIN-ACCESS  read-only
        DESCRIPTION
          "Write access is not required, and only one
          of the enumerated values need be supported."

        GROUP       sonetLineStuff2
        DESCRIPTION
            "Implementation of this group is mandatory for all
             SONET/SDH systems that terminate SONET/SDH Lines,
             Paths or Virtual Tributaries."

        GROUP       sonetFarEndLineStuff2
        DESCRIPTION
            "Implementation of this group is optional for all
             SONET/SDH systems that terminate SONET/SDH Lines,
             Paths or Virtual Tributaries, and that
             provide for a far end block error (FEBE)
             information at the SONET/SDH Line Layer."

        GROUP       sonetPathStuff2
        DESCRIPTION
            "Implementation of this group is mandatory for all
             SONET/SDH systems that terminate SONET/SDH
             Paths or Virtual Tributaries."

        OBJECT      sonetPathCurrentWidth
        MIN-ACCESS  read-only
        DESCRIPTION
            "Write access is not required."

        GROUP       sonetFarEndPathStuff2
        DESCRIPTION
            "Implementation of this group is optional for all
             SONET/SDH systems that terminate SONET/SDH
             Paths or Virtual Tributaries, and that process
             Far End information."

        GROUP       sonetVTStuff2
        DESCRIPTION
            "Implementation of this group is mandatory for all
             SONET/SDH systems that terminate SONET/SDH Virtual
             Tributaries."

Tesink                      Standards Track                    [Page 58]

RFC 2558                   SONET/SDH Objects                  March 1999

        OBJECT      sonetVTCurrentWidth
        MIN-ACCESS  read-only
        DESCRIPTION
            "Write access is not required."

        GROUP       sonetFarEndVTStuff2
        DESCRIPTION
            "Implementation of this group is optional for all
             SONET/SDH systems that terminate the SONET/SDH
             floating Virtual Tributaries, and that process
             Far End information."

    ::= { sonetCompliances 2 }

Faye Ly
Senior System Architect
Salira Optical Network Systems
2698 Orchard Parkway
San Jose, CA 95134
(408)325-8700 X116

---

From: Subrahmanya Hegde <[email-masked]>
Date: Wed, 12 Sep 2001 18:57:38 -0700

Faye

This is for the ATM Edge Switches from Cisco

A. Implemented RFC 2558

Sure.

    MODULE  -- this module

        OBJECT      sonetMediumType
        MIN-ACCESS  read-only
        DESCRIPTION

A.   We do support 'read-write

Write is not supported for the following:

Following Groups supported:

        GROUP       sonetLineStuff2
     GROUP       sonetPathStuff2

Groups Not Supported:

        GROUP       sonetVTStuff2

Thanks
Subra