Subject: RFC 2558 Implementation Report

From: "Faye Ly" <[email-masked]>
Date: Fri, 15 Feb 2002 10:21:58 -0800

Please see attached.  Please also note that there are
a few groups listed by both implementations as NOT
IMPLEMENTED and they are subject to be dropped from
the MIB.  If you have implemented these groups, please
forward your implementation to me.  Your help will be
greatly appreciated.  When submitting your implementation,
please fill out the following -

1. Have you implemented RFC 2558/1595?
2. If yes, what is the implemented objects/tables compared to the
attached compliance statements?
3. Are you willing to publish the name of your company in the
implementation experience report?

Again thank you very much for your help in advancing the RFC to
the Draft Standard.

sonetCompliance2 MODULE-COMPLIANCE
    STATUS  current
    DESCRIPTION
            "The compliance statement for SONET/SDH interfaces."

    MODULE  -- this module
        MANDATORY-GROUPS { sonetMediumStuff2, sonetSectionStuff2 }

        OBJECT      sonetMediumType
        MIN-ACCESS  read-only
        DESCRIPTION
            "Write access is not required."

        OBJECT      sonetMediumLineCoding
        MIN-ACCESS  read-only
        DESCRIPTION
            "Write access is not required."

        OBJECT      sonetMediumLineType
        MIN-ACCESS  read-only
        DESCRIPTION
            "Write access is not required."

        OBJECT      sonetMediumCircuitIdentifier
        MIN-ACCESS  read-only
        DESCRIPTION
            "Write access is not required."

        OBJECT      sonetMediumLoopbackConfig
        MIN-ACCESS  read-only
        DESCRIPTION
            "Write access is not required."

        OBJECT      sonetSESthresholdSet
        MIN-ACCESS  read-only
        DESCRIPTION
          "Write access is not required, and only one
          of the enumerated values need be supported."

        GROUP       sonetLineStuff2
        DESCRIPTION
            "Implementation of this group is mandatory for all
             SONET/SDH systems that terminate SONET/SDH Lines,
             Paths or Virtual Tributaries."

        GROUP       sonetFarEndLineStuff2
        DESCRIPTION
            "Implementation of this group is optional for all
             SONET/SDH systems that terminate SONET/SDH Lines,
             Paths or Virtual Tributaries, and that
             provide for a far end block error (FEBE)
             information at the SONET/SDH Line Layer."

        GROUP       sonetPathStuff2
        DESCRIPTION
            "Implementation of this group is mandatory for all
             SONET/SDH systems that terminate SONET/SDH
             Paths or Virtual Tributaries."

        OBJECT      sonetPathCurrentWidth
        MIN-ACCESS  read-only
        DESCRIPTION
            "Write access is not required."

        GROUP       sonetFarEndPathStuff2
        DESCRIPTION
            "Implementation of this group is optional for all
             SONET/SDH systems that terminate SONET/SDH
             Paths or Virtual Tributaries, and that process
             Far End information."

        GROUP       sonetVTStuff2
        DESCRIPTION
            "Implementation of this group is mandatory for all
             SONET/SDH systems that terminate SONET/SDH Virtual
             Tributaries."

Tesink                      Standards Track                    [Page 58]

RFC 2558                   SONET/SDH Objects                  March 1999

        OBJECT      sonetVTCurrentWidth
        MIN-ACCESS  read-only
        DESCRIPTION
            "Write access is not required."

        GROUP       sonetFarEndVTStuff2
        DESCRIPTION
            "Implementation of this group is optional for all
             SONET/SDH systems that terminate the SONET/SDH
             floating Virtual Tributaries, and that process
             Far End information."

    ::= { sonetCompliances 2 }

_________________________________________________________________
Send and receive Hotmail on your mobile device: http://mobile.msn.com

---

From: "C. M. Heard" <[email-masked]>
Date: Fri, 15 Feb 2002 12:54:22 -0800 (PST)

> please fill out the following -

Faye --

In addition to the reports from Cisco and Nortel that were
reflected in your table, implementation reports from Marconi, 
Corrigent, and Unisphere were posted to the AToMMIB list and
are NOT reflected in your table.  Note that the reports from
Marconi and Unisphere(*) claim support for all of the groups,
in particular sonetVTStuff2 and sonetFarEndVTStuff2, and that
the Corrigent report claims for all of the groups (including
far-end stuff) for all groups except for the VT stuff.

If you will update your table to include input from those
three vendors, then we will have more than enough to advance
all of the groups in the SONET-MIB.  I will forward the
messages from those three vendors to you under separate cover.

Regards,

Mike

(*) for its ERX products