Subject: RE: improving SDH support in rfc2558bis

From: "Mak, L (Leen)" <[email-masked]>
Date: Fri, 12 Apr 2002 09:17:22 +0200

> >This was deemed to be reasonable because for
> >random errors at rates low enough not to cause SESs the
> >ratio of BIP-8 errors to block errors is approximately
> >equal to 1 

Very specific errorcount limits are sometimes written in 
SLAs (service level agreements) and usually the service 
provider has to pay a penalty or a rebate when such limit 
has been crossed.
So I would prefer a "real" BBE count instead of an 
approximation.

> >in G.784 (06/99).  However ...
> >
> >On Mon, 18 Feb 2002, Farzad Khosravi wrote:
> > > [ ... ]
> > > [Newly defined] SES thresholds Standards:
> > >       G.828 : Error Performance parameters and objectives for
> > > international, constant bit rate synchrnous digital paths.
> > >       G.829   : Error Performance Events for SDH multiplex and
> > > regenerator sections.
> >
> >Perhaps someone with access to these documents can indicate
> >whether they provide (a) a definition for regenerator section
> >BBEs (called BBE-S in T1.231) and (b) specifications for SES
> >thresholds that are more complete than those in G.784 (06/99).

(a) for all layers, path and section alike, a BBE is the occurrence
of an errored block not occurring as part of an SES.

(b) SDH SES thresholds (from G.829):

MS layer:

Bit rate		SES threshold	
STM-0		15% Errored Blocks
STM-1		15% Errored Blocks
STM-4		25% Errored Blocks
STM-16		30% Errored Blocks
STM-64		30% Errored Blocks
(STM-256 is not specified)

RS layer:
Bit rate		SES threshold	
STM-0		10% Errored Blocks
STM-1		30% Errored Blocks
STM-4		30% Errored Blocks
STM-16		30% Errored Blocks
(STM-64 and STM-256 are not specified)

Leen Mak.

---

From: "C. M. Heard" <[email-masked]>
Date: Fri, 12 Apr 2002 02:45:47 -0700 (PDT)

> So I would prefer a "real" BBE count instead of an 

Indeed, the suggestion on the table (which I guess did not make
clear) is to add some text that will permit the xyzCVs objects in
the SONET-MIB to be used by SONET implementations to accumulate CVs
(as is the case now) and by SDH implementations to accumulate BBEs.
The fact that BBEs and CVs are approximately equal at error rates
that don't result in SESs makes extension seem reasonably safe.

> of an errored block not occurring as part of an SES.

But the definition of a block is different at different layers.

At the path layer it is the set of bits covered by one B3 byte.

At the multiplex section (aka line) layer it is the set of bit
covered by one bit in one B2 byte (and so MS BBEs and line CVs
are identical, no approximation needed).

What is the definition of a block at the regenerator section layer?

> (b) SDH SES thresholds (from G.829):

Can you provide a citation with complete title
and date of publication (suitable for a citation
in the "References" section of the document)?

> (STM-64 and STM-256 are not specified)

And at the path layer the threshold is 30% errored
blocks, per G.828 (3/2000), right?  (That's the
same as in G.826, which is the reference for
the itu1995 SES threshold enum -- again, a
full citation would be appreciated)

One more thing:  I found an old e-mail to this list
from Geoff Garner stating that "while the clauses
of G.829 dealing with the multiplex section apply
to all media, the clauses dealing with the regerator
section apply only to radio relay and satellite
systems."  Can you confirm this?

Thanks,

Mike