Subject: proposed text for textual conventions...

From: Mike Thatcher <[email-masked]>
Date: Tue, 07 May 2002 10:20:16 -0700

The following is the proposed text for ApsSwitchCommand & ApsControlCommand
which now includes snmp error codes to use, followed by a diff between this and 
the -07 draft.

ApsSwitchCommand ::= TEXTUAL-CONVENTION
      STATUS       current
      DESCRIPTION
          "An APS switch command allows a user to perform protection
           switch actions.

           If the APS switch command cannot be executed because an
           equal or higer priority request is in effect, an
           inconsistentValue error is returned.

           The Switch command values are:

           noCmd

           This value should be returned by a read request when no switch
           command has been written to the object in question since
           initialization. This value may not be used in a write operation.
           If noCmd is used in a write operation a wrongValue error is
           returned.

           clear

           Clears all of the switch commands listed below for the specified
           channel.

           lockoutOfProtection

           Prevents any of the working channels from switching to the protection
           line. The specified channel should be the protection channel,
           otherwise an inconsistentValue error is returned.

           forcedSwitchWorkToProtect

           Switches the specified working channel to the protection line.
           If the protection channel is specified an inconsistentValue
           error is returned.

           forcedSwitchProtectToWork

           Switches the working channel back from the protection
           line to the working line. The specified channel should be
           the protection channel, otherwise an inconsistentValue
           error is returned.

           manualSwitchWorkToProtect

           Switches the specified working channel to the protection line.
           If the protection channel is specified an inconsistentValue
           error is returned.

           manualSwitchProtectToWork

           Switches the working channel back from the protection
           line to the working line. The specified channel should be
           the protection channel, otherwise an inconsistentValue
           error is returned.

           exercise

           Exercises the protocol for a protection switch of the specified
           channel by issuing an Exercise request for that channel and
           checking the response on the APS channel. "
      SYNTAX       INTEGER {
                       noCmd(1),
                       clear(2),
                       lockoutOfProtection(3),
                       forcedSwitchWorkToProtect(4),
                       forcedSwitchProtectToWork(5),
                       manualSwitchWorkToProtect(6),
                       manualSwitchProtectToWork(7),
                       exercise(8)
                   }

ApsControlCommand ::= TEXTUAL-CONVENTION
      STATUS       current
      DESCRIPTION
          "An APS control command applies only to LTE that support the
           1:n architecture and performs the following actions.

           The Control command values are:

           noCmd

           This value should be returned by a read request when no control
           command has been written to the object in question since
           initialization. This value may not be used in a write operation.
           If noCmd is used in a write operation a wrongValue error is
           returned.

           lockoutWorkingChannel

           Prevents the specified working channel from switching to the
           protection line. If the protection line is specified an
           inconsistentValue error is returned.

           clearLockoutWorkingChannel

           Clears the lockout a working channel command for the channel
           specified. If the protection line is specified an
           inconsistentValue error is returned."
      SYNTAX       INTEGER {
                       noCmd(1),
                       lockoutWorkingChannel(2),
                       clearLockoutWorkingChannel(3)
                   }

diff -c drafttest.nr18 drafttest.nr
*** drafttest.nr18	Thu Apr 25 11:55:54 2002
--- drafttest.nr	Mon May  6 14:30:23 2002
***************
*** 389,394 ****
--- 389,398 ----
            "An APS switch command allows a user to perform protection
             switch actions.

+          If the APS switch command cannot be executed because an
+          equal or higer priority request is in effect, an
+          inconsistentValue error is returned.
+
             The Switch command values are:

             noCmd
***************
*** 396,402 ****
             This value should be returned by a read request when no switch
             command has been written to the object in question since
             initialization. This value may not be used in a write operation.
!
             clear

             Clears all of the switch commands listed below for the specified
--- 400,408 ----
             This value should be returned by a read request when no switch
             command has been written to the object in question since
             initialization. This value may not be used in a write operation.
!          If noCmd is used in a write operation a wrongValue error is
!          returned.
!
             clear

             Clears all of the switch commands listed below for the specified
***************
*** 405,431 ****
             lockoutOfProtection

             Prevents any of the working channels from switching to the protection
!          line. The specified channel should be the protection channel.

             forcedSwitchWorkToProtect

             Switches the specified working channel to the protection line.

             forcedSwitchProtectToWork

             Switches the working channel back from the protection
             line to the working line. The specified channel should be
!          the protection channel.

             manualSwitchWorkToProtect

             Switches the specified working channel to the protection line.

             manualSwitchProtectToWork

             Switches the working channel back from the protection
             line to the working line. The specified channel should be
!          the protection channel.

             exercise

--- 411,444 ----
             lockoutOfProtection

             Prevents any of the working channels from switching to the protection
!          line. The specified channel should be the protection channel,
!          otherwise an inconsistentValue error is returned.

             forcedSwitchWorkToProtect

             Switches the specified working channel to the protection line.
+          If the protection channel is specified an inconsistentValue
+          error is returned.

             forcedSwitchProtectToWork

             Switches the working channel back from the protection
             line to the working line. The specified channel should be
!          the protection channel, otherwise an inconsistentValue
!          error is returned.

             manualSwitchWorkToProtect

             Switches the specified working channel to the protection line.
+          If the protection channel is specified an inconsistentValue
+          error is returned.

             manualSwitchProtectToWork

             Switches the working channel back from the protection
             line to the working line. The specified channel should be
!          the protection channel, otherwise an inconsistentValue
!          error is returned.

             exercise

***************
*** 456,471 ****
             This value should be returned by a read request when no control
             command has been written to the object in question since
             initialization. This value may not be used in a write operation.

             lockoutWorkingChannel

             Prevents the specified working channel from switching to the
!          protection line.

             clearLockoutWorkingChannel

             Clears the lockout a working channel command for the channel
!          specified. "
        SYNTAX       INTEGER {
                         noCmd(1),
                         lockoutWorkingChannel(2),
--- 469,488 ----
             This value should be returned by a read request when no control
             command has been written to the object in question since
             initialization. This value may not be used in a write operation.
+          If noCmd is used in a write operation a wrongValue error is
+          returned.

             lockoutWorkingChannel

             Prevents the specified working channel from switching to the
!          protection line. If the protection line is specified an
!          inconsistentValue error is returned.

             clearLockoutWorkingChannel

             Clears the lockout a working channel command for the channel
!          specified. If the protection line is specified an
!          inconsistentValue error is returned."
        SYNTAX       INTEGER {
                         noCmd(1),
                         lockoutWorkingChannel(2),
***************
*** 1215,1224 ****
        DESCRIPTION
            "Allows the initiation of an APS switch command on the
             APS group and channel specified by the index values.
-
-          If the APS switch command cannot be executed because an
-          equal or higer priority request is in effect, an error
-          is returned.

             When read this object returns the last command written
             or noCmd if no command has been written to this
--- 1232,1237 ----

---

From: Joan Cucchiara <[email-masked]>
Date: Tue, 07 May 2002 14:21:47 -0400

Mike,

This looks good. 

 thanks, Joan