Subject: RE: [Entmib] entity mib support for tcif

From: "Faye Ly" <[email-masked]>
Date: Sun, 7 Sep 2003 11:03:16 -0700

Just playing the devil's advocate!  On the other hand, CLEI code is a
fixed string and although it is more elegant to maintain an OID registry
per vendor but this might grow for a NMS that manages multiple vendors.
A fixed string as an augmented table to the physical entity table is
more straightforward to support.

-faye

-----Original Message-----
From: C. M. Heard [mailto:[email-masked]] 
Sent: Sunday, September 07, 2003 12:59 AM
To: [email-masked]; Kaj Tesink; Giamboi, Anthony; Lam, Hing-Kam (Kam);
Faye Ly; Juergen Schoenwaelder; Margaret Wasserman; David T. Perkins;
Wijnen, Bert (Bert); [email-masked]
Subject: Re: [Entmib] entity mib support for tcif

On Sat, 6 Sep 2003, David T. Perkins wrote:
> I believe that adding a CLEI code (common langauge equipment
> identifier code) is completely redundant with the object
> entPhysicalVendorType and should not be added.
> A CLEI code is a globally unique value that is purchased
> from Telcordia. It costs approximately $100 to get the
> document from Telcordia that defines CLEI codes, and
> it costs per assigned code.
> 
> If a vendor wants to use CLEI codes, it is a simple matter
> to construct the OID value for entPhysicalVendorType from
> any CLEI code.
> 
> The only proposal that I would support is to define a standard
> OID prefix, and encoding of the suffix of the OID.
> 
> For example, assume and OID value is assigned with descriptor
> "entPhysicalVendorTypeCLIE", and the encoding is a sub-identifer
> of the decimal value of per character in the CLIE code.

I think this is a VERY GOOD idea.

In previous off-line discussions entPhysicalModelName was suggested
as one place where a CLEI code might live.  While there is nothing
wrong with putting a CLEI code there (especially if it's on a bar
code on the label), there would be no guarantee that any particular
manufacturer did this, nor is there a sure-fire way for a management
application to tell if what's there is actually a CLEI code, if it
happens to be 10 octets long.  But entPhysicalVendorType contains an
OID, which is self-describing.  Very elegant.

I wish there were as neat a solution for entPhysicalMfgDate :-(

Mike

---

From: "C. M. Heard" <[email-masked]>
Date: Sun, 7 Sep 2003 12:45:40 -0700 (PDT)

On Sun, 7 Sep 2003, Faye Ly wrote:
> Just playing the devil's advocate!  On the other hand, CLEI code
> is a fixed string and although it is more elegant to maintain an
> OID registry per vendor but this might grow for a NMS that
> manages multiple vendors. A fixed string as an augmented table
> to the physical entity table is more straightforward to support.

I don't think this is really an issue.  You don't need one OID
prefix per vendor, just one prefix that identifies the OID as one
that contains an embedded CLEI.

Mike