Subject: Re: Yahoo and "Media RSS"

From: [email-masked]
Date: Thu, 16 Dec 2004 16:10:37 EST

In a message dated 12/16/2004 9:02:20 PM GMT Standard Time, 
[email-masked] writes:

> Special case, as I said. It's
> >all in that errata document.
> 
> Where? I can't find anything that covers this case. 

Danny,

I think that NE07 in the Errata was *intended* to cover this case. But I 
don't think it was worded sufficiently precisely or took into consideration all 
possible cases.

In other words, IMHO it's not all in the errata.

It's a perennial problem of specifications.

Specification writers attempt to find words to convey what they mean. 
Specification readers attempt to find a meaning to match the words used by the 
specification writers. When specifications are written to cover all cases and are 
written well the meaning intended by the specification writer and the meaning 
imputed to the words by the specification reader coincide. Result peace and 
productivity. When the specification writers convey their meaning imprecisely or 
omit consideration of significant scenarios the result is a permathread. 
Witness XML Namespaces.

Andrew Watt

---

From: [email-masked]
Date: Thu, 16 Dec 2004 16:21:50 EST

In a message dated 12/16/2004 9:04:23 PM GMT Standard Time, 
[email-masked] writes:

> Danny Ayers wrote:
> >On Thu, 16 Dec 2004 15:05:13 -0500, Sam Ruby <[email-masked]> 
> wrote:
> >
> >>Danny Ayers wrote:
> >>
> >>>The attributes aren't namespace-qualified, yet aren't defined in the
> >>>RSS 2.0 spec.
> >>
> >>They don't need to be defined in the RSS 2.0 spec.  Semantics of
> >>attributes on an element are defined by the element itself, not by the
> >>containing document.
> >
> >
> >Do you have a reference, please?
> >
> >What about:
> >
> ><xx:thing yy:another="elsewhere" />
> >
> >Where would you expect to the semantics of yy:another to be defined?
> 
> Maybe explaining it in terms of the infoset[0] will help. We are 
> interested in two properties:
> 
> [namespace name]
> [owner element]
> 
> <xx:thing yy:another="elsewhere" yetanother="..." />
> 
> yy:another: [namespace name]: some namespace
>        [owner element]: xx:thing instance
> 
> yetanother: [namespace name]:
>        [owner element]: xx:thing instance
> 
> No "null" namespace, just no value. It is defined only by its owner 
> element and local name. It's not sharing a "null" namespace with 
> unqualified element names.
> 
> Robert Sayre
> 
> [0] http://www.w3.org/TR/xml-infoset/#infoitem.attribute

Robert,

The spec writers of the Infoset Recommendation cleverly/dumbly omitted to 
define how a value was or was not determined for the [namespace name] property. 

The definition of the [namespace name] property , "The namespace name, if 
any, of the attribute. Otherwise, this property has no value.", is essentially 
without any meaning as far as determining how to decide what the value of the 
[namespace name] property ought to be. 

This tends to throw the reader back on Namespaces in XML which, as I 
indicated earlier, is less than totally lucid at points.

Andrew Watt