Subject: dereferencability of <link>?

From: Eric Scheid <[email-masked]>
Date: Sun, 06 Feb 2005 16:21:25 +1100

consider

    <link href="tag:example.com,2005:/2005/02/musings" />

    assume for the moment that is a valid scheme

is that kind of URI something we want to allow in link/@href?

putting it another way, look closely at this example

    <feed> 
        [...]
        <entry>
            <id>http://example.com/892379587493</id>
            <link href="http://example.com/2005/02/mutter.html" />
            [...]
        </entry>
        <entry>
            <id>http://example.com/892379587494</id>
            <link href="http://example.com/2005/02/grumble.html" />
            <link href="http://example.com/892379587493" rel="something"/>
            [...]
        </entry>
    <feed> 

The key distinction being that the URI in question is referencing an <id>
URI, and not the dereferenceable location URI.

e.

---

From: Joe Gregorio <[email-masked]>
Date: Sun, 6 Feb 2005 20:32:26 -0500

> is that kind of URI something we want to allow in link/@href?

I see no problem with the above example. The usage of
a URI in no way mandates 'dereferenceability'. 

    -joe

-- 
Joe Gregorio        http://bitworking.org