Subject: Re: Consensus call on last round of Paces

From: Graham <[email-masked]>
Date: Wed, 16 Feb 2005 19:10:18 +0000

On Tuesday, February 15, 2005, at 07:29PM, Tim Bray <[email-masked]> wrote:

>PaceClarifyDateUpdated
>A couple of -1's, one fuzzy +1.
>DISPOSITION: Close it.

Where'd you get this idea? I see two +1s:
http://www.imc.org/atom-syntax/mail-archive/msg13249.html
http://www.imc.org/atom-syntax/mail-archive/msg13460.html

A -1 from Robert, a couple of ambiguous comments and then Henry and Henri derail the thread.

In any case, the sentence I wanted to replace ("Therefore, not all modifications necessarily result in a changed atom:updated value") is still horrible and isn't consistent with the one before it.

Graham

---

From: Graham <[email-masked]>
Date: Wed, 16 Feb 2005 19:22:54 +0000

On Tuesday, February 15, 2005, at 08:11PM, James M Snell <[email-masked]> wrote:

>   - If you just think it's not part of the core and can be added later,
>     fair enough, but that doesn't get around the fact that the current
>     spec, as written, does not allow extensions to change containment
>     requirements and therefore does not provide for a necessary aspect
>     of profile support (the ability to change containment requirements)

Yes it does, if the extension changes the containment elements themselves. The containment requirements are part of the spec of atom:entry and atom:feed/atom:head, not of the atom vocabulary. Replace those and you can choose what you want. I gave this example a few days ago:

<ssff:index> 
  <atom:head> 
    ... 
  </atom:head> 

  <ssff:reference> 
      <atom:id>some-id</id> 
      <atom:link rel="self" type="application/atom+xml" href="..." /> 
      <atom:updated>...</updated> 
   </ssff:reference> 

   .... 

</ssff:index> 

ssff:reference is not subject to the same requirements as atom:entry would be.

Graham