Subject: Re: PaceFeedRecursive

From: Henry Story <[email-masked]>
Date: Mon, 7 Feb 2005 21:18:58 +0100

On 19 Jan 2005, at 10:38, Henry Story wrote:
> I think the easiest way to get what you want is a 2 step procedure:
>
>   1. Merge the Head with the Entry constructs. They are not different 
> enough
>     for the difference to be important.
>   2. Make a Feed a subclass of Entry, with the extra property of being 
> able
>      to point to a Entry (Since a Feed is a Entry, it also points to 
> other Feeds)
>
> I am  +1 on such a refactoring. Nothing will be lost doing this, and a 
> lot gained
> in simplicity.
>
> Henry

I now no longer believe 2. Is needed.
1 would be quite neat though.

Henry

---

From: "Roy T. Fielding" <[email-masked]>
Date: Mon, 7 Feb 2005 15:00:31 -0800

Please withdraw PaceFeedRecursive because forcing everything to
be an entry is sufficient justification to forbid inclusion by
anything other than reference.

The other (still needed) bits are in PaceHeadless.

Cheers,

Roy T. Fielding                            <http://roy.gbiv.com/>
Chief Scientist, Day Software              <http://www.day.com/>