Subject: Required elements for atom:source

From: David Powell <[email-masked]>
Date: Thu, 7 Apr 2005 22:13:29 +0100

According to the RelaxNG:

>    atomSource =
>       element atom:source {
>          atomCommonAttributes,
>          (atomAuthor?
>           & atomCategory*
>           & atomContributor*
>           & atomCopyright?
>           & atomGenerator?
>           & atomIcon?
>           & atomId?
>           & atomImage?
>           & atomLink+
>           & atomSubtitle?
>           & atomTitle
>           & atomUpdated
>           & extensionElement*)

... atom:title and atom:updated are required for atom:source.
Is this a typo?

I'd assume that no elements should be required for atom:source, on the
principle that anything that you can provide is better than nothing.

-- 
Dave

---

From: Bill de hÓra <[email-masked]>
Date: Thu, 07 Apr 2005 23:08:05 +0100

> principle that anything that you can provide is better than nothing.

My reading of the spec - not a typo. This could be like the situation I 
pointed out around simple and extension schema - if so the text ought to 
be amended to indicate the constraint.

** 4.2.14 The "atom:title" Element

extend:
[[[
The "atom:title" element is a Text construct that conveys a 
human-readable title for an entry or feed.
]]]

with:
"An atom:source MUST contain one atom:title element."

** 4.2.15 The "atom:updated" Element

extend:
[[[
The "atom:updated" element is a Date construct indicating the most 
recent instant in time when an entry or feed was modified in a way the 
publisher considers significant. Therefore, not all modifications 
necessarily result in a changed atom:updated value.
]]]

with:
"An atom:source MUST contain one atom:updated element."

cheers
Bill

---

From: "Bob Wyman" <[email-masked]>
Date: Thu, 7 Apr 2005 18:43:11 -0400

Personally, I think the atom:source should have a required link which points
to the feed that is claimed to be the source...

		bob wyman