Subject: RE: HTML/XHTML type issues, was: FW: XML Directorate Reviewer Comments

From: "Klotz, Leigh" <[email-masked]>
Date: Thu, 14 Apr 2005 15:00:57 -0700

I think that casting this problem as XML-in-XML is a problem in itself, and I believe that a more productive approach is to consider it a mixed-namespace document with extensibility as in CDF, and use RNG for the formal description.

-----Original Message-----
Bill de hÓra>...And while I do realize that XML in XML tends be a broader problem that just Atom...

---

From: Bill de hÓra <[email-masked]>
Date: Fri, 15 Apr 2005 01:35:24 +0100

Klotz, Leigh wrote:
> I think that casting this problem as XML-in-XML is a problem in itself, 

It's a problem, but I don't see as casting. But like I said, if that's 
not the technical problem, I'll gladly shut up. If it is, we could do 
worse than be cognizant as to what we're working around.

> and I believe that a more productive approach is to consider it a mixed-namespace document 
> with extensibility as in CDF, and use RNG for the formal description.

Except that strictly speaking the rng is informative and won't count 
formally (altho' it's a nice approach). We'd have to spec it as text.

cheers
Bill