Subject: RE: HTML/XHTML type issues, was: FW: XML Directorate Reviewer Comments

From: "Klotz, Leigh" <[email-masked]>
Date: Fri, 15 Apr 2005 11:15:35 -0700

Bill,
Thank you for the answer.

I'm being cautious here, because vocabulary integration is one of my main concerns in the direction Atom is taking, and I hate to see everything hard-coded with special deference to particular HTML tags.  If we can't solve the problems without recourse to spec changes, we won't be building an extensible standard.

Could you let me know why RNG can't be normative?  Is it written down somewhere in the RFC?  There's normative BNF in various IETF RFCs and I don't see much difference, especially since RNC looks like BNF and it's now an ISO standard.

I do tend to disagree on the terminology issue, still, though.
I think that saying we have an "XML-in-XML" problem leads people to think of encapsulation and semantic-blind content carrying (think base64 or CDATA), whereas calling it "mixed vocabulary" implies solutions that are at the semantic level, and I believe lead to extensibility.  

Dave Orchard and Dare Obasanjo have written eloquently on designing languages for for integration and extensibility [1] [2] [3]. The articles point out some obstacles in using XML Schema so I suggested RNG; although prose would work, it's more, well, wordy, and open to interpretation in the implementation.

Leigh.
[1] http://www.xml.com/pub/a/2003/12/03/versioning.
[2] http://www.xml.com/pub/a/2004/07/21/design.html
[3] htmlhttp://www.pacificspirit.com/blog/2004/07/27/dare%20versioning%20extensibility%20article%20comparison

-----Original Message-----
From: Bill de hÓra [mailto:[email-masked]] 
Sent: Thursday, April 14, 2005 4:35 PM
To: Klotz, Leigh
Cc: [email-masked]
Subject: Re: HTML/XHTML type issues, was: FW: XML Directorate Reviewer Comments

Klotz, Leigh wrote:
> I think that casting this problem as XML-in-XML is a problem in itself, 

It's a problem, but I don't see as casting. But like I said, if that's 
not the technical problem, I'll gladly shut up. If it is, we could do 
worse than be cognizant as to what we're working around.

> and I believe that a more productive approach is to consider it a mixed-namespace document 
> with extensibility as in CDF, and use RNG for the formal description.

Except that strictly speaking the rng is informative and won't count 
formally (altho' it's a nice approach). We'd have to spec it as text.

cheers
Bill

---

From: Robert Sayre <[email-masked]>
Date: Fri, 15 Apr 2005 16:06:25 -0400

Klotz, Leigh wrote:

> I'm being cautious here, because vocabulary integration is one of my
> main concerns in the direction Atom is taking, and I hate to see
> everything hard-coded with special deference to particular HTML tags.
> If we can't solve the problems without recourse to spec changes, we
> won't be building an extensible standard.

Atom's content element allows arbitrary XML. Atom's Text construct does 
not. If the format were to allow basically anything in those, there 
wouldn't be much of a standard.

> 
> Could you let me know why RNG can't be normative?  Is it written down
> somewhere in the RFC?  There's normative BNF in various IETF RFCs and
> I don't see much difference, especially since RNC looks like BNF and
> it's now an ISO standard.

There's no procedural reason, it was a working group decision.

Robert Sayre

---

From: Bill de hÓra <[email-masked]>
Date: Sat, 16 Apr 2005 01:25:11 +0100

Klotz, Leigh wrote:
> Could you let me know why RNG can't be normative?  Is it written down somewhere in the RFC?  

It is written down. There is consensus in the WG that the spec text be 
the final word.

> There's normative BNF in various IETF RFCs and I don't see much difference, especially since RNC looks like BNF and it's now an ISO standard.
> 

Extensibility so far in Atom has been firstly along the axis of 
particular attributes/values that applies to the format itself. Second 
is along the axis of adding names from other namespaces as children of 
the entry element making Atom a general purpose metadata container (the 
entry then is much like a dictionary). But while XHTML and text is an 
issue atm, it's worth pointing out that atom:content can carry arbitrary 
XML.

[After some thought, I'll stand by the XML in XML thing while believing 
it open up a level of debate that is maybe not helpful right now.]

> Dave Orchard and Dare Obasanjo have written eloquently on designing languages for for integration and extensibility [1] [2] [3]. The articles point out some obstacles in using XML Schema so I sugge…

They have.The problem for us going that route is as I see it that we'll 
risk imposing processing constraints and coordination on producers and 
consumers that will be rejected in practice.

[My personal view is that this speaks to modularity and not 
extensibility; for example things like RDF, or say Lisp, have a very 
notion of what an extension is. Being able to mix and match lexically 
and between versions is not what I think about first when it comes to 
extension, but I've been told that's not a common interpretation.]

cheers
Bill