Subject: looking for atom media feeds

From: Pete Brunet <[email-masked]>
Date: Wed, 4 Jun 2008 17:13:29 -0500

In the process of evaluating atom accessibility I'd like to evaluate some 
non-text, non-html/xhtml atom media feeds.  I haven't been able to find 
any yet.  Can someone provide a list of atom media feeds?  What are the 
possible media types I should be looking at?

Thanks,
Pete Brunet
                                                                          
IBM Accessibility Architecture and Development
11501 Burnet Road, MS 9022E004, Austin, TX 78758
Voice: (512) 838-4594, Cell: (512) 689-4155
Ionosphere: WS4G

---

From: Aristotle Pagaltzis <[email-masked]>
Date: Thu, 5 Jun 2008 00:45:26 +0200

* Pete Brunet <[email-masked]> [2008-06-05 00:25]:
> In the process of evaluating atom accessibility I'd like
> to evaluate some non-text, non-html/xhtml atom media feeds.
> I haven't been able to find any yet. Can someone provide a
> list of atom media feeds? What are the possible media types
> I should be looking at?

DOAP over Atom comes to mind; <http://doapspace.org/newest>
has such a feed.

Regards,
-- 
Aristotle Pagaltzis // <http://plasmasturm.org/>

---

From: Pete Brunet <[email-masked]>
Date: Wed, 4 Jun 2008 23:51:05 -0500

Aristotle, Thanks for an example of an RDF content type.  Actually I am 
interested in examples of these media types:  multipart/alternative, 
application/smil+xml (or similar multimedia file type), and cases where 
link rel="alternate" is used to provide an alternate mode of expression, 
e.g. a transcript for audio content..  And any other cases that are in use 
to provide accessibility.

I'm also interested in examples of normal inaccessible audio and video 
atom feeds.

Pete Brunet

Aristotle Pagaltzis <[email-masked]> 
Sent by: [email-masked]
06/04/2008 05:45 PM

To
[email-masked]
cc

Subject
Re: looking for atom media feeds

Regards,

---

From: Aristotle Pagaltzis <[email-masked]>
Date: Thu, 5 Jun 2008 13:40:19 +0200

Hi Pete,

* Pete Brunet <[email-masked]> [2008-06-05 07:00]:
> Actually I am interested in examples of these media types:
> multipart/alternative, […]

multipart/* is forbidden as an Atom payload so you won’t find
any such feeds.

Regards,

---

From: Ernest Prabhakar <[email-masked]>
Date: Thu, 05 Jun 2008 08:51:08 -0700

Hi Pete,

As mentioned, Atom doesn't support multiparty. It does support  
multiple enclosures, though. Are there any HTML conventions we could  
perhaps adopt to identify accessible alternatives?

E
Sent from my iPhone

On Jun 4, 2008, at 21:51, Pete Brunet <[email-masked]> wrote:

>
> Aristotle, Thanks for an example of an RDF content type.  Actually I  
> am interested in examples of these media types:  multipart/ 
> alternative, application/smil+xml (or similar multimedia file type),  
> and cases where link rel="alternate" is used to provide an alternate  
> mode of expression, e.g. a transcript for audio content..  And any  
> other cases that are in use to provide accessibility.
>
> I'm also interested in examples of normal inaccessible audio and  
> video atom feeds.
>
> Pete Brunet
>

---

From: Pete Brunet <[email-masked]>
Date: Mon, 9 Jun 2008 16:39:16 -0500

>It does support multiple enclosures, though. Are there any HTML 
conventions we could perhaps adopt to identify accessible alternatives?

Does anyone have an example of multiple enclosures - or even just a 
pedagogical example?

Regarding the HTML conventions, I'm not aware of any, but perhaps someone 
else is - or understands the HTML spec well enough to know if conventions 
are a possibility.

Pete Brunet

Ernest Prabhakar <[email-masked]> 
06/05/2008 10:51 AM

To
Pete Brunet/Austin/IBM@IBMUS
cc
"[email-masked]" <[email-masked]>
Subject
Re: looking for atom media feeds

Hi Pete,

As mentioned, Atom doesn't support multiparty. It does support multiple 
enclosures, though. Are there any HTML conventions we could perhaps adopt 
to identify accessible alternatives?

E
Sent from my iPhone

Pete Brunet

To
[email-masked] 
cc

Subject

Regards,

---

From: Ernest Prabhakar <[email-masked]>
Date: Tue, 17 Jun 2008 10:03:05 -0700

Hi Pete,

> Does anyone have an example of multiple enclosures - or even just a  

Here's the canonical version from DeveloperWorks:

http://www.ibm.com/developerworks/xml/library/x-atom10.html

They differentiate by MIME type; I'm looking at doing something more  
sophisticated using HTML 5 / CSS 3 media queries...

-- Ernie P.