Subject: Atompub Features Draft Dead for Good?

From: James M Snell <[email-masked]>
Date: Mon, 08 Jun 2009 15:14:58 -0700

Ok, so we'd made quite a bit of progress on the Atom features draft a 
while back and then I decided to sit and watch to see if there was a 
strong enough need for the extensions. At this point, I have not seen 
anyone jumping up and down demanding the functionality provided by the 
Features draft so I'm wondering if I should just consider it Dead for 
Good. Thoughts?

---

From: Al Brown <[email-masked]>
Date: Mon, 8 Jun 2009 16:04:50 -0700

CMIS adds CMIS element to the workspace element in the atompub service
document.  I am not aware of requirements from CMIS for representing
features at the collection level.

FYI - Here's an example of the features/capabilities CMIS advertises in the
atompub workspace element:

        <ns5:repositoryInfo>
            <ns1:repositoryId>repid1</ns1:repositoryId>
            <ns1:repositoryName>Repository1</ns1:repositoryName>
            <ns1:repositoryRelationship>self</ns1:repositoryRelationship>
            <ns1:repositoryDescription>CMIS Repository Description</
ns1:repositoryDescription>
            <ns1:vendorName>CMIS Vendor 1</ns1:vendorName>
            <ns1:productName>CMIS Prototype for VendorX</ns1:productName>
            <ns1:productVersion>0.61</ns1:productVersion>
            <ns1:rootFolderId>rootfolder</ns1:rootFolderId>
            <ns1:capabilities>
                <ns1:capabilityMultifiling>true</ns1:capabilityMultifiling>
                <ns1:capabilityUnfiling>true</ns1:capabilityUnfiling>
                <ns1:capabilityVersionSpecificFiling>true</
ns1:capabilityVersionSpecificFiling>
                <ns1:capabilityPWCUpdateable>true</
ns1:capabilityPWCUpdateable>
                <ns1:capabilityPWCSearchable>true</
ns1:capabilityPWCSearchable>
                <ns1:capabilityAllVersionsSearchable>true</
ns1:capabilityAllVersionsSearchable>
                <ns1:capabilityQuery>bothcombined</ns1:capabilityQuery>
                <ns1:capabilityJoin>innerandouter</ns1:capabilityJoin>
                <ns1:capabilityChanges>all</ns1:capabilityChanges>
                <ns1:capabilityChangesOnType>document</
ns1:capabilityChangesOnType>
                <ns1:capabilityChangesOnType>folder</
ns1:capabilityChangesOnType>
                <ns1:changesIncomplete>true</ns1:changesIncomplete>
            </ns1:capabilities>
            <ns1:cmisVersionSupported>0.61</ns1:cmisVersionSupported>
        </ns5:repositoryInfo>

-Al

Al Brown
Emerging Standards and Industry Frameworks
CMIS: https://w3.tap.ibm.com/w3ki07/display/ECMCMIS/Home
Industry Frameworks: https://w3.tap.ibm.com/w3ki07/display/ECMIF/Home

Office 714 327 3453
Mobile 714 263 6441
Email  [email-masked]
CONFIDENTIAL NOTICE: The contents of this message, including any
attachments, are confidential and are intended solely for the use of the
person or entity to whom the message was addressed. If you are not the
intended recipient of this message, please be advised that any
dissemination, distribution, or use of the contents of this message is
strictly prohibited. If you received this message in error, please notify
the sender. Please also permanently delete all copies of the original
message and any attached documentation.

  From:       James M Snell <[email-masked]>                                                                                 
                                                                                                                                
  To:         atom-syntax <[email-masked]>                                                                                 
                                                                                                                                
  Date:       06/08/2009 03:36 PM                                                                                               
                                                                                                                                
  Subject:    Atompub Features Draft Dead for Good?

---

From: [email-masked]
Date: Mon, 8 Jun 2009 23:13:52 +0000

Ok this is good to see. The main question is whether there is sufficient reason to define a generic features/capabilities extension. There certainly are good arguments in favor. If a generic ext was available would cmis use it?

Sent from my Verizon Wireless BlackBerry

-----Original Message-----
From: Al Brown <[email-masked]>

Date: Mon, 8 Jun 2009 16:04:50 
To: James M Snell<[email-masked]>
Cc: atom-syntax<[email-masked]>; <[email-masked]>
Subject: Re: Atompub Features Draft Dead for Good?

        <ns5:repositoryInfo>

-Al

Al Brown

Office 714 327 3453
Mobile 714 263 6441

---

From: Al Brown <[email-masked]>
Date: Wed, 10 Jun 2009 11:29:10 -0700

If it made sense for CMIS to use it, then yes.  Especially if it becomes
the best practice to advertise an atom extension.

It would be helpful if the feature markup included a way to specify an URI
to get the feature-specific info such as the block below.  That would help
make the service document easier to produce and the client can request the
feature-specific block if desired.

-Al

Al Brown

Office 714 327 3453
Mobile 714 263 6441

  From:       [email-masked]                                                                                                 
                                                                                                                                
  To:         Al Brown/Costa Mesa/IBM@IBMUS                                                                                     
                                                                                                                                
  Cc:         "atom-syntax" <[email-masked]>, [email-masked]                                               
                                                                                                                                
  Date:       06/08/2009 04:36 PM                                                                                               

Ok this is good to see. The main question is whether there is sufficient
reason to define a generic features/capabilities extension. There certainly
are good arguments in favor. If a generic ext was available would cmis use
it?

From: Al Brown
Date: Mon, 8 Jun 2009 16:04:50 -0700
To: James M Snell<[email-masked]>
Subject: Re: Atompub Features Draft Dead for Good?

<ns5:repositoryInfo>
<ns1:capabilityPWCUpdateable>true</ns1:capabilityPWCUpdateable>
<ns1:capabilityPWCSearchable>true</ns1:capabilityPWCSearchable>
<ns1:capabilityChangesOnType>document</ns1:capabilityChangesOnType>
<ns1:capabilityChangesOnType>folder</ns1:capabilityChangesOnType>

-Al

Al Brown

Office 714 327 3453
Mobile 714 263 6441

Inactive hide details for James M Snell ---06/08/2009 03:36:36 PM---Ok, so
we'd made quite a bit of progress on the Atom featurJames M Snell
---06/08/2009 03:36:36 PM---Ok, so we'd made quite a bit of progress on the
Atom features draft a