Subject: looking for atom advice (newbie atom developer)

From: Miles Fidelman <[email-masked]>
Date: Mon, 19 Sep 2011 11:46:10 -0400

Hello Folks,

Please excuse me if this is the wrong list for these questions, but 
there don't seem to be very many places where atom is actively discussed 
(if anyone can point me at a better community for developers working 
with atom, please let me know).

We're considering using Atom in a somewhat non-standard way - as a 
vehicle for transporting HTML content (think web pages, single-page 
JavaScript applications).  It seems like Atom is perfect for this, but 
the specifications are a bit vague in several areas, and implementations 
even more so.

RE. SPECS:

The spec. for content elements, of type HTML (RFC4287, par. 3.1.1.2.), 
says "If the value of "type" is "html", the content of the Text 
construct  .... SHOULD be suitable for handling as HTML [HTML 
<http://tools.ietf.org/html/rfc4287#ref-HTML>] ... (and) SHOULD be such 
that it could validly appear directly within an HTML <DIV> element, 
after unescaping. Atom Processors that display such content MAY use that 
markup to aid in its display."

This implies that the notional use of an HTML content element is for a 
snippet of HTML, but does not seem to preclude embedding an entire web 
page, including JavaScript, within an HTML content element.

Questions:

1. Is this a correct interpretation?

2. If so, does anybody know of anybody who's doing this kind of thing?

3. Can anybody suggest any tools, libraries for generating Atom with 
complicated content elements, posting it via Atompub, processing posts 
on a server, and then parsing feeds on a client?  It seems like all of 
the tools I've been able to find view Atom as nothing more than a 
replacement for RSS as a way to post and read blog feeds.

4. Any thoughts or pointers vis-a-vis how common browsers handle Atom 
feeds.  It's already clear that they handle/render feeds differently 
when they're accessed via HTTP, than when the same XML is read from a 
file.  It sure would be nice to find some material that would help me 
understand what's going on.

Thanks very much for any assistance you can offer.

Miles Fidelman

-- 
In theory, there is no difference between theory and practice.
In<fnord>  practice, there is.   .... Yogi Berra

---

From: Jan Algermissen <[email-masked]>
Date: Mon, 19 Sep 2011 18:02:13 +0200

On Sep 19, 2011, at 5:46 PM, Miles Fidelman wrote:

> 
> Hello Folks,
> 
> Please excuse me if this is the wrong list for these questions, but there don't seem to be very many places where atom is actively discussed (if anyone can point me at a better community for developers working with atom, please let me know).
> 
> We're considering using Atom in a somewhat non-standard way - as a vehicle for transporting HTML content (think web pages, single-page JavaScript applications).  It seems like Atom is perfect for this, but the specifications are a bit vague in several areas, and implementations even more so.
> 
> RE. SPECS:
> 
> The spec. for content elements, of type HTML (RFC4287, par. 3.1.1.2.), says "If the value of "type" is "html", the content of the Text construct  .... SHOULD be suitable for handling as HTML [HTML <http://tools.ietf.org/html/rfc4287#ref-HTML>] ... (and) SHOULD be such that it could validly appear directly within an HTML <DIV> element, after unescaping. Atom Processors that display such content MAY use that markup to aid in its display."
> 
> This implies that the notional use of an HTML content element is for a snippet of HTML, but does not seem to preclude embedding an entire web page, including JavaScript, within an HTML content element.
> 
> Questions:
> 

No. A complete HTML document cannot be put inside an HTML <div>. Why do you consider the text to be vague?

You can simply put the HTML doc in there and make the type a proper mime type, e.g. text/html. Then the limitation of type="HTML" does not apply.

> 2. If so, does anybody know of anybody who's doing this kind of thing?

No.

> 
> 3. Can anybody suggest any tools, libraries for generating Atom with complicated content elements, posting it via Atompub, processing posts on a server, and then parsing feeds on a client?  It seems like all of the tools I've been able to find view Atom as nothing more than a replacement for RSS as a way to post and read blog feeds.

Apache Abdere should work fine.

> 
> 4. Any thoughts or pointers vis-a-vis how common browsers handle Atom feeds.  It's already clear that they handle/render feeds differently when they're accessed via HTTP, than when the same XML is read from a file.  It sure would be nice to find some material that would help me understand what's going on.

No - but that should be quite simple to check, I assume.

Jan