Subject: [Autoconf] Using DHCPv6 without link-local? Support only EUI-64 interfaces?

From: Teco Boot <[email-masked]>
Date: Fri, 30 Jul 2010 13:57:43 +0200

RFC3315:
   ...     The client
   MUST use a link-local address assigned to the interface for which it
   is requesting configuration information as the source address in the
   header of the IP datagram.

Question: can we get around a MUST in a standards track RFC?
I don't think so.

The to be posted proposed text for to be RFC5889 would say that if link-locals are used, there are potential problems when using other than modified EUI-64 IIDs, and therefore must be based on modified EUI-64 IIDs.

Second question, on first item in charter: do we limit ourself to MANET routers that has modified EUI-64 link-locals?
I think: better think twice.

Opinions?

Teco.

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Fri, 30 Jul 2010 14:52:39 +0100

Teco
> Question: can we get around a MUST in a standards track RFC?

There is the "don't use that RFC, use another one - or none"
approach.

> Second question, on first item in charter: do we limit ourself
> to MANET routers that has modified EUI-64 link-locals?

Definitely not. There are issues with EUI-64. One of these is
privacy/security. If I use a device today, and use the same
device at a different time and in a different place, it's still
clearly identified as the same device. That can be a problem.

There's a discussion in RFC 3041. That's obsoleted by RFC 4941.
I mention the older version as someone was concered enough to
write draft-dupont-ipv6-rfc3041harmful-05.txt that argued against
RFC 3041 (but never made it to RFC). My point is, there are issues,
and people of goodwill and expertise disagree on the subject.
Probably because of different backgrounds and assumptions. One
size does not fit all.

-- 
Christopher Dearlove
Technology Leader, Communications Group
Networks, Security and Information Systems Department
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194  Fax: +44 1245 242124

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87,
Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: "Templin, Fred L" <[email-masked]>
Date: Fri, 30 Jul 2010 08:40:35 -0700

Teco,

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Teco Boot
> Sent: Friday, July 30, 2010 4:58 AM
> To: [email-masked] [email-masked]
> Subject: [Autoconf] Using DHCPv6 without link-local? Support only EUI-64interfaces?
> 
> RFC3315:
>    ...     The client

If the MANET router only behaves as a client on an internal
link (e.g., a loopback) but behaves as a relay on its MANET
interfaces, then link-locals need not be exposed for DHCPv6
purposes. There are other reasons why link-locals might need
to be considered for MANETs, but I'm not sure this is one
of them.

Fred
[email-masked]
 
> The to be posted proposed text for to be RFC5889 would say that if link-locals are used, there are
> potential problems when using other than modified EUI-64 IIDs, and therefore must be based on
> modified EUI-64 IIDs.
> 
> _______________________________________________
> Autoconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/autoconf

---

From: Teco Boot <[email-masked]>
Date: Sat, 31 Jul 2010 13:19:23 +0200

Chris, thanks for sharing your opinion.

On using DHCP, the draft charter, workitem 1, specifies usage of DHCPv6.
When thinking on how this could work, I want to know what requirements are.
Did I catch "un-touched DHCPv6" at the meeting?

On RFC 3091 and dupont-ipv6-rfc3041harmful, the recommendations are in RFC 4901.

The change on site duplicates for well generated CGA or private IIDs is close 
to zero. I think duplicate address problems with DHCP servers on CPE devices 
are far larger than self-generated IIDs because reboots and non-volatile storage 
or lazy write.

Using DHCP provided addresses could provide more efficient compression with 
RFC 5444. EUI-64 needs 3 (same OUI in homogenous MANET) or 8 octets.
CGA or private IIDs needs 8 octets.
Centrally managed addresses could result in less, with 1 octet at a minimum.
This would be a good reason to use the more centralized approach.

Teco.

---

From: Teco Boot <[email-masked]>
Date: Sat, 31 Jul 2010 15:56:58 +0200

Fred,

Do you mean DHCP relay can be used on a node, that request an address 
for itself?

I think it could work this way:
1) Node queries with link-local to All_DHCP_Relay_Agents_and_Servers.
2a) Node acts as also relay and queries with ULA (site-local) to All_DHCP_Servers.
2b) If node is provisioned with DHCP server unicast address, it could use that 
    instead of All_DHCP_Servers.
I think this is in line with your RFC 5558.

Drawback of 1: it can result in high number of relayed DHCP packets, in case 
of many neighbors.
Another drawback of 1: there is a timeout delay when there is no relay or server
at one hop.

For 2a: the network needs multicast support. Could be SMF.

For both 2a and 2b: a temporally used unicast address must be routable. So this 
DHCP mechanism can only be used as a second step, moving from the self-generated 
address to a centrally managed address.

Teco