Subject: [Autoconf] RFC 5889 on IP Addressing Model in Ad Hoc Networks

From: [email-masked]
Date: Tue, 7 Sep 2010 09:22:26 -0700 (PDT)

A new Request for Comments is now available in online RFC libraries.

        RFC 5889

        Title:      IP Addressing Model in Ad 
                    Hoc Networks 
        Author:     E. Baccelli, Ed.,
                    M. Townsley, Ed.
        Status:     Informational
        Stream:     IETF
        Date:       September 2010
        Mailbox:    [email-masked], 
                    [email-masked]
        Pages:      8
        Characters: 14918
        Updates/Obsoletes/SeeAlso:   None

        I-D Tag:    draft-ietf-autoconf-adhoc-addr-model-03.txt

        URL:        http://www.rfc-editor.org/rfc/rfc5889.txt

This document describes a model for configuring IP addresses and
subnet prefixes on the interfaces of routers which connect to links
with undetermined connectivity properties.  This document is not an 
Internet Standards Track specification; it is published for 
informational purposes.

This document is a product of the Ad-Hoc Network Autoconfiguration Working Group of the IETF.

INFORMATIONAL: This memo provides information for the Internet community.
It does not specify an Internet standard of any kind. Distribution of
this memo is unlimited.

This announcement is sent to the IETF-Announce and rfc-dist lists.
To subscribe or unsubscribe, see
  http://www.ietf.org/mailman/listinfo/ietf-announce
  http://mailman.rfc-editor.org/mailman/listinfo/rfc-dist

For searching the RFC series, see http://www.rfc-editor.org/rfcsearch.html.
For downloading RFCs, see http://www.rfc-editor.org/rfc.html.

Requests for special distribution should be addressed to either the
author of the RFC in question, or to [email-masked].  Unless
specifically noted otherwise on the RFC itself, all RFCs are for
unlimited distribution.

The RFC Editor Team
Association Management Solutions, LLC

---

From: Alexandru Petrescu <[email-masked]>
Date: Wed, 08 Sep 2010 21:37:15 +0200

AUTOCONF group,

I am happy this is a Request For Comments!

The title sounds good, it could be read as "an" addressing model.  It
doesn't say exclusively "Router" as it may have shadowed the notion of
end system being configured.

The text on link-local addresses reads good, balanced between the
initial reluctance of lls and the acceptance they could be unique
globally when that bit is ok.

Alex

Le 07/09/2010 18:22, [email-masked] a écrit :
> Title:      IP Addressing Model in Ad Hoc Networks Author:     E.
> Baccelli, Ed., M. Townsley, Ed. Status:     Informational Stream:
> IETF Date:       September 2010 Mailbox:
> [email-masked], [email-masked] Pages:      8
> Characters: 14918 Updates/Obsoletes/SeeAlso:   None
>
> INFORMATIONAL: This memo provides information for the Internet
> community. It does not specify an Internet standard of any kind.
> Distribution of this memo is unlimited.
>
> This announcement is sent to the IETF-Announce and rfc-dist lists. To
> subscribe or unsubscribe, see
> For searching the RFC series, see
> http://www.rfc-editor.org/rfcsearch.html. For downloading RFCs, see
> http://www.rfc-editor.org/rfc.html.
>
> author of the RFC in question, or to [email-masked].
> Unless specifically noted otherwise on the RFC itself, all RFCs are
> for unlimited distribution.
>
>
> The RFC Editor Team Association Management Solutions, LLC
>
>
> _______________________________________________ Autoconf mailing
> list [email-masked]
> https://www.ietf.org/mailman/listinfo/autoconf
>

---

From: Paul Lambert <[email-masked]>
Date: Fri, 24 Sep 2010 17:32:22 -0700

> globally when that bit is ok.

I'm not unhappy with the draft - but I find it does not provide very much guidance or any solutions.

Yes - link local does not work well.  If we have an ad hoc (802.11 IBSS) network, what is the recommended way to assign an IPv4 address?

Paul

PS - sorry, for delay in comments to the list - I lurk very infrequently
PPS - I'm working with a vendor consortium (Wi-Fi Alliance) on IBSS interoperability - IP address assignment would be useful :-)

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Mon, 27 Sep 2010 10:19:24 +0100

> I'm not unhappy with the draft - but I find it does
> not provide very much guidance or any solutions.

This makes no attempt to provide any solutions. That
work should be starting now.

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: Paul Lambert <[email-masked]>
Date: Mon, 27 Sep 2010 13:07:15 -0700

Great.  Glad to hear that .... will start to track more closely ...   Paul

Paul A. Lambert | Marvell Semiconductor | +1 650-787-9141

> -----Original Message-----
> From: Dearlove, Christopher (UK) [mailto:[email-masked]]
> Sent: Monday, September 27, 2010 2:19 AM
> To: Paul Lambert; Alexandru Petrescu; [email-masked]
> Subject: RE: [Autoconf] RFC 5889 on IP Addressing Model in Ad Hoc Networks
>