Subject: RE: rtcp implementation

From: Ronen Ofer <[email-masked]>
Date: Wed, 25 Aug 1999 17:04:12 +0200

Hi,

	I have an application that handles the rtp, including the
calculation of the sender/reception report statistics.

	Ronen.

> -----Original Message-----
> From:	Colin Perkins [SMTP:[email-masked]]
> Sent:	יום רביעי 25 אוגוסט 1999 16:59
> To:	Ronen Ofer
> Cc:	[email-masked]'
> Subject:	Re: rtcp implementation
> 
> --> Ronen Ofer writes:
> >Does anyone knows of an rtcp stand alone implementation that is not
> rtp
> >dependant.
> >I am handling the rtp send & receive myself & need just the rtcp
> >implementation.
> 
> Such a thing is not possible - the rtcp implementation needs
> information
> from the rtp send/receive code to calculate the sender/reception
> report
> statistics.
> 
> Colin

---

From: Colin Perkins <[email-masked]>
Date: Wed, 25 Aug 1999 16:10:43 +0100

>calculation of the sender/reception report statistics.

I understand, but this means you don't need a standalone rtcp implementation, 
rather one which integrates with your rtp code. The same is true of the other 
implementations I know - they all integrate with the relevent rtp code. 

If you don't mind pulling the rtcp code out from the rtp code, there's a
free implementation in the UCL multimedia library, which forms the base
of our mbone toolset. See http://www-mice.cs.ucl.ac.uk/multimedia/software/
and pull the source code to the common library.

Cheers,
Colin