Subject: Re: rtcp implementation

From: "Glenn L. Cash" <[email-masked]>
Date: Wed, 25 Aug 1999 11:23:55 -0400

I think that this standalone RTCP implementation
is a great idea. The implementation of full-blown
RTCP is a big headache that should not be inflicted
on all RTP application programmers.

As long as the RTP implementation calculates the
statistics, you could feed these to the RTCP application
through a socket,  for example.

                Glenn

--
Glenn L. Cash
AT&T Labs - Research
100 Schultz Drive, Room 3-221,
Red Bank, NJ  07701-7033
E-mail: [email-masked]

-----Original Message-----
From: Ronen Ofer <[email-masked]>
To: 'Colin Perkins' <[email-masked]>; Ronen Ofer <[email-masked]>
Cc: [email-masked]' <[email-masked]>
Date: Wednesday, August 25, 1999 11:10 AM
Subject: RE: rtcp implementation

>      Hi,
>
> I have an application that handles the rtp, including the
>calculation of the sender/reception report statistics.
>
> Ronen.
>
>> -----Original Message-----
>> From: Colin Perkins [SMTP:[email-masked]]
>> Sent: יום רביעי 25 אוגוסט 1999 16:59
>> To: Ronen Ofer
>> Cc: [email-masked]'
>> Subject: Re: rtcp implementation
>>
>> --> Ronen Ofer writes:
>> >Does anyone knows of an rtcp stand alone implementation that is not
>> rtp
>> >dependant.
>> >I am handling the rtp send & receive myself & need just the rtcp
>> >implementation.
>>
>> Such a thing is not possible - the rtcp implementation needs
>> information
>> from the rtp send/receive code to calculate the sender/reception
>> report
>> statistics.
>>
>> Colin
>
>

---

From: Henning Schulzrinne <[email-masked]>
Date: Wed, 25 Aug 1999 11:38:26 -0400

> on all RTP application programmers.

Parsing RTCP is not *that* bad. All of rtpdump
(http://www.cs.columbia.edu/~hgs/rtptools), which parses RTCP and RTP,
is only about 750 lines of code. There are now libraries, such as the
Bell Labs/Columbia RTP library, which allow you to "delegate" the task.

-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs