Subject: Named signaling events - minor request.

From: Bill Foster <[email-masked]>
Date: Mon, 06 Dec 1999 19:47:30 -0800

One minor comment/request for "draft-ietf-avt-tones-03.txt".

It would be nice to have a separate named signaling event (NSE) for ringing versus ring-back. 

The place where a NSE for ringback tone comes in useful is in a device control situation using MGCP or Megacop. The particular case is where the Media Gateway Controller (MGC) requests the media gateway (MG) to do ringback from the far end as follows:

Call between two residential media gateways MG A and MG B
- MG A originates a call to MG B
- once the MGC sets up a half duplex connection from MG B it requests ringing and ringback to MGB (in MGCP S: rg, rt@connection)
- if during the capabilities exchange earlier when the half duplex connection was set up (SDP passed between endpoints), the endpoints realized that they supported ringback tone using NSEs, they might use the NSE rather than a tone (some advantages in terms of use of bandwidth prior to call, as well as implementation advantages - MIPS required etc.).

On the other hand, the same MG may be used in other RTP trunking applications where an MGC may set up the trunk and NSE's used for signaling (e.g. ringing request passed across the RTP stream).

If we leave ringing and ringback as the same event that depends on context (like hook status) there are problems in the trunking application. If one end sends a ringing request to the other end - but when it gets there the person just happens to have gone off-hook (because they wanted to originate a call just as a call was coming in) - if the MG is left to interpret the meaning of the ringing NSE event based on hook-status - they will suddenly hear ringback - not quite what was intended.

In Summary:

Any chance of getting to separate NSE events - one for ringing and another for ringback - they are both useful but only if the are separate events.

Bill 
-----------------------------
Bill Foster
Phone: (408) 527-8791
Page:   (800) 365-4578
Fax:     (781) 998-6492

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 07 Dec 1999 22:05:35 -0500

> It would be nice to have a separate named signaling event (NSE) for ringing versus ring-back.

This seems reasonable. The only minor complications are naming (since
there's the potential for confusion between ringing tone = ringback and
"ring") and that this tone doesn't have a canonical representation. To
minimize the confusion, I used the term "alert". My suggested wording
is:

--- begin spec excerpt ---

\item[Alert:] This named signal event causes the recipient to generate
an alert signal (``ringing''). The
tone rendition is up to the receiver. (This differs from the ringing
tone, below, heard by the {\bf caller}.)

--- end excerpt ---

Please let me know if this definition is clear enough.

A meta comment: since the last call periods are over, I will now declare
a last and final chance. Any tone request, however reasonable, that
doesn't reach me by tomorrow 5 pm EST will not be included in this round
so that I can package up -04 and get this to the IESG, finally.
Additional requests will have to wait

-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs

---

From: Bill Foster <[email-masked]>
Date: Wed, 08 Dec 1999 08:42:13 -0800

Usually alerting is coming from the far end (callee to caller) as in Q.931.

How about:

Caller => Callee:        Ringing
Caller <= Callee:        Alerting

---

From: Henning Schulzrinne <[email-masked]>
Date: Wed, 08 Dec 1999 21:49:43 -0500

> Caller <= Callee:        Alerting
Unfortunately, the ITU specs (E.182, p. 2, item 7) seem to insist on
"ringing tone" as the tone heard by the caller, so I think this would be
rather confusing. Other suggestions are welcome.

Henning

---

From: Bill Foster <[email-masked]>
Date: Thu, 09 Dec 1999 09:21:56 -0800

What about:

Caller => Callee:        Power Ringing
Caller <= Callee:        Audible Ringing or Ringing Tone

---

From: "Gunnar Hellstrom" <[email-masked]>
Date: Thu, 9 Dec 1999 23:26:02 +0100

I suggest to keep as close as possible to already established nomenclature.
Proposal
Caller => Callee:        Ring
Caller <= Callee:        Ringing Tone
Motivation:
"RING" is the standardised message from a modem experiencing an incoming
ring. It also matches normal language. I.e. "I heard a ring".

"Ringing Tone" is the E.182 name for the tone back to the caller.
"Alerting" could be used for the same thing since it is the name of the
Q.931 message in that situation.
But we are talking about tones from the PSTN here, aren't we?

Gunnar Hellström

-----Original Message-----
From: Bill Foster [mailto:[email-masked]]
Sent: Thursday, December 09, 1999 6:22 PM
To: Henning Schulzrinne
Cc: [email-masked]
Subject: Re: Named signaling events - minor request.

What about:

---

From: Bill Foster <[email-masked]>
Date: Thu, 09 Dec 1999 15:03:29 -0800

Sounds fine.