Subject: RE: I-D ACTION:draft-ietf-avt-tones-03.txt,.ps

From: Gunnar Hellström <[email-masked]>
Date: Thu, 2 Dec 1999 10:58:32 +0100

A question on tones.
In the draft-ietf-avt-tones-03.txt, a set of modem and fax related tones are
specified.

I miss two modem related signals used by calling modems in the same way as
the faxes use the CNG tone:

The V.25 CT, Calling tone. 1300 Hz for 0.5 s with 2 s. intervals ( more
precisely defined in V.25).
All modems not starting with V.8 CI starts with this tone nowadays (at least
in Europe).

The V.8 CI. That is a V.21 (1) modulated signal. Therefore it could be
tranmitted as V.21 tones, but it might be of interest to have a specific
code for it with a parameter for the data contents of the CI.

Since their inclusion would complete the modem handshake support in the
tones spec, I suggest that they are added.

Regards
______________________________________________
Gunnar Hellström
Omnitor AB
Alsnögatan 7 ,  4 tr
S-116 41 Stockholm
Sweden

Tel +46 8 556 002 03
Mob: + 46 708 204 288
Txt and video +46 8 556 002 05
Fax +46 8 556 002 06

e-mail: [email-masked]
web:    www.omnitor.se

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of [email-masked]
> Sent: Tuesday, November 30, 1999 12:57 PM
> To: IETF-Announce: ;
> Cc: [email-masked]
> Subject: I-D ACTION:draft-ietf-avt-tones-03.txt,.ps
>
>
> A New Internet-Draft is available from the on-line
> Internet-Drafts directories.
> This draft is a work item of the Audio/Video Transport Working
> Group of the IETF.
>
> 	Title		: RTP Payload for DTMF Digits, Telephony Tones and
>                           Telephony Signals
> 	Author(s)	: H. Schulzrinne, S. Petrack
> 	Filename	: draft-ietf-avt-tones-03.txt,.ps
> 	Pages		: 28
> 	Date		: 29-Nov-99
>
> This memo describes how to carry dual-tone multifrequency (DTMF)
> signaling, other tone signals and telephony events in RTP packets.
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-avt-tones-03.txt
>
> Internet-Drafts are also available by anonymous FTP. Login with
> the username
> "anonymous" and a password of your e-mail address. After logging in,
> type "cd internet-drafts" and then
> 	"get draft-ietf-avt-tones-03.txt".
>
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
>
> Internet-Drafts can also be obtained by e-mail.
>
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE /internet-drafts/draft-ietf-avt-tones-03.txt".
>
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
>
>
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
>

---

From: Henning Schulzrinne <[email-masked]>
Date: Sun, 05 Dec 1999 18:34:59 -0500

> All modems not starting with V.8 CI starts with this tone nowadays (at least

I tentatively added this, but since it is not quite clear where the spec
is in the pipeline right now, it may be too late for this round. Adding
additional tones, however, can be done at any time, by normal IANA
registration procedures.

> code for it with a parameter for the data contents of the CI.

We currently don't really have tone parameters, so this would be
somewhat difficult to do.

-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs

---

From: Colin Perkins <[email-masked]>
Date: Mon, 06 Dec 1999 11:04:19 +0000

>additional tones, however, can be done at any time, by normal IANA

We were taking the latest draft as being a revision to address working group
last call comments, and something we could send to the IESG. If this is just 
a new tone, which has no impact on the rest of the document, it is appropriate 
to add it now and make one final revision to the document. 

Any additional tones after this should, in my opinion, be registered with IANA
rather than added to this draft.

>somewhat difficult to do.

Does this imply a need for parameters? Or are the cases which would require
them sufficiently unusual that they can always be defined as sequences of
the existing tones? I'm hesitent about making this draft more complex,
unless there is a definite need.

Colin

---

From: Gunnar Hellström <[email-masked]>
Date: Mon, 6 Dec 1999 14:34:44 +0100

OK,
1. For V.25 Calling tone:

Here is the definition of Calling Tone from V.25:  "The calling tone
consists of a series of interrupted bursts of binary 1 signal or 1300 Hz, ON
for a duration of not less than 0.5 s and not more than 0.7 s and OFF for a
duration of not less than 1.5 s and not more than 2.0 s."

In practice you can ignore the option of sending it as the "binary 1"
signal. All modems I know, transmit Calling Tone as 1300 Hz.
I believe the tones draft would gain by adding this definition, but I do not
want to hold up progress by requiring it.

2. V.8 CI.
This signal is meaningful only if communicated with its data contents.
It starts with a general CI identifier, but that is followed by contents
declaring possible modes and modulations. It is V.21 (1) modulated at 300
bits/s.
So, it may be true that the solution is to transmit it with the codes for
V.21 transmission.

Regards
Gunnar Hellström

Tel +46 8 556 002 03
Mob: + 46 708 204 288

> From: Colin Perkins [mailto:[email-masked]]
> Sent: Monday, December 06, 1999 12:04 PM
> To: Henning Schulzrinne
> Cc: m; [email-masked]
> Subject: Re: I-D ACTION:draft-ietf-avt-tones-03.txt,.ps
>
>

---

From: Henning Schulzrinne <[email-masked]>
Date: Mon, 06 Dec 1999 11:08:04 -0500

Colin Perkins wrote:

> to add it now and make one final revision to the document.

I'll await the outcome of this discussion and then submit -04 with this
change. This is indeed a trivial change.

> rather than added to this draft.

Agreed; or added when the draft progresses along the standards track,
assuming there's demonstrable need and usage.

> unless there is a definite need.

Adding a parameter would indeed require significant changes and
complexity. Also, this type of information is not really a tone anymore,
but basically a text or octet string of variable length.

I've had recent discussions about creating a third payload format (in
addition to the two in the current draft) suitable for caller-id. I
suspect that the V.8 CI fits there. My intent is to make this a separate
document, although many of the reliability and timing discussions from
the current draft will apply there, too. One of the items to be
discussed is whether caller-id is to be sent all at once or in the
"incremental" fashion we've used for DTMF. Caller-id consists of a
relatively long preamble, which consists of invalid characters, for
example, followed by roughly 30 to 40 information-bearing octets.

A summary of caller id can be found at
http://www-s.ti.com/sc/psheets/spra462/spra462.pdf

---

From: Colin Perkins <[email-masked]>
Date: Mon, 06 Dec 1999 17:32:18 +0000

>change. This is indeed a trivial change.

Okay.

>example, followed by roughly 30 to 40 information-bearing octets.

This seems to be a good approach, and one that won't hold up the current
tones payload format unnecessarily.

Colin

---

From: "Gunnar Hellstrom" <[email-masked]>
Date: Tue, 7 Dec 1999 00:26:36 +0100

Caller ID is sent in PSTN before or between the Rings. Some networks use
DTMF, other use V.22, I think. Usually consists of the caller´s telephone
number.

V.8 CI is V.21(1) modulated. Can be as little as two bytes. Starts with a CI
identifier. Still, your mechanism for V.21 transmission could carry it.

Regards
Gunnar

-----Original Message-----
From: Colin Perkins [mailto:[email-masked]]
Sent: Monday, December 06, 1999 6:32 PM
To: Henning Schulzrinne
Cc: m; [email-masked]
Subject: Re: I-D ACTION:draft-ietf-avt-tones-03.txt,.ps

Okay.

Colin