Subject: CRTP and QoS

From: Harish Manchaiah <[email-masked]>
Date: Mon, 07 Aug 2000 16:22:33 -0700

Hello,

I am new to this area, please pardon me if it is explained in some document 
I should have read properly.
I am having trouble understanding the requirements for CRTP and QoS.

CRTP is applied on link-by-link basis. Can multiple RTP/CRTP streams/flows 
come into a CRTP interface?
I am assuming it is a valid scenario. If this is true, do we need to apply 
QoS to each of these flows? RFC1889
states that rtp doesn't guarantee QoS or in-order delivery. Has this been 
discussed before? Can someone provide
some pointers to this please?

thank you,
-harish

---

From: Dan Wing <[email-masked]>
Date: Mon, 7 Aug 2000 13:47:15 -0700 (PDT)

> come into a CRTP interface?

Yes, that's why CRTP has a context-ID.

> QoS to each of these flows?

Yep.

> RFC1889 states that rtp doesn't guarantee QoS or in-order delivery.
> Has this been discussed before? Can someone provide some pointers to
> this please?

IP doesn't guarantee in-order delivery, neither does UDP, neither does
RTP.  If in-order delivery is important, the application has to rebuild
the packets in the correct order.  With RTP, this reconstruction is done
using the sequence number.

-Dan Wing

---

From: "rafi" <[email-masked]>
Date: Tue, 8 Aug 2000 11:55:23 +0530

If in order delivery is so important then
we can run RTP over TCP though
basic purpose might be defeated,  but
it all depends on what exactly the requirement
is.

Thanks
Rafi Assadi H.M.