Subject: RTCP interval testing in draft-ietf-avt-rtptest-03.txt

From: "Gert Olsson (ECS)" <[email-masked]>
Date: Wed, 16 Aug 2000 09:41:27 +0200

Hi,
just a small question about the RTCP transmission interval testing described in section 2.7.1 ('Basic Behavior') of:
http://www.ietf.org/internet-drafts/draft-ietf-avt-rtptest-03.txt

I have some problem understanding the last two of the four properties at the top of page 9. If applying the division by (e-3/2), mentioned in the new RTP draft, shouldn't the interval time be uniformly distributed between appr. 2.1 and 6.2 seconds (average appr. 4.1 seconds) ?

(If not applying the division, it is prop. 1,2 and 4 that don't make sense to me.) 

BR,

/GO
__________________________________________________________________|
Gert Olsson   /  phone: +46 46  23 24 97   /  e-mail: [email-masked]
Ericsson Mobile Communications AB, SE-221 83  Lund, Sweden

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 17 Aug 2000 03:01:06 -0400

> I have some problem understanding the last two of the four properties at the top of page 9. If applying the division by (e-3/2), mentioned in the new RTP draft, shouldn't the interval time be unifo…

No, it won't. Under static group memberships, the reconsideration
algorithm will cause the interval to be distributed *non-uniformly*.
This skewed distribution is critical to the operation of the algorithm.
The skew also moves up the average interval. The division by e-3/2 helps
reduce it again so it remains at the same value as if there were no
reconsideration. 

-Jonathan R.

-- 
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
http://www.dynamicsoft.com