Subject: [AVT] comments on draft-ietf-avt-mpeg4-simple00.txt

From: "Dorairaj V" <[email-masked]>
Date: Fri, 1 Feb 2002 13:40:13 +0530

Hi ,

In the document draft-ietf-avt-mpeg4-simple00.txt

Section 3.2.1.1 : 

1) AU-Index :
There is a statement which says " To encode the serial number in any 
         such non-first AU-header, the AU-Index-delta field is used. 
         When each AU-Index field is coded with the value 0, the serial 
         number of the AU (fragment) is not specified and in that case 
         receivers MAY ignore the AU-Index field. "

Section 3.3.6 on High-bit-rate AAC says contains the following statement 
"Each AU-Index field MUST be coded with the value 0" . which implies that receivers MAY ignore the AU-Index field .

In the above case it is not clear as to what is the utiliy of "AU-Index" field for High-bit rate AAC  .
If AU-Index field has to be 0 , then the better option would be to have "AUIndexLength" = 0 instead of having "AU-Index"  field as 0 .

2) Section 3.2.1.1 : 
AU-Index-delta :
"If the AU-Index field is present in the first AU-header in 
         the AU Header Section, then the AU-Index-delta field MUST be 
         present in any subsequent (non-first) AU-header. When the 
         AU-Index-delta is coded with the value 0, it indicates that 
         the Access Units are consecutive in time"

If interleaving is not used then instead of using IndexDeltaLength > 0 and then setting  the IndexDeltaLength field to 0 , it is better to have IndexDeltaLength = 0 .
I dont see any utility in having IndexDeltaLength > 0 when you dont have any intention of using interleaving .

3) 
It would be clear if the different media which are convered under the term "mpeg-generic" (Used in a=rtpmap:96 , mpeg-generic ... )are mentioned . Do AAC-LC , MPEG4 CELP  fall under mpeg-generic . 

With regards
Dorai

---

From: [email-masked]
Date: Mon, 4 Feb 2002 16:19:07 +0100

Dear Dorai,

Thanks for your comments. Please find my reply below:

Comment 1);
You suggest that if AU-Index field has to be 0, then the better option would be to have "AUIndexLength" = 0 instead of having "AU-Index" field as 0. From conceptual point of view your suggestion makes sense. However, the solution in the draft was selected
to simplify parsing of the AU header. If the AU-index field is absent for the first AU, and if the AU-index-delta field is present for any subsequent AU, then the number of bits in the AU-header is not the same for each AU. This complicates parsing and
therefore the current solution was chosen. I agree that this choice needs some explanation in the draft.

Comment 2);
Again you are right from conceptual perspective. This was chosen for simplicity reason, and also this choice may need explanation in the draft. For AAC and CELP it was decided to use one or two bytes per AU-header, independent of the usage of
interleaving. It means that the AU-index-delta field is also present if no interleaving is applied, and the consequence of that is is that the value of AU-index-delta needs to be coded with the value 0. On the other hand this constraint allows
applications to swith off interleaving for a short period, and concatenate subsequent frames in one RTP packet, but I am not sure how useful that feature is.

Comment 3);
The draft can be used to transport any MPEG-4 stream under the term "mpeg-generic"; in principle, the draft can even be used to transport future, not yet defined MPEG-4 streams. So a list of media can be provided, but that will be only a list of examples,
not an exhaustive list. But AAC and CELP are certainly in that list.

In due time I will incorporate your suggestions in a new release of the draft. Thanks again for your comments; if you have further questions, please let me know.

Kind regards,

Jan

Jan van der Meer
Philips Digital Networks - MP4Net
Prof Holstlaan 4
Building WDB-1
P.O. Box 80002
5600 JB Eindhoven
The Netherlands
Phone +31 402 735 774
Fax +31 402 735 545

                    "Dorairaj V"                                                                                   
                    <dorai@sasken           To:  <[email-masked]>                                                    
                    .com>                   cc:  (bcc: Jan vanderMeer/EHV/BE/PHILIPS)                              
                    Sent by:                Subject:  [AVT] comments on draft-ietf-avt-mpeg4-simple00.txt          
                    avt-admin@iet                                                                                  
                    f.org                   Classification:                                                        

                    2002-02-01                                                                                     
                    09:10 AM                                                                                       

Hi ,

Section 3.2.1.1 :

1) AU-Index :

2) Section 3.2.1.1 :
AU-Index-delta :

3)

With regards
Dorai

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt