Subject: [AVT] MWPP notes ...

From: John Lazzaro <[email-masked]>
Date: Tue, 12 Feb 2002 10:28:54 -0800

> [email-masked] writes:
>
>         Title           : The MIDI Wire Protocol Packetization (MWPP)
>         Filename        : draft-ietf-avt-mwpp-midi-rtp-00.txt
>
> http://www.ietf.org/internet-drafts/draft-ietf-avt-mwpp-midi-rtp-00.txt

This version has large sections rewritten compared to the version I
talked about in Salt Lake, in response to both IETF feedback and      
feedback from MIDI developers ... too many changes to list here, see
Section 0 of the memo for a list of what's new and what's left to do ...

-------------------------------------------------------------------------
John Lazzaro -- Research Specialist -- CS Division -- EECS -- UC Berkeley
lazzaro [at] cs [dot] berkeley [dot] edu     www.cs.berkeley.edu/~lazzaro
-------------------------------------------------------------------------

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Dominique Fober <[email-masked]>
Date: Thu, 14 Feb 2002 11:24:02 +0100

>Section 0 of the memo for a list of what's new and what's left to do ...

Hi,

Some questions and comments about draft-ietf-avt-mwpp-midi-rtp-00.txt.

>6. Session Description Protocol for RTP Transport
>...
>The binary parameter <rj> codes the presence (1) or absence (0) of the
>recovery journal section in MWPP packets.

Isn't it redundant with the G bit of the recovery kournal ? Moreover, the policy concerning recovery may change during a session as mentionned section 5.

>9. Congestion Control
>...
>MWPP implementations SHOULD sense the MIDI wire procotol stream for
>command patterns that result in excessive packet rates, and filter these
>streams as part of MWPP to reduce the packet rate.

In particular, control change and pitch bend commands may raise the congestion problem. Such flow is generaly made up of continuous variations. Filtering is one solution but it would usefull to provide a policy in appendix (normative or not ?): raw filtering of one message type ? or filtering part of a set of messages so as to keep the global shape of the variation ?

>Appendix A.3. Chapter N: MIDI NoteOff and NoteOn
>...
>The 4-bit fields LOW and HIGH determine the number of bitfield bytes
>that follow the note logs. A bitfield byte codes NoteOff information for
>eight consecutive MIDI note numbers, with the MSB representing the
>lowest note number. The MSB of the first bitfield byte codes the note
>number 16*LOW; the MSB of the last bitfield byte codes the note number
>16*HIGH.

Why 16*LOW and 16*HIGH ? as 8*LOW and 8*HIGH is enough and may save one byte.
For example:
coding a note off 8 in the first case would be:
LOW=0
HIGH=0
bitfield: 0x00 0x70	(2 bytes are necessary)
while in the second case:
LOW=1
HIGH=1
bitfield: 0x70	(1 bytes only)
The midi pitch range (0-127) is covered by the fact that HIGH is related to the last bitfield MSB. Therefore, coding a note off 127 would be:
LOW=15
HIGH=15
bitfield: 0x01

>Appendix A.6. Chapter C: MIDI Control Change
When you talk about controlers, could you add the control number to their name ? (less ambiguity to the reader: the Sustain pedal is commonly named Sustenuto on/off (#66) for example).
I can't understand the purpose of the VALUE/COUNT field for some controlers: it's sometimes used like a serial number, is it to improve reliability ? but isn't it redundant with the Checkpoint Packet Seqnum ?

>Appendix C. References
You can add to reference 8: "Proceedings of the International Conference on WEB Delivering of Music 2001, pages 147-154"

And some more general comments:
Support of system common and real-time messages would provide a nearly complete MIDI support. 

Great work !

----------------------------------------------
Dominique Fober               <[email-masked]>
----------------------------------------------
GRAME - Centre National de Creation Musicale -
9 rue du Garet  69001 Lyon France
tel:+33 (0)4 720 737 06 fax:+33 (0)4 720 737 01
http://www.grame.fr