Subject: [AVT] Arguments on SL

From: HAINING LIU <[email-masked]>
Date: Tue, 19 Feb 2002 01:27:21 -0500 (EST)

Hello,

Can anyone point out the benefits SL bring to us comparing with the
current solution of no sl layer in Mpeg-4 application (i.e. mp4 file
streaming)? It seems that a design w/o sl layer still works fine,
especially a system over IP networks.

Certainly we have to build SL layer to be compliant with MPEG-4 systems
standard, but that will also bring us complexity when mapping over
RTP. Any strong arguments or useful pointers is highly appreciated.

Regards,

Haining

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: ROUX Catherine FTRD/DMI/REN <[email-masked]>
Date: Tue, 19 Feb 2002 10:57:49 +0100

Using Synchronisation Layer becomes necessary when the 
sampling is not made at constant rate.
because in this case you have to transmit the timeStamp to 
Display at the good time.

-----Message d'origine-----
De : HAINING LIU [mailto:[email-masked]]
Envoye : mardi 19 fevrier 2002 07:27
A : [email-masked]
Cc : [email-masked]
Objet : [AVT] Arguments on SL

Hello,

Regards,

Haining

---

From: [email-masked]
Date: Tue, 19 Feb 2002 12:52:08 +0100

Catherine,

I have to disagree because RTP alone can do that ...

SL becomes "necessary" as soon as you do more than audio + video
specifically if you use MPEG-4 system stuff 

regards,

Philippe Gentric
Software Architect
Philips MP4Net
[email-masked]
http://www.mpeg-4.philips.com

ROUX Catherine FTRD/DMI/REN <[email-masked]>
Sent by: [email-masked]
02/19/2002 10:57

        To:     "'HAINING LIU'" <[email-masked]>
        cc:     "[email-masked]'" <[email-masked]>
(bcc: Philippe Gentric/LIM/CE/PHILIPS)
        Subject:        RE: [AVT] Arguments on SL
        Classification: 

-----Message d'origine----- 
De : HAINING LIU [mailto:[email-masked]] 
Envoye : mardi 19 fevrier 2002 07:27 
A : [email-masked] 
Cc : [email-masked] 
Objet : [AVT] Arguments on SL 

Hello,