Subject: RE: [AVT] WG last call on draft-ietf-avt-srtp-04.txt - choice of init ial sequence number

From: "Elisabetta Carrara (ERA)" <[email-masked]>
Date: Thu, 23 May 2002 13:04:47 +0200

Hello Martin,
yes, the issue has been considered some time ago.
However, our conclusion was to try to 'mix up' SRTP with
RTP as little as possible (you might remember the discussion of
guaranteeing unique SSRCs, with its signalling at the key management time).

We prefer not to inflict non-standard RTP behavior from the
SRTP implementation if possible.

If you choose an almost-wrapping seq number, you might need some packets before
gaining the synch (it depends on how smart is your ROC-updating algorithm, not
trivial sure), or you might loose the synch totally. As alternative, section 8:

*For initialization, an interoperable SRTP implementation SHOULD be given the SSRC
and MAY be given the initial RTP sequence number for the RTP stream by key
management (thus, key management has a dependency on RTP operational parameters). *

What you mention is also an additional motivation to why we should not
 mandate a fixed ROC update algorithm in SRTP. One should be allowed
 to use any or all information available to solve this problem, e.g.
 feedback from (S)RTCP (which is robust in this sense) when available.

Cheers.

> -----Original Message-----
> From: Euchner Martin ICN M SR 3 [mailto:[email-masked]]
> Sent: den 23 maj 2002 10:19
> To: Euchner Martin ICN M SR 3; [email-masked]'; [email-masked]';
> [email-masked]'; [email-masked]';
> [email-masked]'; [email-masked]';
> [email-masked]'
> Subject: [AVT] WG last call on draft-ietf-avt-srtp-04.txt - choice of
> init ial sequence number
> 
> 
> 
> SRTP allows to use arbitrary initial sequence number from the 
> 16-bit range.
> It has been observed that not each potential initial sequence 
> number may be
> equally well suited. For example, there is concern that the 
> choice of an
> initial sequence number that would immediately wrap around 
> with the next
> packet, might lead to problems for the receiver in estimating 
> the sequence
> number, especially on error prone links where is initial RTP 
> packet gets
> lost. Thus, it is probably better (more reliable) to choose an initial
> sequence number that is a certain distance away from the 
> wrap-around point.
> 
> Has this been taken already into consideration?
> 
> 
> 
> With kind regards
> 
> Martin Euchner.
> --------------------------------------------------------------
> ---------
> | Dipl.-Inf.                     Rapporteur Q.G/SG16
> | Martin Euchner                 Phone: +49 89 722 55790
> | Siemens AG.....................Fax  : +49 89 722 47713
> | ICN M SR 3                     mailto:[email-masked]
> |                                mailto:[email-masked]
> | Hofmannstr. 51                 Intranet:
> http://intranet.icn.siemens.de/marketing/cs27/topics/security/
> | D-81359 Muenchen               Internet: http://www.siemens.de/
> | __________________
> | Germany     
> --------------------------------------------------------------
> ---------
> 

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Euchner Martin ICN M SR 3 <[email-masked]>
Date: Fri, 24 May 2002 11:27:08 +0200

Hello Elisabetta,

yes I understand your arguments and there appears indeed some caution upon
the choice of the initial sequence number depending on the implementation of
the end point and several conditions on the packet loss rate etc. Thus, to
be on the safe side, it appears not wrong to choose the initial sequence
number at some distance apart from the wrap-around point (this should not
weaken the security). Since determination of the initial sequence number
(and SSRC is some cases) is more an issue for the key management, it is
probably worth noting there somewhere.

However, I was not requesting to standardize any particular ROC updating
algorithm and there is no need to do so. In my eyes, SRTP-04 gives an idea
of a non-normative example algorithm, leaving plenty degrees of freedom for
different (i.e. simpler or more complex, improved what-so-ever) algorithms.

With kind regards

Martin Euchner.
-----------------------------------------------------------------------
-----------------------------------------------------------------------

 -----Original Message-----
From: 	Elisabetta Carrara (ERA) [mailto:[email-masked]]

Sent:	Thursday, May 23, 2002 1:05 PM
To:	Euchner Martin  ICN M SR 3; [email-masked]'
Cc:	[email-masked]'; Rolf Blom (ERA); [email-masked]'; Mats
Näslund (ERA); Karl Norrman (ERA)
Subject:	RE: [AVT] WG last call on draft-ietf-avt-srtp-04.txt -
choice of  init ial sequence number

Hello Martin,

If you choose an almost-wrapping seq number, you might need some packets
before
gaining the synch (it depends on how smart is your ROC-updating algorithm,
not
trivial sure), or you might loose the synch totally. As alternative, section
8:

*For initialization, an interoperable SRTP implementation SHOULD be given
the SSRC
and MAY be given the initial RTP sequence number for the RTP stream by key
management (thus, key management has a dependency on RTP operational
parameters). *

Cheers.