Subject: Re: [AVT] RTP over TCP.

From: "Peter Westerink" <[email-masked]>
Date: Tue, 14 May 2002 16:03:01 -0400

Ram,

I believe such a profile existed in draft-ietf-avt-profile-new-09.txt, but
it was removed in version 10 because "there were no 2 implementations".
There were no technical reasons mentioned. The draft proposed prepending
each RTP packet with a 2-byte length and that's all.

IBM is interested in the same thing you're after, and I can assume there
are more MPEG-4 companies that also would want to send their BIFS and OD
streams reliably (albeit not guaranteed on-time) over TCP. With that we
should be able to come up with 2 implementations and hence re-instate the
profile?

      Peter

                      Ram Kordale                                                                                           
                      <kordale@kasenna.        To:       Ross Finlayson <[email-masked]>                                
                      com>                     cc:       <[email-masked]>, [email-masked]                                
                      Sent by:                 Subject:  Re: [AVT] RTP over TCP.                                            
                      [email-masked]                                                                                     
                      g                                                                                                     

                      05/14/2002 03:50                                                                                      
                      PM                                                                                                    

Ross,

Section 10.12 describes only the interleaving case. What about the case
where RTP and RTCP data need to be transferred on separate TCP connections?

This will need a separate profile. Does such a profile exist?

Thanks.
Ram

At 12:17 PM 5/8/2002 -0700, Ross Finlayson wrote:
>At 10:45 AM 5/8/02, Ethen Bommaiah wrote:
>>I was curious to know if there were any standard profiles that define
>>transferring RTP
>>packets over TCP. In particular, we were interested in transferring RTP
data
>>over TCP
>>while using RTSP as the control protocol.
>
>Yes - see section 10.12 of the RTSP specification (RFC 2326).  This
>defines how RTP packets may be carried over the RTSP (TCP) stream.  (This
>is actually not a new RTP 'profile', but instead, an optonal mechanism
>defined within RTSP.)
>
>         Ross.
>
>
>_______________________________________________
>Audio/Video Transport Working Group
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/avt

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Ram Kordale <[email-masked]>
Date: Thu, 16 May 2002 15:58:39 -0700

Peter,

This is very good. We will certainly commit to an implementation. If you 
can forward a copy of draft-ietf-avt-profile-new-09.txt, that will be great.

Ram

At 04:03 PM 5/14/2002 -0400, Peter Westerink wrote:

> Kordale 
>                       05/14/2002 
> 03:50