Subject: RE: [AVT] WG last call on draft-ietf-avt-srtp-04.txt - synchroniz ation of key derivation algorithm

From: Mats Näslund (ERA)<[email-masked]>
Date: Thu, 30 May 2002 00:18:15 +0200

Hi Oleg,

Many thanks for your comments/questions.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: den 29 maj 2002 19:17
> To: David A. Mcgrew; [email-masked]; [email-masked];
> [email-masked]; [email-masked];
> [email-masked]; [email-masked];
> [email-masked]
> Subject: [AVT] WG last call on draft-ietf-avt-srtp-04.txt -
> synchronization of key derivation algorithm
> 
> 
> 
> Hi there,
> 
> I have some questions concerning key derivation algorithm of the srtp
> draft:
> 
> - The key derivation starts from definition of packet index 
> as 48-bit ROC
> || SEQ. What SEQ will be applied on transmit and receive sides?

In both cases: the SEQ of the RTP packet to be processed. That is
clear if you look at the packet processing which states what parameters
to be used for the session key derivation. 

(Also, it is as far as I can tell the only reasonable interpretation.)

> - What is a synchronization algorithm in case of some first 
> packet loss?

The receiver takes the SEQ from the first received packet as 
intial value for s_l, unless the initial SEQ is sent out of band.
This is clearly stated in the I-D, but as pointed out by Martin Euchner, it
is (like the rest of the "implicit" index approach) not 100% error-robust.
 
> 
> - What is a start point for counting every r-th packet for derivation
> function reiteration if derivation rate r>0 and some first 
> packet are lost?

Refer to the spec. We *always* use "index DIV r". The
non-normative description "every r-th packet" is an average statement
and does not apply to the first few packets. The normative specification 
is unambigous though. 

Note that it is impossible to make it "every r-th packet" for all receivers,
since a receiver can join the session at any time and may need to do two
derivations in a row if he is "unlucky", regardless of what "r" is.

Best,

/Mats

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: "David A. Mcgrew" <[email-masked]>
Date: Thu, 30 May 2002 05:42:11 -0700

Oleg,

...
> is (like the rest of the "implicit" index approach) not 100% error-robust.

in particular, srtp's index-guessing approach will fail if there is a burst
loss of 32,768 packets, or the same amount of re-order.    And if there's
re-order in the initial packets of the flow, then srtp will drop some of
those, effectively turning re-order into loss.

David