Subject: [AVT] time stamp

From: "Bill Cunningham" <[email-masked]>
Date: Wed, 22 May 2002 01:29:56 -0400

Is the time stamp in the AVT frame determined by NTP or network time
protocol?

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Colin Perkins <[email-masked]>
Date: Wed, 22 May 2002 07:03:58 -0700

>Is the time stamp in the AVT frame determined by NTP or network time

No. The timestamp is RTP packets is payload format dependent. That in RTCP
packets uses the format of NTP, but is not required to be NTP synchronized.

Colin

---

From: "Srikrish" <[email-masked]>
Date: Wed, 22 May 2002 18:17:48 -0700

Should the RTP Time stamp in RTCP packet matches with
RTP Time stamp in data stream?

If RTP is done in hardware ( chip set) and  RTCP in
slow path (host processor) how can we sync-up
this RTP Time stamp?

Can anyone please suggest.

Regards
Sriks

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Colin
Perkins
Sent: May 22, 2002 7:04 AM
To: Bill Cunningham
Cc: [email-masked]
Subject: Re: [AVT] time stamp 

Colin

---

From: [email-masked]
Date: Thu, 23 May 2002 10:47:25 +0300 (EEST)

> Can anyone please suggest.
There may be two solutions:
1) you provide a procedure(through the chipset driver) for the host
processor to read the current RTP timestamp from the hardware.
You will use this solution if you want a very PRECISE RTCP interval.
So, whenever the host processor decides to send an RTCP packet, all it
has to do is to get the current RTP timestamp from hardware.

2) if you don't want a precise RTCP interval, then you will syncronize
with the RTP flow generated by hardware(THIS MAY NOT WORK if
the silence suppresion is activated!!!!).
Lets say that RTCP interval is 3 sec and RTP packet time is 30 ms
and without silsup. In this case you will send one RTCP packet at
100 RTP packets. And you will use as RTP timestamp in the TCP packet the
RTP timestamp of the last RTP packet sent by the hardware.

I think solution #1 is better.

NOTE: the (RTP_timestamp / 8) != NTP_timestamp(ms) !!!
(because there is an innevitable clock skew between the 2 clocks:
hardware sampling clock and host clock)

Dan Firac,
Software Engineer,
Redline Communications, Romania.