Subject: [AVT] Retransmission drafts

From: Go Hori <[email-masked]>
Date: Wed, 29 May 2002 14:26:12 -0700 (PDT)

Hi everyone,

David's email below suggests that there will continue to be two drafts, to
represent the "two approaches":

1.  draft-ietf-avt-rtp-retransmission-00.txt - This proposes a separate
RTP session as a resend channel , and provides no mechanism for selective
retransmission
2.  draft-ietf-avt-rtp-selret-04.txt - This proposes a framework for
retransmission requests/responses, which may (or may not) be sent in the
same RTP session, and which may (or may not) use selective retransmission

Looking at this, selret-04 represents four different approaches:

               1. Unmarked     2. Selective
             +--------------+--------------+
A. Inband    |     A1       |     A2       |
             +--------------+--------------+
B. Separate  |     B1       |     B2       |
             +--------------+--------------+

The retransmission-00 draft only provides for "A1", whereas selret-04
provides for all approaches ("A1", "A2", "B1", and "B2").

It seems that there are more than two approaches here, and that using
retransmission-00 prescribes exactly one approach (which is a good thing
in a standard), but maybe prescribes the wrong approach.

However, selret-04 doesn't prescribe an approach.  While that makes it
agreeable to everyone, it doesn't foster interoperability.

So, what is the current path to choosing a single approach and sticking to
it?

Go
---------- Forwarded message ----------
Date: Thu, 25 Apr 2002 16:51:54 -0500
From: "[email-masked]" <[email-masked]>
To: "[email-masked]" <[email-masked]>,
     "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>,
     "[email-masked]" <[email-masked]>
Subject: [AVT] RE: Retransmission Format

Bill,

Thanks for your comments.
At the last AVT meeting, we proposed to merge the two drafts within a single draft. However, it was felt that it would be more clear to keep the two approaches into two separate documents. Both drafts will be resubmitted with an applicablity statement.
As far as the 4-byte alignement is concerned, we have chosen to minimise the overhead. This can be worthwile when the RTP header is compressed and the payload is small.
It is hard to tell how many extension bits it is reasonable to define. However, provided that one extension bit is defined I guess we are safe as any future extension may define its own extension bit.

Regards, David.

> -----Original Message-----
> From: ext Bill Foster [mailto:[email-masked]]
> Sent: Thursday, April 25, 2002 4:12 PM
> To: Leon David (NRC/Dallas); Varsa Viktor (NRC/Dallas)
> Cc: Naoshad Mehta; [email-masked]; [email-masked]
> Subject: Retransmission Format
>
>
> David, Victor:
>
> The retransmission format you have suggested in
> draft-ietf-avt-rtp-retransmission-00.txt has an odd number of bytes -
> rather than sitting on the normal 4 byte boundary. In
> addition, there may
> be some need in the future for more than one bit for
> extensions. I would
> like to see that remaining byte left as reserved and the
> retransmission
> header end at the 4 byte boundary. This will make life easier
> for some
> implementations w.r.t. development and performance and allows
> for potential
> extensions later on.
>
> The format is almost the same as in
> draft-ietf-avt-rtp-selret-03.txt. Is
> there an intent to merge the formats? The same comment
> applies to that
> draft. It appears that the formats are pretty much the same
> anyway except
> for the meaning of X versus E bit. In either case, I would
> like to see
> headers end on a four byte boundary (preferably one format
> even though the
> drafts appear to be addressing slightly different applications).
>
> Bill
> -----------------------------
> Bill Foster
> Phone: (250) 758-9418
> Fax:     (781) 998-6492
>
>

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Jose Rey <[email-masked]>
Date: Fri, 31 May 2002 11:28:12 +0200

Dear Go and all,

	the draft-ietf-avt-selret-04.txt is actually the draft as it was BEFORE the
IETF#53. Somehow the submission got lost in the I-D queue and didn't got
published until now.

	The new draft-ietf-avt-selret-05.txt is being drafted and it complies with
the changes agreed in IETF#53, namely:

- removal of the 2 session approach
- inclusion of an applicability statement

cheers,

Jose? Rey
Mobile Multimedia Team -  MCOM Group
Panasonic European Laboratories GmbH
-
[email-masked]
www.pel.panasonic.de
-
Tel: +49(0)6103-766-134
Fax: +49(0)6103-766-166
--

> -----Ursprungliche Nachricht-----
> Von: [email-masked] [mailto:[email-masked]]Im Auftrag von Go
> Hori
> Gesendet: Mittwoch, 29. Mai 2002 23:26
> An: [email-masked]
> Betreff: [AVT] Retransmission drafts
>
>
> Hi everyone,
>
> At the last AVT meeting, we proposed to merge the two drafts
> within a single draft. However, it was felt that it would be more
> clear to keep the two approaches into two separate documents.
> Both drafts will be resubmitted with an applicablity statement.
> As far as the 4-byte alignement is concerned, we have chosen to
> minimise the overhead. This can be worthwile when the RTP header
> is compressed and the payload is small.
> It is hard to tell how many extension bits it is reasonable to
> define. However, provided that one extension bit is defined I
> guess we are safe as any future extension may define its own
> extension bit.
>
> Regards, David.
>