Subject: Re: [AVT] Audio Payload format design

From: [email-masked]
Date: Fri, 3 May 2002 17:46:33 +0200

would you put in the mandate that such an effort not only cover 
interleaving but also aggregation
(as a special degenerate case of interleaving) ?

Philippe Gentric
Software Architect
Philips MP4Net
[email-masked]
http://www.mpeg-4.philips.com

Colin Perkins <[email-masked]>
Sent by: [email-masked]
05/03/2002 16:48

        To:     Orion Hodson <[email-masked]>
        cc:     [email-masked]
(bcc: Philippe Gentric/MP4-SUR/DN/PHILIPS)
        Subject:        Re: [AVT] Audio Payload format design
        Classification: 

--> Orion Hodson writes:
>/-- Magnus Westerlund wrote:
...
>| I would suggest that you collect the ideas about having a generic 
>| interleaving format into a draft. I guess that document should also 
give 
>| suggestions and motivations behind why you should design in the way you 

>| argue. Then we can have a discussion about in the WG if it is an 
>| appropriate way. My comments to your suggestion about self describing 
>| frames is that it may still require a format specific payload header, 
>| for example to handle something like the codec mode request field in 
>| AMR. Then we can also see how applicable the ideas is for any future 
>| format to be standardized.
>
>This is a perfectly reasonable suggestion.  I have an old interleaving 
draft 
>that would be improved with the codec/payload request feature of 
EVRC/SMV's 
>interleaver.

I think it's too late to change EVRC now, but I encourage you to submit 
the
generic interleaving draft anyway. We've been missing a non-format 
specific
interleaver, resulting in the need to define them in several payload 
format
drafts.

Colin

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Colin Perkins <[email-masked]>
Date: Tue, 07 May 2002 00:25:58 +0100

I'd hope that aggregation could be done more efficiently than interleaving.
Colin