Subject: [AVT] Talkspurt indication for SID packets ????

From: Bino george <[email-masked]>
Date: Fri, 17 May 2002 03:11:02 -0700 (PDT)

Hello :

      In VAD enabled scenario periodic or random SID/CNI packets will come.

      What will be the general approach to this SID/CNI packets ?? Are they have to represent

      a new talkspurt { Marker Bit enabled state }?

      The receiver can find out the Silence Gap from the Timestamp/SeqNumber combination, and 

      the talkspurt indication can give, when real speech starts. 

     Which will be the widely using concept and  What are the tradeoffs??

     I felt the silence gap detection from Timestamp/Seqnum combination may fail

    in variable packetization intervel.

Regards.

bino

Bino George 

Work: 91-080-6788342 
"The Individual will most likely survive longer than the corporation"

---------------------------------
Do You Yahoo!?
LAUNCH - Your Yahoo! Music Experience

---

From: Magnus Westerlund <[email-masked]>
Date: Tue, 21 May 2002 10:05:32 +0200

Hi Bino,

When the VAD (Voice Activity Detector) detects a silence period a 
initial SID/CNI packets should be sent to indicate the start of the 
silence period. This SID/CNI contains noise energy and often spectral 
information to apply to the noise. As the background noise can change in 
energy and spectrum it is normal to send periodic updates (AMR sends 
every 8th frame) as long as the silence period remains. When the silence 
periods ends and a new talkspurt comes you simple start sending the 
encoded speech instead.

The marker bit shall not be used for SID/CNI packets that are sent 
within the same RTP session as the speech. In this case the marker bit 
should only be set for the first packet containing speech in a talkspurt.

A receiver will detect the silence suppression in two ways. First the 
planned way. After the last speech packet in the talkspurt it will 
receive a SID/CNI packet. After that it will no that it should replace 
all missing frames/samples with comfort noise until a speech packet is 
received again. Secondly the first SID/CNI can be lost and the receiver 
will be forced to go into error concealment. After concealing several 
frames it will end up in a state much like comfort noise. As soon a 
SID/CNI update is received it will know to switch to comfort noise 
generation.

I hope this helps

Magnus

Bino george wrote:

> ------------------------------------------------------------------------
> Do You Yahoo!?
> LAUNCH <http://rd.yahoo.com/welcome/*http://launch.yahoo.com> - Your 
> Yahoo! Music Experience 

-- 

Magnus Westerlund 

Multimedia Technologies, Ericsson Research ERA/TVA/A
----------------------------------------------------------------------
Ericsson Radio Systems AB  | Phone +46 8 4048287
Torshamsgatan 23           | Fax   +46 8 7575550
S-164 80 Stockholm, Sweden | mailto: [email-masked]

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Bino george <[email-masked]>
Date: Tue, 21 May 2002 02:10:41 -0700 (PDT)

Hello magnus: 
      Thank you very much. I thought my question was completely outdated, because 
 no one replied for 2/3 days. 
       I understood your mail clearly, But I have to explain the problem I am facing. 
 I have to differentiate between jitter buffer underruns caused by silence from the original underruns. 
 I am counting the Jitter Buffer underruns whenever the Buffer doesnot have any frames to play, But 
 I will invalidate this counts whenever a new talkspurt coming, Because I know the underruns are 
 because of silence and not because of my faulty estimation. But this normal logic will fail when the 
SID/CNI frames will not contain talkspurt indication. ie why I am trying to get confirmation about this. 
I understood the idea of talkpurt indication for  real speech starts, not on SID/CNI frames. 
Please give me a suggestion how can I estimate the silence gaps most correctly, considering all the aspects 
- like SID/CNI frames ,  the variable packetization-  etc- 
bino

  Magnus Westerlund <[email-masked]> wrote: Hi Bino,

I hope this helps

Magnus

-- 

Magnus Westerlund 

Bino George 

Work: 91-080-6788342