Subject: RE: [AVT] SRTP and ICMP destination unreachable ...

From: John Lazzaro <[email-masked]>
Date: Wed, 30 Oct 2002 10:53:33 -0800

> "Elisabetta Carrara (EAB)" writes:                             
>
> I think it is sometimes practice not to take drastic
> actions based on unauthenticated ICMP messages.

It might be a good idea to include text somewhere in
the SRTP Security Considerations to bring this point
up explicitly -- the ECONNREFUSED issue is special
because it is visible to the applications programmer
via errno, and not all implementors will realize that
the underlying source of an ECONNREFUSED is an 
unauthenticated ICMP packet. A sentence reminding them
could only help ... 

-------------------------------------------------------------------------
John Lazzaro -- Research Specialist -- CS Division -- EECS -- UC Berkeley
lazzaro [at] cs [dot] berkeley [dot] edu     www.cs.berkeley.edu/~lazzaro
-------------------------------------------------------------------------
_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Mark Baugher <[email-masked]>
Date: Thu, 31 Oct 2002 08:29:01 -0800

I agree.

Mark