Subject: [AVT] Key management in SRTP

From: "BUYCK Jacky FTRD/DMI/CAE" <[email-masked]>
Date: Tue, 8 Oct 2002 15:29:58 +0200

Hi all.
I'm looking on the way to secure RTP / RTCP sessions and I've found the SRTP Draft.
I've read it but I still have a problem with one point that don't seem to be clear for me.

I've understand how session's keys are generate and how all the mechanisms of encryption and signature are performs but I don't understand HOW initial masters keys are exchange ?
Nowhere in the SRTP draft is specify key exchange protocols or something like this. Or I've  not see an important part in the draft.

Does it rely on external protocol like SIP / SAP / SDP ? 
Or is there a key exchange mechanism in the SRTP protocol ?

Really thanks to u.

Jacky BUYCK
France Telecom R&D - Caen - DMI/SIR/SSI
42 Rue des Coutures - BP 6243 - 14066 Caen Cedex 4
Telephone : 02.31.75.93.61
Fax : 02.31.75.06.31

---

From: "Elisabetta Carrara (EAB)" <[email-masked]>
Date: Tue, 8 Oct 2002 16:18:38 +0200

Hi!
see answers below

>-----Original Message-----
>From: BUYCK Jacky FTRD/DMI/CAE [mailto:[email-masked]]
>Sent: den 8 oktober 2002 15:30
>To: [email-masked]
>Cc: [email-masked]; [email-masked]; [email-masked]
>Subject: [AVT] Key management in SRTP

>I've understand how session's keys are generate and how all 
>the mechanisms of encryption and signature 

There is no signatures in SRTP, only a message authentication tag 
for integrity protection

>are performs but I don't understand HOW initial masters keys 
>are exchange ?
>Nowhere in the SRTP draft is specify key exchange protocols 
>or something like this. Or I've  not see an important part in the draft.

You are correct, SRTP is decoupled from key management protocols.
In principle, you can use the key management you want. 

>Does it rely on external protocol like SIP / SAP / SDP ?

"no", see below.

>Or is there a key exchange mechanism in the SRTP protocol ? 

no, SRTP is a security protocol.
In the back you need a key management, but SRTP does not define it.

Up to now, the MIKEY protocol (MSEC WG) supports SRTP, and MIKEY
can be piggybacked in SIP/RTSP (work in progress in the MMUSIC WG).
There is also a recent draft by Mark Baugher, still in the MMUSIC WG,
that exchanges keys and parameters in SDP, but is not a key management
protocol and needs some other security in the back.

Cheers
/Elisabetta

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Mark Baugher <[email-masked]>
Date: Tue, 08 Oct 2002 13:55:05 -0700

hi

At 03:29 PM 10/8/2002 +0200, BUYCK Jacky FTRD/DMI/CAE wrote:

>I've understand how session's keys are generate and how all the mechanisms 
>of encryption and signature are performs but I don't understand HOW 
>initial masters keys are exchange ?
>
>Nowhere in the SRTP draft is specify key exchange protocols or something 
>like this. Or I've  not see an important part in the draft.
>

As Elisabetta stated, there is no single key management protocol for 
SRTP.  We expect that a number of them will be needed owing to the 
diversity of SRTP applications.  So the data security protocol is uncoupled 
from the key management protocol, like IPsec but unlike SSL.

Mark