Subject: RE: [AVT] retransmission payload format

From: [email-masked]
Date: Tue, 1 Oct 2002 10:11:18 -0500

Magnus,
 
> I think we are in agreement on which solution is the more 
> proper one in 
> this case. Using one RTX payload type for each original PT. 
> The original 
> TS goes in the retransmitted packets RTP header exactly as 
> is. All RTCP 
> statistics for the retransmission stream will be screwed up and is 
> simply declared as incorrect.
> 
With the proposed approach, the RTCP jitter for the retransmission stream is not correct in the sense that it does not reflect the actual network jitter. However, I don't see why the other RTCP statistics would be incorrect.

David.
_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Magnus Westerlund <[email-masked]>
Date: Wed, 02 Oct 2002 08:54:09 +0200

Hi David,

You are of course correct that most of the statistics is still useful. 
However the two following has issues in the retransmission stream.
SR:
NTP - TS synchronization.
RR:
interarrival jitter

The NTP - TS timestamping should be correct, except around RTP TS rate 
switches when it might behave strange due to the switches. The 
interarrival jitter as mentioned is practically useless.

Cheers

Magnus

-- 

Magnus Westerlund 

Multimedia Technologies, Ericsson Research ERA/TVA/A
----------------------------------------------------------------------
Ericsson AB                | Phone +46 8 4048287
Torshamsgatan 23           | Fax   +46 8 7575550
S-164 80 Stockholm, Sweden | mailto: [email-masked]