Subject: RE: [AVT] Question on RTP and RTSP

From: "BUYCK Jacky FTRD/DMI/CAE" <[email-masked]>
Date: Tue, 29 Oct 2002 08:50:19 +0100

Hi.
    From what I've seen during my look to RTP Security is that RTP is more dedicated to real time sessions like telephony or video conferences.
    RTSP seam to be made at a more higher level to provide media on demand. It can use RTP but it's not necessary : RTSP can be it's own transport protocol. The main differences between each one is that RTSP provide an HTTP like protocol with all the concept attached to it (control, and transport if my memory is good, protocol can be secure like in HTTPs at least they can be authenticated.
 
    AVT users correct me if I'm wrong or incomplete !
 
Thanks.

-----Message d'origine-----
De : Soyoung Lee [mailto:[email-masked]]
Envoye : mardi 29 octobre 2002 06:18
A : avt
Objet : [AVT] Question on RTP and RTSP

Dear experts,
 
I wonder what is the difference between RTP and RTSP.
In my understanding, RTP is used for real-time voice and streaming service.
Then, what is the RTSP?
 
Thanks in advance.

 ===========================
  Soyoung Lee
  LG Electronics Inc. Korea

  e-mail:  <mailto:[email-masked]> [email-masked]
  phone: +82-31-450-7859
  fax: +82-31-450-7912
===========================

---

From: Marshall Eubanks <[email-masked]>
Date: Tue, 29 Oct 2002 11:54:48 -0500

BUYCK Jacky FTRD/DMI/CAE wrote:
> Hi.
>     From what I've seen during my look to RTP Security is that RTP is 
> more dedicated to real time sessions like telephony or video conferences.
>     RTSP seam to be made at a more higher level to provide media on 
> demand. It can use RTP but it's not necessary : RTSP can be it's own 
> transport protocol. The main differences between each one is that RTSP 

RTSP does control / signalling, and is _not_ a transport protocol. The streams
must be transported using another protocol, such as RTP or HTTP. RTSP is
commonly used to help negotiate an audiovideo setup to decide what transport
protocol and bit rate etc. is to be used.

                                 Regards
                                 Marshall Eubanks

P.S. Please avoid html e-mail to IETF lists.

> provide an HTTP like protocol with all the concept attached to it 
> (control, and transport if my memory is good, protocol can be secure 
> like in HTTPs at least they can be authenticated.
>  
>     Envoye' : mardi 29 octobre 2002 06:18
>     A` : avt
>       e-mail: [email-masked] <mailto:[email-masked]>
>       phone: +82-31-450-7859
>       fax: +82-31-450-7912

-- 

T.M. Eubanks
Multicast Technologies, Inc
10301 Democracy Lane, Suite 410
Fairfax, Virginia 22030
Phone : 703-293-9624       Fax     : 703-293-9609
e-mail : [email-masked]
http://www.multicasttech.com

Test your network for multicast :
http://www.multicasttech.com/mt/
 Status of Multicast on the Web  :
 http://www.multicasttech.com/status/index.html

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt