Subject: RE: [AVT] RFC 2190 : Clarification

From: Muni Chandra <[email-masked]>
Date: Tue, 1 Jul 2003 08:53:26 -0700 (PDT)

Hi
 
 Thanks a lot for the reponse.
 
 One more clarification.
 
1) At  MODE-A packet without GOB header at start of it, it not possible to decode, becasue no way of finding out where this GOB belongs in the encoded frame in the case of packet loss case. This is since i feel MODE-A H.263 payload header will not give this information.
 
2) so based on above point, in MODE-A packet first GOB has header then solves the problem. Rest GOBs headers in MODE-A  packet are redundant. It is waste of network bandwidth.
 
Please clarify this.
 
Best Regards
Muni Chandra Reddy

Gary Sullivan <[email-masked]> wrote:
A few comments in response:
 
- RFC 2190 should only be used for H.263 that pre-date 1998 in syntax design (i.e., no use of PLUSPTYPE header format).
 
- RFC 2429 is a better design than 2190, and 2429 can be used for both old and newer versions of H.263 syntax.

Regarding the questions:
 
1) I don't think RFC 2190 any prohibition against having additional GOB headers within Mode A packets.  The RFC says it "allows fragmentation at GOB boundaries", but I don't see anywhere where it says it *requires* such fragmentation or prohibits GOB headers within packets.
 
2) As far as the H.263 standard (and within RFC 2190, I believe) is concerned, it is up to the discretion of the encoder when to send GOB headers and when not to.  Even within a single coded picture, some GOBs can have headers while others do not.  In some particular system environments (e.g. in some H.32x environments), there are ways to indicate that GOB headers should be sent or do not need to be sent for all GOBs - but this is outside the scope of H.263 itself.  There is nothing in the H.263 video spec itself that requires any particular behavior for whether GOB headers are present or not.
 
3) Given the above statements about item 1, I don't think item 3 is especially relevant anymore.
 
Best Regards,
 
Gary Sullivan
 
 -----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Muni Chandra
Sent: Saturday, June 28, 2003 5:07 AM
To: [email-masked]
Subject: [AVT] RFC 2190 : Clarification

Hello 
 
I am working on the implementation part of RFC 2190
for H.263 video packtization.
 
I have a clarification.
 
1) As per RFC 2190, In MODE A,   beginning of Packet should contain GOB with its Header. So, this means only first GOB (or part of it) in  each packet should contain GOB header, rest GOBs will not have GOB header in the same MODE-A packet.
 
2) But H.263 standard says ( this with respective to my discussion with H.263 developers) whether all GOB's should have headers and all should not have GOB headers in a paerticular frame.
 
3) So to acheive above point 1 with respective above point 2, we need to  calculate header for all GOB's and transmit GOB header only for first GOB of each MODE - A packet.
 
Please clarify above point 3 is correct or we can calculate GOB headers for only first GOB of each MODE -A packet. So that we can save time of GOB header computation at  rest of GOBs.
 
Thanking you in Advance
 
Muni Chanra Reddy

---------------------------------
Do you Yahoo!?
SBC Yahoo! DSL - Now only $29.95 per month!

---------------------------------
Do you Yahoo!?
SBC Yahoo! DSL - Now only $29.95 per month!

---

From: "Gary Sullivan" <[email-masked]>
Date: Tue, 1 Jul 2003 16:43:17 -0700

Muni,
 
I believe I basically agree with you on both points.
 
Regarding item 1, yes - I believe you would not be able to decode the
data at the start of such a GOB-headerless packet unless you had
received the packet or packets before it that provided the necessary
header information.
 
Regarding item 2, yes - Placing more than one GOB header within a single
RFC 2190 Mode A RTP packet appears to be basically a useless waste of
bits, unless you can argue that some form of data corruption is possible
somewhere in the transmission channel (possibly through a gateway to
some other non-IP environment).
 
As I previously indicated, I am not too fond of RFC 2190.  RFC 2429 is a
superior design.  However, RFC 2190 was done earlier and is therefore
still needed for interoperability with devices made before RFc 2429 was
developed.
 
Best Regards,
 
Gary Sullivan

-----Original Message-----
From: Muni Chandra [mailto:[email-masked]] 
Sent: Tuesday, July 01, 2003 8:53 AM
To: Gary Sullivan; [email-masked]
Subject: RE: [AVT] RFC 2190 : Clarification

Hi

 One more clarification.
 
1) At  MODE-A packet without GOB header at start of it, it not possible
to decode, becasue no way of finding out where this GOB belongs in the
encoded frame in the case of packet loss case. This is since i feel
MODE-A H.263 payload header will not give this information.
 
2) so based on above point, in MODE-A packet first GOB has header then
solves the problem. Rest GOBs headers in MODE-A  packet are redundant.
It is waste of network bandwidth.
 
Please clarify this.
 
Best Regards
Muni Chandra Reddy

 
- RFC 2190 should only be used for H.263 that pre-date 1998 in syntax
design (i.e., no use of PLUSPTYPE header format).

- RFC 2429 is a better design than 2190, and 2429 can be used for both
old and newer versions of H.263 syntax.
 
Regarding the questions:
 
1) I don't think RFC 2190 any prohibition against having additional GOB
headers within Mode A packets.  The RFC says it "allows fragmentation at
GOB boundaries", but I don't see anywhere where it says it *requires*
such fragmentation or prohibits GOB headers within packets.
 
2) As far as the H.263 standard (and within RFC 2190, I believe) is
concerned, it is up to the discretion of the encoder when to send GOB
headers and when not to.  Even within a single coded picture, some GOBs
can have headers while others do not.  In some particular system
environments (e.g. in some H.32x environments), there are ways to
indicate that GOB headers should be sent or do not need to be sent for
all GOBs - but this is outside the scope of H.263 itself.  There is
nothing in the H.263 video spec itself that requires any particular
behavior for whether GOB headers are present or not.
 
3) Given the above statements about item 1, I don't think item 3 is
especially relevant anymore.
 
Best Regards,
 
Gary Sullivan
 
 -----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Muni
Chandra
Sent: Saturday, June 28, 2003 5:07 AM
To: [email-masked]
Subject: [AVT] RFC 2190 : Clarification

Hello 

I have a clarification.
 
1) As per RFC 2190, In MODE A,   beginning of Packet should contain GOB
with its Header. So, this means only first GOB (or part of it) in  each
packet should contain GOB header, rest GOBs will not have GOB header in
the same MODE-A packet.
 
2) But H.263 standard says ( this with respective to my discussion with
H.263 developers) whether all GOB's should have headers and all should
not have GOB headers in a paerticular frame.
 
3) So to acheive above point 1 with respective above point 2, we need to
calculate header for all GOB's and transmit GOB header only for first
GOB of each MODE - A packet.
 
Please clarify above point 3 is correct or we can calculate GOB headers
for only first GOB of each MODE -A packet. So that we can save time of
GOB header computation at  rest of GOBs.
 
Thanking you in Advance
 
Muni Chanra Reddy

  _____  

Do you Yahoo!?
SBC
<http://pa.yahoo.com/*http://rd.yahoo.com/evt=1207/*http://promo.yahoo.c
om/sbc/> Yahoo! DSL - Now only $29.95 per month!

  _____  

Do you Yahoo!?
SBC
<http://pa.yahoo.com/*http://rd.yahoo.com/evt=1207/*http://promo.yahoo.c
om/sbc/> Yahoo! DSL - Now only $29.95 per month!