Subject: [AVT] possible error on testvectors of draft "draft-ietf-avt-srtp-08.txt"

From: "Claudio Thomas" <[email-masked]>
Date: Tue, 8 Jul 2003 09:54:58 +0200

Actual link:
<http://www.ietf.org/internet-drafts/draft-ietf-avt-srtp-08.txt>
http://www.ietf.org/internet-drafts/draft-ietf-avt-srtp-08.txt

Chapter B.1 AES-f8 Test Vectors (page 52)

Position: j=2

IV' XOR j : 595b699bbd3bc0df26062093c1ad8f70

Should be

IV' XOR j : 595b699bbd3bc0df26062093c1ad8f71

Reason:

Last byte of IV' = 73, j=02:  73 xor 02 = 71 (0011 xor 0010 = 0001)

If my calculator is right, then the values after this position also can't be
correct.

Do someone have already implemented it to give me working vextors? Or can
somebody explain me what is wrong on my calc?

Thanks,

Claudio

---

From: Mats Näslund <[email-masked]>
Date: Tue, 08 Jul 2003 11:41:06 +0200

Dear Claudio,

Your observation appears correct. Unfortunately, the person
coding our f8 test code is on vacation, so it will take
some time before we can explain what the actual error is.
(A *hypothesis* is that our code has side-effects on the
variable IV', so that IV' is not kept fixed, but rather
updated "by accident".)

Thanks for being observant, we will get back as soon as
we can.

/Mats

Claudio Thomas wrote:
> Actual link:  <http://www.ietf.org/internet-drafts/draft-ietf-avt-srtp-08.txt> http://www.ietf.org/internet-drafts/draft-ietf-avt-srtp-08.txt
> 
>  
> 
> If my calculator is right, then the values after this position also can't be correct.
> 
>  
> 
> Do someone have already implemented it to give me working vextors? Or can somebody explain me what is wrong on my calc?
> 
>  
> 
> Thanks,
> 
>  
> 
> Claudio
> 

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt