Subject: RE: [AVT] (no subject)

From: Thomas Zeng <[email-masked]>
Date: Tue, 22 Jul 2003 02:30:32 -0700

Prem:

see below.

- thomas

-----Original Message-----
From: Kumar Premendra (IFIN DC COM)
To: [email-masked]
Sent: 22.07.2003 01:20
Subject: [AVT] (no subject)

Hello,

I have some doubt while implementing RTP/RTCP....please clarify my doubt
if
possible.

Q.  We must send RTCP packet  in compound packet format ,Always ?
 If not, how do we identify whether received packet is  normal RTCP
packet
or compound packet.

[tz] based on size of each rtcp packet, as well as overall size of the UDP
packet, you can tell whether you are getting a correctly formated RTCP
compound packet. If it is not a compound RTCP packet, it is ill-formated.

Thanks in advance
prem

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: "Neo Anderson" <[email-masked]>
Date: Tue, 29 Jul 2003 15:21:17 +0530

---- Begin Original Message ----

From: "Kumar Premendra (IFIN DC COM)" <[email-masked]>

Sent: Tue, 22 Jul 2003 13:50:26 +0530

To: [email-masked]

Hello,

I have some doubt while implementing RTP/RTCP....please clarify my

doubt if

possible.

Yes.

> If not, how do we identify whether received packet is  normal RTCP

packet or compound packet.

RFC 1889, 6.1 Says:

"There is no explicit count of individual RTCP packets in the

compound packet since the lower layer protocols are expected to

provide an overall length to determine the end of the compound

packet."

Using udp for example, recvfrom () will give the length of the packet

which is received. This length has to be crosschecked with the length

field in the fixed header of RTCP packet(s).

--Neo

Get your own Free E-mail at Witch Wisdom http://www.witchwisdom.com
___________________________________________________________
Get your own Web-based E-mail Service at http://www.zzn.com