Subject: RE: [AVT] Re: draft-ahmadi-avt-rtp-vmr-wb-01.txt

From: [email-masked]
Date: Tue, 18 May 2004 09:06:23 -0700

Colin,

Thanks for your good comment. 

Based on your recent comment, I revised the VMR-WB Internet Draft and included a section on "Offer-Answer Model Considerations" similar to that of AMR-WB+ draft (see Section 10.3) and also updated Section 12.

To maintain interoperability with AMR-WB in cases where negotiation is possible using the VMR-WB interoperable mode, a VMR-WB enabled terminal SHOULD also declare itself capable of AMR-WB with limited  mode set (i.e., only AMR-WB codec modes 0, 1, and 2 are allowed) and octet-align mode of operation. Example:

               m=audio 49120 RTP/AVP 98 99
               a=rtpmap:98 VMR-WB/16000/1
               a=rtpmap:99 AMR-WB/16000/1
               a=fmtp:99 octet-align=1; mode-set=0,1,2

I hope this new addition would satisfy your concern and eliminate any signaling conflicts. I have already posted version -02 of VMR-WB payload on IETF server (draft-ahmadi-avt-rtp-vmr-wb-02.txt)

Once again, I would like to kindly ask the IETF/AVT group to adopt this version of VMR-WB Internet Draft as a working group work item.

Thanks in advance.

Regards

-Sassan Ahmadi

> 
> This is certainly greatly improved, however it does not 
> address my concern 
> with respect to the signaling of AMR-WB compatible modes. I 
> would suggest 
> you study the Offer-Answer Model Considerations for the 
> AMR-WB+ payload 
> format (draft-sjoberg-avt-rtp-amrwbplus-01.txt) and follow a 
> similar model 
> for interoperability (i.e. require a VMR-WB capable endpoint 
> to advertise 
> support for the AMR-WB payload format, in addition to native 
> VMR-WB, as an 
> way of avoiding interoperability problems).
> 
> With that change made, I believe this would be appropriate to 
> accept as an 
> AVT work item (provided there are no other objections from the list).
> 

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Colin Perkins <[email-masked]>
Date: Thu, 20 May 2004 22:47:39 +0100

On Tuesday 18 May 2004 17:06, [email-masked] wrote:
> Based on your recent comment, I revised the VMR-WB Internet Draft and
> included a section on "Offer-Answer Model Considerations" similar to
> that of AMR-WB+ draft (see Section 10.3) and also updated Section 12.
>
> To maintain interoperability with AMR-WB in cases where negotiation is
> possible using the VMR-WB interoperable mode, a VMR-WB enabled terminal
> SHOULD also declare itself capable of AMR-WB with limited  mode set
> (i.e., only AMR-WB codec modes 0, 1, and 2 are allowed) and octet-align
> mode of operation. Example:
>
>
> I hope this new addition would satisfy your concern and eliminate any
> signaling conflicts. I have already posted version -02 of VMR-WB payload
> on IETF server (draft-ahmadi-avt-rtp-vmr-wb-02.txt)
>
> Once again, I would like to kindly ask the IETF/AVT group to adopt this
> version of VMR-WB Internet Draft as a working group work item.

This version addresses my concern. If there are any other objections to 
accepting this draft as an AVT work item, please comment to the mailing 
list by 28th May 2004. 

-- 
Colin Perkins
http://csperkins.org/