Subject: [AVT] RFC3711, MKI and <From, To>

From: "Ofer Goren" <[email-masked]>
Date: Mon, 17 May 2004 17:16:03 +0300

Hi.
 
Since I'm new to security issues I have the following question:
 
If the SRTP and SRTCP for the same session DO NOT share the same master key (well, even if they DO share it), can each of those protocols use different method for master-key retrieval? e.g. the SRTP uses the MKI method, and the SRTCP uses the <From, To> method. And if so, is there any reason to do so, or can I safely assume this will not happen?
 
Thanks,
 
Ofer
___________________________________________________
"What kind of a name is Azam Azam?" - Butrus Butrus Ghali.

---

From: Mark Baugher <[email-masked]>
Date: Mon, 17 May 2004 08:51:06 -0700

hi Ofer,
   RFC 3711 places few restrictions on key management.  It is up to the key 
establishment method (e.g. MIKEY or SDP Security Descriptions) to constrain 
how keys are defined, installed, maintained and updated.  I think it is 
possible to do complex and probably therefor insecure things like you 
mention in your note.  This is a key management problem, and interoperable 
SRTP implementations will need to have interoperable key management systems.

Mark
At 07:16 AM 5/17/2004, Ofer Goren wrote:
>If the SRTP and SRTCP for the same session DO NOT share the same master 
>key (well, even if they DO share it), can each of those protocols use 
>different method for master-key retrieval? e.g. the SRTP uses the MKI 
>method, and the SRTCP uses the <From, To> method. And if so, is there any 
>reason to do so, or can I safely assume this will not happen?
>
>Thanks,
>
>Ofer

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt