Subject: [AVT] draft-ahmadi-avt-rtp-vmr-wb-01.txt

From: [email-masked]
Date: Wed, 5 May 2004 10:57:50 -0700

Dear Colin and Magnus,

I am sorry that it took me a long time to respond to your comments and provide a revision of the Internet Draft for VMR-WB RTP payload and Storage formats.

My delay was partially due to the fact that I was waiting for the VMR-WB specification to be finalized and published in 3GPP2/TIA. Now VMR-WB specification is complete and is scheduled for publication by 3GPP2 in June 2004. The source code has been made available to 3GPP2 membership since March 1, 2004 and will be published as part of the minimum performance specification in September 2004 for public access (see ftp://ftp.3gpp2.org/V&V/C.P0052-0_v0.2_VMR-WB_V&V_Text.zip for more information)

In the revised draft I have addressed all of your comments and concerns about the original draft. Major changes include

1- All comments from AVT chairs are addressed.
2- A header-free payload format has been added (just like RFC 3558)
3- Bandwidth-efficient mode is eliminated.
4- By some changes in Tables 2 and 3 in Section 6, the interworking function is completely  
   eliminated.
5- The size of MIME parameter set has been reduced. The extra MIME parameters have been 
   removed.
6- CDMA system issues have been removed from the document.
7- Signaling conflicts with AMR-WB have all been resolved both in the payload and the 
   storage formats.

Attached please find a PowerPoint presentation comprising highlights of the revised Internet Draft. Also please find the draft as well as detailed response to Magnus' comments.

Considering the improvements and corrections that have been made in the revised draft, I would like to kindly ask IETF/AVT group to accept this Internet Draft as an AVT group work item now.

I also kindly ask you to provide your feedback and comments to complete and finalize a RFC for VMR-WB.

Thanks in advance.

-Sassan Ahmadi, Ph.D.
 Nokia Inc. USA

---

From: Colin Perkins <[email-masked]>
Date: Wed, 12 May 2004 15:59:55 +0100

On Wednesday 05 May 2004 18:57, [email-masked] wrote:
...
> In the revised draft I have addressed all of your comments and concerns
> about the original draft. Major changes include
>
> 4- By some changes in Tables 2 and 3 in Section 6, the interworking
> function is completely eliminated.
> 5- The size of MIME parameter set has been reduced. The extra MIME
> parameters have been removed.
> 7- Signaling conflicts with AMR-WB have all been resolved both in the
> payload and the storage formats.
>
> Attached please find a PowerPoint presentation comprising highlights of
> the revised Internet Draft. Also please find the draft as well as
> detailed response to Magnus' comments.
>
> Considering the improvements and corrections that have been made in the
> revised draft, I would like to kindly ask IETF/AVT group to accept this
> Internet Draft as an AVT group work item now.
>

This is certainly greatly improved, however it does not address my concern 
with respect to the signalling of AMR-WB compatible modes. I would suggest 
you study the Offer-Answer Model Considerations for the AMR-WB+ payload 
format (draft-sjoberg-avt-rtp-amrwbplus-01.txt) and follow a similar model 
for interoperability (i.e. require a VMR-WB capable endpoint to advertise 
support for the AMR-WB payload format, in addition to native VMR-WB, as an 
way of avoiding interoperability problems).

With that change made, I believe this would be appropriate to accept as an 
AVT work item (provided there are no other objections from the list).

-- 
Colin Perkins
http://csperkins.org/

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt