Subject: [AVT] draft-ietf-avt-rtp-vmr-wb-03: MIME type

From: Magnus Westerlund <[email-masked]>
Date: Mon, 06 Sep 2004 14:37:48 +0200

Hi,

I mentioned this before in a discussion note, that if you like to 
utilize the magic numbers etc properly. Then you should in fact define 
parameters that do tell a receiver prior to downloading a body the fact 
on what it will download. Thus a need for MIME parameters.

I have also in the review found that the MIME registration is not as 
clear as would be desirable on what parameters do apply to.

First, the MIME parameters do not all apply to the file format. In my 
view the only parameters making sense for the file format are:
- channels
- rate
- mode-set
- dtx
 From these parameters a receiver can determine, if it is multi-channel 
or not, if the mode-set is equal to 3, indicating interoperable mode. 
Mode set does also support future extension, when new mode sets are 
defined.

Second, I think there is need to clarify better what applies to the two 
different use cases by being explicit about it. I will read Ned Freed's 
draft to determine it it recommends any language for this.

Cheers

Magnus Westerlund

Multimedia Technologies, Ericsson Research EAB/TVA/A
----------------------------------------------------------------------
Ericsson AB                | Phone +46 8 4048287
Torshamsgatan 23           | Fax   +46 8 7575550
S-164 80 Stockholm, Sweden | mailto: [email-masked]

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: "Gunnar Hellstrom" <[email-masked]>
Date: Thu, 9 Sep 2004 23:35:58 +0200

A few comments on draft-ietf-avt-rtp-vmr-wb-03:

<GH1> 4.2.1 Last paragraph:
This paragraph is a bit strange to me:
"Beyond plain text, there are many formats for representing what might
   be known as "rich text".  An interesting characteristic of many such
   representations is that they are to some extent readable even without
   the software that interprets them.  It is useful, then, to
   distinguish them, at the highest level, from such unreadable data as
   images, audio, or text represented in an unreadable form.  In the
   absence of appropriate interpretation software, it is reasonable to
   show subtypes of "text" to the user, while it is not reasonable to do
   so with most non textual data.  Such formatted textual data should be
   represented using subtypes of "text". "

What does it want to say?
Is it that there are kinds of text coding expressed in images or on video that are better
declared as image or video media?
E.g. postscript coded text would rather be an image medium?

The thought that text is readable even without the software that interprets it is strange
and does not produce any distinguishing definition. I think encrypted text should still be
declared as text, but it is impossible to read without interpreting software. So the
comments rather create confusion than clarification.

I think that the definition that 4.2.1 starts with is sufficient to define what text is.
The last paragraph could be limited to:

"Beyond plain text, there are many formats for representing what might be known as "rich
text". Coding is often intermixed control information and text contents. Such formatted
textual data should be represented using subtypes of "text". "

<GH2> 4.2.4 last paragraph:
"Note that although in general this document strongly discourages the
   mixing of multiple media in a single body, it is recognized that many
   so-called video formats include a representation for synchronized
   audio, and this is explicitly permitted for subtypes of "video"."

It is also common that text for subtitling is multiplexed into the file or stream. I
suggest that the word "text" is added so that the paragraph reads:

"Note that although in general this document strongly discourages the
   mixing of multiple media in a single body, it is recognized that many
   so-called video formats include a representation for synchronized
   audio and text, and this is explicitly permitted for subtypes of "video"."

----

Regards

Gunnar Hellstrom
-------------------------------------------
Gunnar Hellstrom
Omnitor AB
Renathvagen 2
SE 121 37 Johanneshov
SWEDEN
+46 8 556 002 03
Mob: +46 708 204 288
www.omnitor.se
[email-masked]
--------------------------------------------

---

From: "Gunnar Hellstrom" <[email-masked]>
Date: Thu, 9 Sep 2004 23:50:17 +0200

Please disregard my recent comments with this subject, they were intended for another
document, and are reissued in the right context.

Gunnar