Subject: RE: [AVT] RE: <draft-ietf-avt-rtp-vmr-wb-03.txt>: sampling rate

From: [email-masked]
Date: Fri, 10 Sep 2004 12:02:41 -0700

Hi Magnus,
 
> As I indicated above, I am not certain what the usage of knowing the 
> sampling frequency of the source material. Can you please 
> provide some 
> use cases when this actually is useful information. If you 
> can motivate 
> why there is good reason to have this information I don't see 
> a problem 
> of doing as you suggest. However I like to avoid defining things that 
> are not really useful.
> 

I think it is beneficial from application point of view if there is a way to communicate the original media sampling frequency.

However, to satisfy your concern and to conclude this discussion, I just use a 16000 Hz RTP clock rate and I do not define any new sampling-rate MIME parameter.

Regards

-Sassan Ahmadi

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Colin Perkins <[email-masked]>
Date: Sat, 11 Sep 2004 13:06:29 +0100

On 10 Sep 2004, at 20:02, [email-masked] wrote:
> I think it is beneficial from application point of view if there is a 
> way to communicate the original media sampling frequency.

Yes. This is the point of the RTP timestamp, and the "rate" parameter.

> However, to satisfy your concern and to conclude this discussion, I 
> just use a 16000 Hz RTP clock rate and I do not define any new 
> sampling-rate MIME parameter.

No - this is not appropriate.

Colin