Subject: [AVT] RE: <draft-ietf-avt-rtp-vmr-wb-03.txt>: Storage format

From: [email-masked]
Date: Thu, 9 Sep 2004 13:51:48 -0700

Hi Magnus,

As I mentioned in my previous reply, the storage format does not have any MIME parameter associated with it. 

I am not following the discussion on media types registration. Considering that we have only MIME parameters associated with RTP payload, could you please tell me how does this discussion affect VMR-WB I-D?

Thanks and Regards

-Sassan Ahmadi

> -----Original Message-----
> From: ext Magnus Westerlund [mailto:[email-masked]]
> Sent: Wednesday, September 08, 2004 7:31 AM
> To: Ahmadi Sassan (Nokia-TP/SanDiego)
> Cc: [email-masked]; [email-masked]
> Subject: Re: <draft-ietf-avt-rtp-vmr-wb-03.txt>: Storage format
> 
> 
> Hi Sassan,
> 
> If you have read the discussion of the media types 
> registration of the 
> draft, it seems evident that the RTP payload format and file format 
> shall have two different media type names with their own list of 
> parameters.
> 
> Cheers
> 
> Magnus Westerlund
> 
> Multimedia Technologies, Ericsson Research EAB/TVA/A
> ----------------------------------------------------------------------
> Ericsson AB                | Phone +46 8 4048287
> Torshamsgatan 23           | Fax   +46 8 7575550
> S-164 80 Stockholm, Sweden | mailto: [email-masked]
> 

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Magnus Westerlund <[email-masked]>
Date: Fri, 10 Sep 2004 08:50:13 +0200

> any MIME parameter associated with it. 

Actually I think you are not correct. It makes a lot of sense to have 
the following parameters also for the file format.

mode-set: So that you can indicate what is used in the file. For example 
by using mode-set=3 you can indicate interoperable mode.

channels: Indicate the actual number of channels present in the file

dtx: To indicate that DTX is used in this file

What do you say?

> 
> I am not following the discussion on media types registration.
> Considering that we have only MIME parameters associated with RTP
> payload, could you please tell me how does this discussion affect VMR-WB
> I-D?

My conclusions of the discussion is that you will need to define one 
MIME type for the RTP payload format, and another for the file format as 
they have different formats.

Cheers

Magnus Westerlund