Subject: RE: [AVT] I-D ACTION:draft-ietf-avt-tcrtp-08.txt

From: "Yaakov Stein" <[email-masked]>
Date: Wed, 22 Sep 2004 09:45:34 +0300

> ATM's multiplexing only helps significantly if you can take 
> advantage of it, which requires chosing a codec and 
> packetization interval the fit into the user payload, and 
> requires multiple streams terminating on the same VPI/VCI.

ITU Y.1414 uses AAL2 directly over MPLS.
Similarly draft-ietf-pwe3-tdmoip uses AAL2 directly over UDP/IP.

The format is :
  PSN (MPLS or IP) headers
  first connection : mini-header + payload
  second connection :  miniheader + payload
  ...
  last connection : miniheader + payload

The only payload size restrictions are maximums due to the 
size of the AAL2 length field in the miniheader.

> We needed a compression technique that saved bandwidth even 
> in the absence of multiplexing -- such as a branch office 
> doing VoIP with a single user.

In that case you only need a robust header compression method.

Y(J)S

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: "Dan Wing" <[email-masked]>
Date: Wed, 22 Sep 2004 07:57:18 -0700

> size of the AAL2 length field in the miniheader.

You're comparing VoMPLS to VoIP, and I was comparing VoATM to VoIP.
The weakness of VoATM is the minimum 53-byte packet size.  VoMPLS
doesn't have that weakness, but VoMPLS still has smaller headers
than VoIP.

> In that case you only need a robust header compression method.

ROHC, by itself, doesn't work if packets are reordered unless 
draft-pelletier-rohc-over-reordering-00 is used, and ECRTP, by
itself, doesn't work over multiple hops -- ECRTP needs to be
encapsulated (tunneled) inside of something else.  And TCRTP
defines one mechanism for such tunneling.

-d