Subject: RE: [AVT] RFC3558 header-free packet format question

From: "Lars-Erik Jonsson (LU/EAB)" <[email-masked]>
Date: Fri, 17 Sep 2004 08:36:21 +0200

Qiaobing,

The header-free format was included to make no-overhead-over-the-air
possible, then obviously assuming IP/UDP/RTP header compression on
the wireless link. By using RFC 3242, the header overhead can be
totally eliminated under certain conditions, thus one frame per RTP
packet can make much sense.

Cheers,
/L-E

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Qiaobing Xie
> Sent: den 17 september 2004 05:51
> To: AVT List
> Cc: [email-masked]
> Subject: [AVT] RFC3558 header-free packet format question
> 
> 
> Hi, Adam,
> 
> The text in section 4.2 of RFC3558 **seems** to indicate that 
> only ONE speech frame is 
> allowed per RTP packet when header-free format is used. This 
> seems to be overly limiting and 
> may severely hinder the usage of this payload format (e.g., I 
> don't think any over-the-air 
> link can afford to use one frame per RTP packet arrangement, 
> and if over-the-air link can 
> not use header-free format, what would be its purpose?). One 
> would think that as long as the 
> same codec rate (hence the layout and size) is in use, more 
> than one frame should be able to 
> be unambiguously carried in a header-free RTP packet.
> 
> Maybe I missed something.
> 
> regards,
> -Qiaobing
> 
> 
> _______________________________________________
> Audio/Video Transport Working Group
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/avt
> 

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Qiaobing Xie <[email-masked]>
Date: Fri, 17 Sep 2004 18:39:25 +0800

Hi, Lars-Erik/Magnus,

Thank you both for the explanation. Yes, it makes sense now. Does the intended 
ROHC-LLA/CDMA2000 operation (as described by both of you) must require the 
one-frame-per-packet limitation on the header-free format? This is not obvious to me at least.

regards,
-Qiaobing