Subject: [AVT] RE: <draft-ietf-avt-rtp-vmr-wb-03.txt>: Storage format

From: [email-masked]
Date: Fri, 3 Sep 2004 10:34:04 -0700

Magnus,

> > While I added the necessary notes to Section 7 (storage format), I
> > decided not to remove this section for the following reasons:
> > 
> > - This section and Section 8.5 of the 3GPP2 VMR-WB specification are
> > fully consistent.
> > 
> > - I was advised by some 3GPP2 colleagues that the I-D is 
> the best place
> > to define the storage format.
> > 
> 
> Do, you or do you not have a full specification in the 3GPP2 
> specifications of the storage format?

Section 8.5 of VMR-WB spec describes the MIME/file storage format. The reason I described the storage format in VMR-WB spec was that at that time VMR-WB RFC was not published and could not be referenced. 

We believe that the best place to describe the storage format is the VMR-WB RFC.

Currently both VMR-WB I-D, software, and spec are fully consistent in the definition of the storage format.

If you agree, let's keep the storage format in VMR-WB RFC and I will remove the storage format description in Release A of the VMR-WB specification (that includes VMR-WB extension) which is being drafted and which is scheduled for publication as 3GPP2 C.S0052-A v1.0 in April 2005. Because by that time, the VMR-WB RFC is hopefully published and can be referenced.

That way, we do not have to be worried about updating two specifications, should a revision is necessary.

Regards

-Sassan Ahmadi

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Magnus Westerlund <[email-masked]>
Date: Mon, 06 Sep 2004 09:21:47 +0200

Okay,

I do understand, and I fine with this, as long as the removal from the 
3GPP2 spec actually happens.

Cheers

Magnus

[email-masked] wrote:

> Section 8.5 of VMR-WB spec describes the MIME/file storage format. The
> reason I described the storage format in VMR-WB spec was that at that
> time VMR-WB RFC was not published and could not be referenced. 
> 
> If you agree, let's keep the storage format in VMR-WB RFC and I will
> remove the storage format description in Release A of the VMR-WB
> specification (that includes VMR-WB extension) which is being drafted
> and which is scheduled for publication as 3GPP2 C.S0052-A v1.0 in April
> 2005. Because by that time, the VMR-WB RFC is hopefully published and
> can be referenced.
> 
> That way, we do not have to be worried about updating two
> specifications, should a revision is necessary.
> 
> Regards
> 
> -Sassan Ahmadi

-- 

Magnus Westerlund

Multimedia Technologies, Ericsson Research EAB/TVA/A
----------------------------------------------------------------------
Ericsson AB                | Phone +46 8 4048287
Torshamsgatan 23           | Fax   +46 8 7575550
S-164 80 Stockholm, Sweden | mailto: [email-masked]

---

From: Qiaobing Xie <[email-masked]>
Date: Tue, 07 Sep 2004 18:23:56 +0800

Hi, Sassan,

I am trying to better understand the VMR-WB codec design and have the following question -

Is it true that all the coded frames output from a VMR-WB __encoder__ use the 12.8k sampling 
rate, independent of the original sampling rate of the speech?

regards,
-Qiaobing