Subject: [AVT] draft-ietf-avt-rtp-vmr-wb-03: file format errors?`

From: Magnus Westerlund <[email-masked]>
Date: Mon, 06 Sep 2004 14:09:02 +0200

Hi Sassan,

I was reviewing the draft to see if it was ready for WG last call, when 
I think I have spotted an serious error in the file format. Is the file 
format specified in the draft missing internal rate indication? I can't 
find anyway to indicate that the saved material is in 8kHz rather the 
the default 16kHz? Please clarify how this is handled.

Cheers

Magnus Westerlund

Multimedia Technologies, Ericsson Research EAB/TVA/A
----------------------------------------------------------------------
Ericsson AB                | Phone +46 8 4048287
Torshamsgatan 23           | Fax   +46 8 7575550
S-164 80 Stockholm, Sweden | mailto: [email-masked]

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: [email-masked]
Date: Tue, 7 Sep 2004 21:27:15 -0700

Hi Magnus,

There is no error or missing information. 

The VMR-WB decoder does not need to know the sampling frequency of the encoder input speech for decoding of the stored speech data or the incoming bit stream. Both 8 kHz and 16 kHz sampled input speech are converted to an internal sampling frequency of 12.8 kHz for the encoding functions. The bit stream or the storage file generated by the VMR-WB encoder are independent of the input sampling frequency.

By default, the VMR-WB decoder generates wideband output, unless otherwise instructed. 

That is why the sampling frequency has not been considered as a parameter for the storage format.

If you receive a VMR-WB stored file through e-mail, depending on your output audio interface, you instruct the VMR-WB decoder to generate a wideband or narrowband output regardless of the input sampling frequency.

The VMR-WB decoder also does not need the mode information. The decoding functions are independent of the encoder operating mode.

The above processes have been extensively tested with VMR-WB C simulation and described in VMR-WB spec.

Regards

-Sassan Ahmadi

> -----Original Message-----
> From: ext Magnus Westerlund [mailto:[email-masked]]
> Sent: Monday, September 06, 2004 5:09 AM
> To: Ahmadi Sassan (Nokia-TP/SanDiego); IETF AVT WG
> Subject: draft-ietf-avt-rtp-vmr-wb-03: file format errors?`
> 
> 
> Hi Sassan,
>