Subject: Re: [AVT] RE: <draft-ietf-avt-rtp-vmr-wb-03.txt>: sampling rate

From: Colin Perkins <[email-masked]>
Date: Sun, 3 Oct 2004 15:37:59 +0100

Qiaobing,

On 24 Sep 2004, at 13:16, Qiaobing Xie wrote:
> Colin Perkins wrote:
>
> <snip>
>>> Not that such things exist currently, but playing devil's advocate,
>>> one could create a codec that takes a variable-sampling-rate input
>>> depending on current conditions.  (Similar to video codecs that vary 
>>> the
>>> frame rate, resolution, and/or bitrate within a stream.)
>> Sure, one could. I don't think it would be a good idea though: the 
>> convention that the sampling rate equals the timestamp rate is very 
>> helpful when building multi-format systems.
>
> The practical need in 3GPP2 (and possibly other systems) to feed mixed 
> sampling rate input (depending on conditions in the call flow) to 
> vmr-wb codec in a single session has already been explained in this 
> discussion. I think it is quite equivalent to the scenario depicted by 
> Randell.

With respect, the only argument I've heard is that you want to save 
having to store both 8kHz and 16kHz sampled clips in a system. That is 
not a compelling reason to break the RTP timing model.

Colin

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Qiaobing Xie <[email-masked]>
Date: Wed, 06 Oct 2004 20:30:24 -0500

Hi, Colin,

<snip>
> not a compelling reason to break the RTP timing model.

No, that's not what I am concerned. Storage costs little nowadays. Other costs can be far 
more significant. For example, if one has to do a system-wide update of pre-existing 
announcement clips in order to use vmr-wb/rtp, it would become a substantial deployment cost 
of vmr-wb. Moreover, to maintain 2 sets of clips is surely going to add complexity to the 
system design as well as add to engineering and maintenance costs. So, I don't see storing 
both 8kHz and 16kHz sampled clips in a system as the best solution.

regards,
-Qiaobing