Subject: RE: [AVT] V.32 AA AC in RFC2833bis

From: "Yaakov Stein" <[email-masked]>
Date: Wed, 25 May 2005 16:54:59 +0200

> V.32 is a synchronous modem at 2400, 4800, or 9600 bits/s 
> using QAM over an 1800 Hz carrier modulated at 2400 baud/s. 
> Is it still in use?

V.32 was updated to V.32bis,
which includes all the V.32 rates PLUS
the 12Kbps and 14.4Kbps mode.
Since the higher rates have TCM the newer "bis"
version replaced all of the older implementations,
so I doubt you will find many V.32 (non-bis) modems out there.

However, all the considerations are the same,
so the question remains.

> The AA and AC patterns are part of the V.32 start-up 
> sequence, of course, but at the answering end, as I 
> understand V.32, the first tone emitted is the 2100 Hz ANS 
> signal for which we have already defined an event.

When using V.25/V.8 you should hear ANS/ANSam tone first.
However, there are two exceptions to this rule.
1) on non-dial-up (i.e. leased lines) the modem is allowed 
    to start up without V.25, so the first signals on the line
    will be the A and the alternations.
2) If you only hear the calling side, you will not hear any
    ANS tone, and you will start with the AA and CC signals.
    Note that this is an important trigger for modem relay.

Please note that it is incorrect to describe these signals
as 600/3000 Hz tones. They are 1800Hz with possible alternations
at a 2400Hz rate, and thus have sidebands at 600 and 3000 Hz.

> The question is therefore whether we also need to support the 
> V.32 calling pattern (AA) and post-ANS response (AC). Is 
> there a real need to support this particular modem?

There is still need to support V.32bis modems,
as they are many out there.

The question is whether we need a message to relay all
the combinations (AA, CC, AC, S=ABABAB, S'=CDCDCD).
I personally doubt it.

If ANS is not seen we need a reliable detector,
but once detected we need to transition to either
a modem relay or to clear channel. Either way
no message for these signals is needed.

Y(J)S

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Tom Taylor <[email-masked]>
Date: Wed, 25 May 2005 22:24:55 -0400

Thanks.  Your remarks on frequency were helpful in confirming my 
impression.  It looks like it would be a good idea to add the events AA 
on the calling side and AC on the answering side, with advice to 
transition into V.150.1 modem relay when these are detected.