Subject: [AVT] Reg: Sender/Member Tables in RTP

From: "Siddhartha Gandhi" <[email-masked]>
Date: Fri, 3 Feb 2006 11:24:59 -0600

As per RFC 1889/3550, the Sender and Member Tables will store all the unique
participants (SSRC /CSRC) that is extracts from the RTCP and RTP packets.

Also the Receivers in a multicast environment are not allowed to talk to
each other i.e, send RTCP packets.

Given the above two facts, how does a receiver know, how many receivers
other than itself are there in the multicast session or conference ?

Thanks,

Siddhartha

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Colin Perkins <[email-masked]>
Date: Fri, 3 Feb 2006 17:37:57 +0000

On 3 Feb 2006, at 17:24, Siddhartha Gandhi wrote:
> As per RFC 1889/3550, the Sender and Member Tables will store all  
> the unique participants (SSRC /CSRC) that is extracts from the RTCP  
> and RTP packets.
>
> Also the Receivers in a multicast environment are not allowed to  
> talk to each other i.e, send RTCP packets.
>
>
>
> Given the above two facts, how does a receiver know, how many  
> receivers other than itself are there in the multicast session or  
> conference ?

The receivers send RTCP RR packets to the multicast group.

Colin