Subject: [AVT] Question on RFC 2833

From: <[email-masked]>
Date: Sun, 26 Feb 2006 04:07:52 +0530

I have a question regarding DTMF relay implementation using RFC2833. 
 
(1) If the DTMF receiver does not receive first DTMF packet but receives directly an end-bit packet, should it generate full DTMF tone? Typically it happens if tone is short say 40ms.
 
(2) Is it allowed to send a DTMF packet with Marker bit and end-bit set if the tone is of short duration (typically shorter than the packetization interval)? Should the receiver honor such packet with full genertion of tone.
 
I would appreciate views on this one from other designers.
 
Thanks & Regards,
Rupesh
 
--
Rupesh W Kumbhare
Software Specialist
DSP & Multimedia Group,
Wipro Technologies
OFF: 301-515-3783
 
_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Sat, 25 Feb 2006 19:59:52 -0500

I'm not an implementor, just an editor, so you can weigh my opinions 
accordingly.

My view on 1) is that the full duration should be played out. That's the 
point of including cumulative duration in every packet -- you can lose 
one and still have all the information you need. Of course, this also 
means you are playing with a bit of a lag, but that is probably OK for DTMF.

My view of 2) is "yes" -- this is perfectly legal within the payload rules.

[email-masked] wrote:
> (1) If the DTMF receiver does not receive first DTMF packet but
> receives directly an end-bit packet, should it generate full DTMF
> tone? Typically it happens if tone is short say 40ms.
> 
> (2) Is it allowed to send a DTMF packet with Marker bit and end-bit
> set if the tone is of short duration (typically shorter than the
> packetization interval)? Should the receiver honor such packet with
> full genertion of tone.
> 
> Thanks & Regards, Rupesh
> -- Rupesh W Kumbhare Software Specialist DSP & Multimedia Group, 
> Wipro Technologies OFF: 301-515-3783
> 
> 
> 
> 
> ------------------------------------------------------------------------
> 
> 
> _______________________________________________ Audio/Video Transport
> Working Group [email-masked] https://www1.ietf.org/mailman/listinfo/avt

---

From: <[email-masked]>
Date: Sun, 26 Feb 2006 09:18:07 +0530

Thank you for your reply! I also interpreted and planned to implement the same way, but wanted to check with other engineers for maximum interoperability.
 
Regards,
Rupesh
 
---
Rupesh W Kumbhare
Software Specialist
DSP & Multimedia Group,
Wipro Technologies
OFF: 301-515-3783
 
________________________________

From: Taylor, Tom-PT [CAR:5N00:EXCH] [mailto:[email-masked]]
Sent: Sat 2/25/2006 7:59 PM
To: Rupesh W Kumbhare (WT01 - VLSI Services)
Cc: [email-masked]
Subject: Re: [AVT] Question on RFC 2833