Subject: RE: [AVT] Comments requested - RTCP XR MIB restructuring

From: "Strahm, Bill" <[email-masked]>
Date: Mon, 17 Jul 2006 15:02:47 -0700

What does the XR MIB cover that the RTP MIB wouldn't cover ?
 
Just curious.  In the design of the RTP MIB we thought we would have
covered the point-point case...
 
I guess I will need to look into the XR MIB - been out of the space
until recently.

Bill

________________________________

From: Alan Clark [mailto:[email-masked]] 
Sent: Monday, July 17, 2006 2:45 PM
To: 'Romascanu, Dan (Dan)'; [email-masked]
Subject: RE: [AVT] Comments requested - RTCP XR MIB restructuring

Dan
 
The existing RTCP XR MIB draft covers point-to-point applications
whereas the RTP MIB (and RTP) addresses multicast, unicast,
broadcast....  
 
Alan

________________________________

	From: Romascanu, Dan (Dan) [mailto:[email-masked]] 
	Sent: Friday, July 14, 2006 5:45 PM
	To: Alan Clark; [email-masked]
	Subject: RE: [AVT] Comments requested - RTCP XR MIB
restructuring

	Alan,
	 
	I could not attend the AVT WG meeting this morning because of a
conflicting meeting in my area. Can you shortly explain what are the
advantages of this restructuring and specifically what use cases can be
covered with the new structure and were un-accessible before?
	 
	Thanks and Regards, 
	 
	Dan

________________________________

		From: Alan Clark [mailto:[email-masked]] 
		Sent: Friday, July 14, 2006 6:24 PM
		To: [email-masked]
		Subject: [AVT] Comments requested - RTCP XR MIB
restructuring

		The AVT group previously agreed that the RTP MIB/ RTCP
XR MIB should be restructured to accomodate a wider range of RTP use
cases.
		 
		At the Montreal AVT meeting I proposed that this could
be accomodated by making the RTCP XR MIB an extension to the RTP MIB's
Receiver Table rather than the Session Table.  This approach did receive
some support, and no disagreement, at the meeting however I'd like to
get any other viewpoints from the AVT list prior to restructuring the
MIB.
		 
		If you have any disagreement with the above proposal
then please let me know by 4th August.  I'll implement the changes after
that date.
		 
		Thanks
		 
		Alan Clark

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: "Alan Clark" <[email-masked]>
Date: Mon, 17 Jul 2006 18:38:36 -0400

It's more the other way around - the XR MIB provides more detailed VoIP
related metrics but is point-to-point whereas the RTP MIB "also covers"
multicast....
 
Hence the restructuring of the XR MIB would allow it to inherit the wider
variety of topologies covered by the RTP MIB
 
Regards
 
Alan

  _____  

From: Strahm, Bill [mailto:[email-masked]] 
Sent: Monday, July 17, 2006 6:03 PM
To: [email-masked]
Subject: RE: [AVT] Comments requested - RTCP XR MIB restructuring

Just curious.  In the design of the RTP MIB we thought we would have covered
the point-point case...
 
I guess I will need to look into the XR MIB - been out of the space until
recently.

Bill

  _____  

Dan
 
The existing RTCP XR MIB draft covers point-to-point applications whereas
the RTP MIB (and RTP) addresses multicast, unicast, broadcast....  
 
Alan

  _____  

Alan,
 
I could not attend the AVT WG meeting this morning because of a conflicting
meeting in my area. Can you shortly explain what are the advantages of this
restructuring and specifically what use cases can be covered with the new
structure and were un-accessible before?
 
Thanks and Regards, 
 
Dan

  _____  

From: Alan Clark [mailto:[email-masked]] 
Sent: Friday, July 14, 2006 6:24 PM
To: [email-masked]
Subject: [AVT] Comments requested - RTCP XR MIB restructuring

The AVT group previously agreed that the RTP MIB/ RTCP XR MIB should be
restructured to accomodate a wider range of RTP use cases.
 
At the Montreal AVT meeting I proposed that this could be accomodated by
making the RTCP XR MIB an extension to the RTP MIB's Receiver Table rather
than the Session Table.  This approach did receive some support, and no
disagreement, at the meeting however I'd like to get any other viewpoints
from the AVT list prior to restructuring the MIB.
 
If you have any disagreement with the above proposal then please let me know
by 4th August.  I'll implement the changes after that date.
 
Thanks
 
Alan Clark