Subject: [AVT] More Comments on draft-clark-avt-rtcpxr-video-02

From: "Fardid, Reza" <[email-masked]>
Date: Fri, 14 Jul 2006 00:41:20 -0700

Alan, Amy,
 
These comments reflect a Service Provider perspective on this Draft:
 
Sec 3.1: 
 
RTP and MPEG Metrics:
 -Average Jitter is not a useful statistic for real-time management of Voice over IP sessions compared
   to Jitter Percentile.  The IPPM WG is also de-emphasizing its use. Has its significance been proven in
   the context of Video over IP to include it in these metrics sub-blocks?
 
Video/Audio Metrics: 
-Overwhelming network management with too many Video Service Quality metrics is not likely to be   productive. In particular, when these metrics are expected to be correlated to one another and to IP/RTP metrics. A single composite A/V quality metric and a control plane quality metric will be sufficient for most practical purposes.
 
Sec 3.2:
 
It may useful to have an indication of inactive media based on a configurable timer to suppress sending the sub-blocks. For instance, Block Type = mmm+10 can indicate Null metrics.
 
Sec 3.3:
 
Is the Number of IP Packets Expected estimated from the last M sessions, as an average or smoothed average?  I wonder about the usefulness of this estimate.  Can you please clarify?
 
Regards,
Reza Fardid

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Alan Clark <[email-masked]>
Date: Fri, 14 Jul 2006 07:26:41 -0400

Reza

Thanks for the comments - some of which would apply equally to the RTCP HR
draft.

> Sec 3.1: 
>  
> RTP and MPEG Metrics:
>  -Average Jitter is not a useful statistic for real-time 
> management of Voice over IP sessions compared
>    to Jitter Percentile.  The IPPM WG is also de-emphasizing 
> its use. Has its significance been proven in

We intend that RTCP XR Video be aligned with RTCP HR in the area of jitter
metrics (where it makes sense).

Also - MAPDV is a very useful metric for VoIP applications, it correlates
well with jitter buffer behavior (e.g. is a good predictor of optimum jitter
buffer size)

> Video/Audio Metrics: 
> -Overwhelming network management with too many Video Service 
> Quality metrics is not likely to be   productive. In 
> particular, when these metrics are expected to be correlated 
> to one another and to IP/RTP metrics. A single composite A/V 
> quality metric and a control plane quality metric will be 
> sufficient for most practical purposes.

These metrics are in discussion in other standards groups that are heavily
service provider oriented - if anything some of these groups are generating
even more metrics :-(

> Sec 3.2:
>  
> It may useful to have an indication of inactive media based 
> on a configurable timer to suppress sending the sub-blocks. 
> For instance, Block Type = mmm+10 can indicate Null metrics.

Good idea - we can accomodate this or some equivalent

> Sec 3.3:
>  
> Is the Number of IP Packets Expected estimated from the last 
> M sessions, as an average or smoothed average?  I wonder 
> about the usefulness of this estimate.  Can you please clarify?

This is as per RTCP HR - and is simply to allow you to put some metrics in
context.  I can see a potential issue with multiplexed MPEG streams over a
single IP path .. needs further clarification

Regards

Alan