Subject: Re: [AVT] I-D ACTION:draft-setsko-avt-ipmr-00.txt

From: Colin Perkins <[email-masked]>
Date: Wed, 20 Feb 2008 13:57:36 +0000

Andrey,

Thanks - these seem like good changes. You should resubmit the draft  
to the IETF (using the tool at https://datatracker.ietf.org/idst/ 
upload.cgi), with an incremented version number (-01), and updated  
date. That makes it available for others to review.

Colin

On 18 Feb 2008, at 15:18, Andrey Setsko wrote:
> Dear Colin,
>
> Thank you for your comments and suggestions.
> First of all we left only in-band signaling since the codec is capable
> to change its bitrate on the fly.
> As for "T" bit we have left it but removed entire extended header
> description as you recommended.
> Also we've corrected media type description to match the guidelines  
> you
> kindly provided.
> Please find the edited document enclosed. I'm not if I need to send it
> to you or just re-submit it once again to the website. Also it's not
> clear if we need to change the dates each time we make a revision and
> release a new document version. Thanks in advance for your assistance!
>
> Best regards,
> Andrey Setsko
> SPIRIT DSP
> tel.: +7 495 912-62-39
>
> -----Original Message-----
> From: Colin Perkins [mailto:[email-masked]]
> Sent: Sunday, December 30, 2007 8:58 PM
> To: Andrey Setsko
> Cc: AVT WG
> Subject: Re: I-D ACTION:draft-setsko-avt-ipmr-00.txt
>
> Andrey,
>
> On 18 Dec 2007, at 20:15, [email-masked] wrote:
>> A New Internet-Draft is available from the on-line Internet-Drafts
>> directories.
>>
>> Title	: RTP Payload Format for SPIRIT IP-MR Speech Codec Software
>> Author	: A. Setsko
>> Filename: draft-setsko-avt-ipmr-00.txt
>> Pages	: 14
>> Date	: 2007-12-18
>> 	
>>   This document specifies the payload format for packetization of
>>   SPIRIT IP-MR encoded speech signals into the Real-time Transport
>>   Protocol (RTP). The payload format supports transmission of  
>> multiple
>>   frames per payload, introduced redundancy for robustness against
>>   packet loss, and payload format extension for future versions
>>   compatibility.
>>
>> A URL for this Internet-Draft is:
>> http://www.ietf.org/internet-drafts/draft-setsko-avt-ipmr-00.txt
>
> This generally looks very reasonable, although I have a couple of
> comments:
>
> The payload header includes two bits to signal if DTX is allowed and
> if byte aligned mode is used. There are also media type parameters
> defined to signal these features suitable for use with SDP
> signalling. It's not clear that both are useful - you might consider
> removing in-band signalling from the payload header, and relying
> solely on the SDP signalling.
>
> Similarly, the payload header includes a bit (the "T bit") to
> indicate the presence of an extension to the payload header.
> Including extension headers in-band like this makes it difficult to
> negotiate their use: it's generally better to use different media
> subtype names for each variant, and hence use a different RTP payload
> type for each, since that allows negotiation for the extension.
>
> Section 3 uses the old media type registration template, and should
> be updated to follow RFCs 4855 and 4288.
>
> Regards,
>
> -- 
> Colin Perkins
> http://csperkins.org/
>
>
> <draft-setsko-avt-ipmr-01.txt>

-- 
Colin Perkins
http://csperkins.org/

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
http://www.ietf.org/mailman/listinfo/avt

---

From: "Andrey Setsko" <[email-masked]>
Date: Thu, 21 Feb 2008 14:48:24 +0300

Dear Colin,

When I uploaded the document to IETF for the first time, I was asked to
change the draft status (and file name) to individual draft until the
working group decides it can be considered to be a working document.
Could you please advise when it may happen, since we have already
started some technical discussions? Also could you please clarify what
is the next step for the draft submission?

Thanks in advance!

Best regards,
Andrey Setsko
SPIRIT DSP
tel.: +7 495 912-62-39

-----Original Message-----
From: Colin Perkins [mailto:[email-masked]] 
Sent: Wednesday, February 20, 2008 4:58 PM
To: Andrey Setsko
Cc: AVT WG
Subject: Re: I-D ACTION:draft-setsko-avt-ipmr-00.txt 

Andrey,

Colin

-- 
Colin Perkins
http://csperkins.org/

---

From: Colin Perkins <[email-masked]>
Date: Fri, 22 Feb 2008 10:35:57 +0000

Andrey,

On 21 Feb 2008, at 11:48, Andrey Setsko wrote:
> started some technical discussions?

The draft is clearly within the scope of our charter, so I don't see  
any problem with accepting it as an AVT working group draft, should  
you want that. I won't be at the coming meeting, but my co-chairs can  
probably start the process then. If not, we can do so via the mailing  
list, after the meeting.

> Also could you please clarify what is the next step for the draft  
> submission?

The deadline for submissions to be considered at the coming meeting  
is 5:00pm US Eastern Time on Monday 25th February. Before that time,  
you need to update the draft you circulated, to add the current date,  
and update to version -01, then submit it to the IETF using the web  
form at https://datatracker.ietf.org/idst/upload.cgi

Colin

---

From: Colin Perkins <[email-masked]>
Date: Fri, 22 Feb 2008 10:53:08 +0000

> form at https://datatracker.ietf.org/idst/upload.cgi

Catching up on my i-d-announce email, I see this has already been done.

-- 
Colin Perkins
http://csperkins.org/