Subject: [AVT] WGLC for draft-ietf-avt-rtp-mps-00.txt

From: Tom Taylor <[email-masked]>
Date: Thu, 02 Oct 2008 12:32:42 -0400

Working Group Last Call is issued for draft-ietf-avt-rtp-mps-00.txt, "RTP 
Payload Format for Elementary Streams with MPEG Surround multi- 
             channel audio", as a Standards Track document. Please forward 
comments to the list copy the authors by October 16 2008.

Tom Taylor
AVT Co-Chair
_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www.ietf.org/mailman/listinfo/avt

---

From: Colin Perkins <[email-masked]>
Date: Fri, 17 Oct 2008 00:08:58 +0100

On 2 Oct 2008, at 17:32, Tom Taylor wrote:
> Working Group Last Call is issued for draft-ietf-avt-rtp- 
> mps-00.txt, "RTP Payload Format for Elementary Streams with MPEG  
> Surround multi-             channel audio", as a Standards Track  
> document. Please forward comments to the list copy the authors by  
> October 16 2008.

In general, I'm comfortable with this draft progressing, but I did  
have some detailed comments:

- In Section 4.2, it might be useful to clarify that RTCP SR packets  
will show a constant offset between RTP timestamp and NTP timestamp,  
and that "in the same block domain" means derived from a common clock.

- The Abstract, and Section 4.1, 4.2.1, 4.2.2, 5, and 5.3 use the  
term "MIME Type". They should use the term "Media Type", since the  
types database is used for more than just MIME email.

-- 
Colin Perkins
http://csperkins.org/

---

From: Colin Perkins <[email-masked]>
Date: Mon, 20 Oct 2008 18:47:54 +0100

Hi Malte,

On 20 Oct 2008, at 11:31, Schmidt , Malte wrote:
>> In general, I'm comfortable with this draft progressing, but
>> I did have some detailed comments:
>>
>> - In Section 4.2, it might be useful to clarify that RTCP SR
>> packets will show a constant offset between RTP timestamp and
>> NTP timestamp,
>
> Here I have a little problem understanding you correctly. My  
> understanding is that the clock(s) used to generate the RTP  
> timestamps must not drift. The RTP and the NTP clock may drift and  
> thus have a non-constant offset.

You're right - my mistake. The RTP timestamps for each stream will  
drift relative to the NTP clock at the same rate, since they're  
essentially the same clock.

The other changes look good.

-- 
Colin Perkins
http://csperkins.org/

---

From: "Schmidt , Malte" <[email-masked]>
Date: Mon, 20 Oct 2008 11:31:46 +0100

Hi Colin,

> packets will show a constant offset between RTP timestamp and 

Here I have a little problem understanding you correctly. My understanding is that the clock(s) used to generate the RTP timestamps must not drift. The RTP and the NTP clock may drift and thus have a non-constant offset. 

> derived from a common clock.

o.k. I'll changed that to:
The media clocks of the MPEG Surround elementary stream and the downmix stream SHALL operate in the same clock domain, i.e. the media clocks are derived from a common clock and MUST NOT drift

> - The Abstract, and Section 4.1, 4.2.1, 4.2.2, 5, and 5.3 use 
> the term "MIME Type". They should use the term "Media Type", 
> since the types database is used for more than just MIME email.

o.k.

I modified the draft accordingly and took a small editorial change from the mmusic draft into account. The draft can be found at:
http://www.ietf.org/internet-drafts/draft-ietf-avt-rtp-mps-01.txt

Given that these changes have been editorial only is it o.k. to go ahead with this draft?

Best,
Malte

MALTE SCHMIDT
SYSTEMS ENGINEER

Dolby Germany GmbH
Deutschherrnstr. 15 - 19            
90429 Nuernberg, Germany           
http://www.dolby.com

+ 49 911 928 91 - 42 (phone)
+ 49 911 928 91 - 99 (fax)
mailto:[email-masked]

HRB 17557, Amtsgericht Nürnberg,
GF: Dipl.Ing. Martin Dietz (Managing Director) 

> -----Original Message-----
> From: Colin Perkins [mailto:[email-masked]] 
> Sent: Friday, October 17, 2008 1:09 AM
> To: Tom Taylor
> Cc: IETF AVT WG; Schmidt , Malte; Ralph Sperschneider; 
> [email-masked]; [email-masked]
> Subject: Re: [AVT] WGLC for draft-ietf-avt-rtp-mps-00.txt
> 

-----------------------------------------
This message (including any attachments) may contain confidential
information intended for a specific individual and purpose.  If you
are not the intended recipient, delete this message.  If you are
not the intended recipient, disclosing, copying, distributing, or
taking any action based on this message is strictly prohibited.
_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www.ietf.org/mailman/listinfo/avt