Subject: Re: [AVT] avt Digest, Vol 56, Issue 13

From: "Ingemar Johansson S" <[email-masked]>
Date: Mon, 15 Dec 2008 10:17:25 +0100

Hi

I have briefly read though this draft and one thing that 
it lacks is a reference to a proper codec specification.
As all standardized media types refer to codec specifications 
that are available in one form or the other I would believe 
that it is reasonable to require the same in this case as well.
The referred codec specification needs to contain a 
description of both functions and data structures.

Regards
Ingemar Johansson

> 
> Message: 1
> Date: Wed, 10 Dec 2008 09:08:59 -0500
> From: Tom Taylor <[email-masked]>
> Subject: Re: [AVT] Request comments on draft-legrand-rtp-isac-00.txt
> To: Tina le Grand <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset=ISO-8859-1; format=flowed
> 
> You can register isac as a media type quite straightforwardly 
> in the vendor branch of the tree. That is, the media type 
> would be audio/vnd.isac.
> 
> Tina le Grand wrote:
> > Hi,
> > 
> > This is the background: iSAC is a proprietary wideband 
> speech codec that is supported by a number of vendors and 
> they are using audio/isac as media type. We would like to 
> register the name to avoid conflicts and confusion, and to 
> make sure the codec is used in a standardized way. There are 
> no other document to refer to than the one mentioned in the 
> draft. What kind of information do you think is needed in 
> this draft to make it more complete?
> > Is it possible to register isac as a media type?
> > 
> > Thanks!
> > 
> > Regards,
> > Tina le Grand.
> > 
> > 
> > From: Roni Even [mailto:[email-masked]]
> > Sent: Monday, December 08, 2008 4:10 PM
> > To: Tina le Grand; [email-masked]
> > Subject: RE: [AVT] Request comments on draft-legrand-rtp-isac-00.txt
> > 
> > Hi,
> > I am not familiar with this codec, what type of the codec 
> documentation is publically available. Your reference in the 
> draft is to some marketing document.
> > This information may help progress the payload specification in AVT
> > 
> > Roni Even
> > AVT co-chair
> > 
> > From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of 
> > Tina le Grand
> > Sent: Thursday, December 04, 2008 6:11 PM
> > To: [email-masked]
> > Subject: [AVT] Request comments on draft-legrand-rtp-isac-00.txt
> > 
> > I sent an email to the list a while ago, asking for 
> comments on the Internet-Draft 
> "draft-legrand-rtp-isac-00.txt" 
> (http://www.ietf.org/internet-drafts/draft-legrand-rtp-isac-00
> .txt), but have not yet received any. I would highly 
> appreciate to have the draft reviewed, all comments are welcome.
> > 
> > The draft is a description of the RTP Payload format for 
> the iSAC wideband speech codec.
> > 
> > Best regards,
> > Tina le Grand.
> > 
> > Tina le Grand
> > R&D Manager, Stockholm
> > Global IP Solutions
> > http://www.gipscorp.com<http://www.gipscorp.com/>
> > Magnus Ladul?sgatan 63B | 118 27 Stockholm | Sweden
> > Phone: +46 8 410 398 03 | Mobile: +46 70 209 06 99
> > 
> > 
> > ________________________________
> > CONFIDENTIALITY NOTE: This e-mail message, including any 
> attachment(s), contains information that may be confidential, 
> protected by the attorney-client or other legal privileges, 
> and/or proprietary non-public information. If you are not an 
> intended recipient of this message or an authorized assistant 
> to an intended recipient, please do not read, copy, use or 
> disclose this communication and notify the sender 
> immediately. It should be noted that any review, 
> retransmission, dissemination or other use of, or taking 
> action or reliance upon, this information by persons or 
> entities other than the intended recipient is prohibited.
> > 
> > ________________________________
> > CONFIDENTIALITY NOTE: This e-mail message, including any 
> attachment(s), contains information that may be confidential, 
> protected by the attorney-client or other legal privileges, 
> and/or proprietary non-public information. If you are not an 
> intended recipient of this message or an authorized assistant 
> to an intended recipient, please do not read, copy, use or 
> disclose this communication and notify the sender 
> immediately. It should be noted that any review, 
> retransmission, dissemination or other use of, or taking 
> action or reliance upon, this information by persons or 
> entities other than the intended recipient is prohibited.
> > 
> > 
> > 
> > 
> ----------------------------------------------------------------------
> > --
> > 
> > _______________________________________________
> > Audio/Video Transport Working Group
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/avt
> 
> 
> ------------------------------
> 
> Message: 2
> Date: Wed, 10 Dec 2008 20:06:36 +0200
> From: "Roni Even" <[email-masked]>
> Subject: Re: [AVT] Request comments on draft-legrand-rtp-isac-00.txt
> To: "'Tina le Grand'" <[email-masked]>,	<[email-masked]>
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset="iso-8859-1"
> 
> Tina,
> 
> To register a media subtype name in IANA you need to follow
> http://tools.ietf.org/html/rfc4855 . you will need to have a 
> draft according to it. 
> 
> Most probably this payload can be registered under the vendor 
> tree like Tom wrote.
> 
>  
> 
> If you want to try to have it in the standard tree the draft 
> needs to specify the payload better. You can look at one of 
> the audio payload types in AVT as an example.
> 
>  
> 
> Roni Even
> 
>  
> 
> From: Tina le Grand [mailto:[email-masked]]
> Sent: Wednesday, December 10, 2008 12:31 PM
> To: Roni Even; [email-masked]
> Subject: RE: [AVT] Request comments on draft-legrand-rtp-isac-00.txt
> 
>  
> 
> Hi,
> 
>  
> 
> This is the background: iSAC is a proprietary wideband speech 
> codec that is supported by a number of vendors and they are 
> using audio/isac as media type. We would like to register the 
> name to avoid conflicts and confusion, and to make sure the 
> codec is used in a standardized way. There are no other 
> document to refer to than the one mentioned in the draft. 
> What kind of information do you think is needed in this draft 
> to make it more complete?
> 
> Is it possible to register isac as a media type?
> 
>  
> 
> Thanks!
> 
>  
> 
> Regards,
> 
> Tina le Grand.
> 
>  
> 
>  
> 
> From: Roni Even [mailto:[email-masked]]
> Sent: Monday, December 08, 2008 4:10 PM
> To: Tina le Grand; [email-masked]
> Subject: RE: [AVT] Request comments on draft-legrand-rtp-isac-00.txt
> 
>  
> 
> Hi,
> 
> I am not familiar with this codec, what type of the codec 
> documentation is publically available. Your reference in the 
> draft is to some marketing document.
> 
> This information may help progress the payload specification in AVT
> 
>  
> 
> Roni Even
> 
> AVT co-chair
> 
>  
> 
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Tina le Grand
> Sent: Thursday, December 04, 2008 6:11 PM
> To: [email-masked]
> Subject: [AVT] Request comments on draft-legrand-rtp-isac-00.txt
> 
>  
> 
> I sent an email to the list a while ago, asking for comments 
> on the Internet-Draft ?draft-legrand-rtp-isac-00.txt?
> (http://www.ietf.org/internet-drafts/draft-legrand-rtp-isac-00
> .txt), but have not yet received any. I would highly 
> appreciate to have the draft reviewed, all comments are welcome.
> 
>  
> 
> The draft is a description of the RTP Payload format for the 
> iSAC wideband speech codec.
> 
>  
> 
> Best regards,
> 
> Tina le Grand.
> 
>  
> 
> Tina le Grand
> R&D Manager, Stockholm
> Global IP Solutions
> http://www.gipscorp.com <http://www.gipscorp.com/> Magnus 
> Ladul?sgatan 63B | 118 27 Stockholm | Sweden
> Phone: +46 8 410 398 03 | Mobile: +46 70 209 06 99
> 
>  
> 
>  
> 
>   _____  
> 
> CONFIDENTIALITY NOTE: This e-mail message, including any 
> attachment(s), contains information that may be confidential, 
> protected by the attorney-client or other legal privileges, 
> and/or proprietary non-public information. If you are not an 
> intended recipient of this message or an authorized assistant 
> to an intended recipient, please do not read, copy, use or 
> disclose this communication and notify the sender 
> immediately. It should be noted that any review, 
> retransmission, dissemination or other use of, or taking 
> action or reliance upon, this information by persons or 
> entities other than the intended recipient is prohibited.
> 
>  
> 
>   _____  
> 
> CONFIDENTIALITY NOTE: This e-mail message, including any 
> attachment(s), contains information that may be confidential, 
> protected by the attorney-client or other legal privileges, 
> and/or proprietary non-public information. If you are not an 
> intended recipient of this message or an authorized assistant 
> to an intended recipient, please do not read, copy, use or 
> disclose this communication and notify the sender 
> immediately. It should be noted that any review, 
> retransmission, dissemination or other use of, or taking 
> action or reliance upon, this information by persons or 
> entities other than the intended recipient is prohibited.
> 
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL: 
> <http://www.ietf.org/pipermail/avt/attachments/20081210/3ba05e
> 97/attachment-0001.htm>
> 
> ------------------------------
> 
> _______________________________________________
> Audio/Video Transport Working Group
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avt
> 
> 
> End of avt Digest, Vol 56, Issue 13
> ***********************************
> 
_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www.ietf.org/mailman/listinfo/avt

---

From: "Ingemar Johansson S" <[email-masked]>
Date: Mon, 15 Dec 2008 10:34:42 +0100

Hi

Misleading subject line in my last email (sorry) 

I have briefly read though this draft and one thing that it lacks is a
reference to a proper codec specification.
As all standardized media types refer to codec specifications that are
available in one form or the other I would believe that it is reasonable
to require the same in this case as well.
The referred codec specification needs to contain a description of both
functions and data structures.

Regards
Ingemar Johansson 

> -----Original Message-----
> Behalf Of [email-masked]
> Sent: den 10 december 2008 21:00
> To: [email-masked]
> Subject: avt Digest, Vol 56, Issue 13
> 
> Send avt mailing list submissions to
> 	[email-masked]
> 
> To subscribe or unsubscribe via the World Wide Web, visit
> or, via email, send a message with subject or body 'help' to
> 	[email-masked]
> 
> You can reach the person managing the list at
> 	[email-masked]
> 
> When replying, please edit your Subject line so it is more 
> specific than "Re: Contents of avt digest..."
> 
> 
> Today's Topics:
> 
>    1. Re: Request comments on draft-legrand-rtp-isac-00.txt 
> (Tom Taylor)
>    2. Re: Request comments on draft-legrand-rtp-isac-00.txt 
> (Roni Even)
> 
>

---

From: Tina le Grand <[email-masked]>
Date: Mon, 15 Dec 2008 02:19:01 -0800

Ingemar,

Thanks for reviewing the document. I see the need for a better codec description, but since iSAC is not a standard codec and the intention with this internet-draft is to standardize the RTP format, not the codec, I do not see why a separate codec specification is needed? Are there any RFCs for non-standard codecs that you can advice me to look at?

Regards,
Tina le Grand.

-----Original Message-----
From: Ingemar Johansson S [mailto:[email-masked]]
Sent: Monday, December 15, 2008 10:35 AM
To: [email-masked]
Cc: Tina le Grand; [email-masked]; [email-masked]; Ingemar Johansson S
Subject: RE: Request comments on draft-legrand-rtp-isac-00.txt

Hi

Regards
Ingemar Johansson

> entities other than the intended recipient is prohibited.

CONFIDENTIALITY NOTE:  This e-mail message, including any attachment(s), contains information that may be confidential, protected by the attorney-client or other legal privileges, and/or proprietary non-public information. If you are not an intended recipient of this message or an authorized assistant to an intended recipient, please do not read, copy, use or disclose this communication and notify the sender immediately. It should be noted that any review, retransmission, dissemination or other use of, or taking action or reliance upon, this information by persons or entities other than the intended recipient is prohibited.
_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www.ietf.org/mailman/listinfo/avt

---

From: "Ingemar Johansson S" <[email-masked]>
Date: Mon, 15 Dec 2008 14:22:48 +0100

Hi

I am not aware of any non-standardized (or perhaps we should call it
non-documented) codec that has a standardized media type. 
I skimmed through all the payload format RFC's at
http://tools.ietf.org/wg/avt/ and could not find any example of this. 
As an example your iLBC codec is thorougly described with the complete
code in RFC3951 and thus I would say that the reference requirement is
fulfilled. 

Regards
/Ingemar

> Sent: den 15 december 2008 11:19
> To: Ingemar Johansson S; [email-masked]
> Cc: [email-masked]; [email-masked]
> Thanks for reviewing the document. I see the need for a 
> better codec description, but since iSAC is not a standard 
> codec and the intention with this internet-draft is to 
> standardize the RTP format, not the codec, I do not see why a 
> separate codec specification is needed? Are there any RFCs 
> for non-standard codecs that you can advice me to look at?
> 
> Regards,
> Tina le Grand.
> 
> Cc: Tina le Grand; [email-masked]; 
> [email-masked]; Ingemar Johansson S
> I have briefly read though this draft and one thing that it 
> lacks is a reference to a proper codec specification.
> > When replying, please edit your Subject line so it is more specific 
> > than "Re: Contents of avt digest..."
> >
> >
> > Today's Topics:
> >
> >    1. Re: Request comments on draft-legrand-rtp-isac-00.txt (Tom 
> > Taylor)
> >    2. Re: Request comments on draft-legrand-rtp-isac-00.txt (Roni 
> > Even)
> >
> >
> > 
> > You can register isac as a media type quite 
> straightforwardly in the 
> > vendor branch of the tree. That is, the media type would be 
> > audio/vnd.isac.
> >
> > Tina le Grand wrote:
> > > Hi,
> > >
> > speech codec that is supported by a number of vendors and they are 
> > using audio/isac as media type. We would like to register 
> the name to 
> > avoid conflicts and confusion, and to make sure the codec 
> is used in a 
> > standardized way. There are no other document to refer to 
> than the one 
> > mentioned in the draft. What kind of information do you think is 
> > needed in this draft to make it more complete?
> > documentation is publically available. Your reference in 
> the draft is 
> > to some marketing document.
> > .txt), but have not yet received any. I would highly appreciate to 
> > have the draft reviewed, all comments are welcome.
> > >
> > protected by the attorney-client or other legal privileges, and/or 
> > proprietary non-public information. If you are not an intended 
> > recipient of this message or an authorized assistant to an intended 
> > recipient, please do not read, copy, use or disclose this 
> > communication and notify the sender immediately. It should be noted 
> > that any review, retransmission, dissemination or other use of, or 
> > taking action or reliance upon, this information by persons or 
> > protected by the attorney-client or other legal privileges, and/or 
> > proprietary non-public information. If you are not an intended 
> > recipient of this message or an authorized assistant to an intended 
> > recipient, please do not read, copy, use or disclose this 
> > communication and notify the sender immediately. It should be noted 
> > that any review, retransmission, dissemination or other use of, or 
> > taking action or reliance upon, this information by persons or 
> > http://tools.ietf.org/html/rfc4855 . you will need to have a draft 
> > according to it.
> >
> > Most probably this payload can be registered under the vendor tree 
> > like Tom wrote.
> >
> >
> >
> > If you want to try to have it in the standard tree the 
> draft needs to 
> > specify the payload better. You can look at one of the 
> audio payload 
> > types in AVT as an example.
> >
> >
> >
> > Roni Even
> >
> >
> >
> > This is the background: iSAC is a proprietary wideband speech codec 
> > that is supported by a number of vendors and they are using 
> audio/isac 
> > as media type. We would like to register the name to avoid 
> conflicts 
> > and confusion, and to make sure the codec is used in a standardized 
> > way. There are no other document to refer to than the one 
> mentioned in 
> > the draft.
> > What kind of information do you think is needed in this 
> draft to make 
> > it more complete?
> >
> > documentation is publically available. Your reference in 
> the draft is 
> > to some marketing document.
> >
> > I sent an email to the list a while ago, asking for comments on the 
> > Internet-Draft ?draft-legrand-rtp-isac-00.txt?
> > .txt), but have not yet received any. I would highly appreciate to 
> > have the draft reviewed, all comments are welcome.
> >
> >
> >
> > The draft is a description of the RTP Payload format for the iSAC 
> > wideband speech codec.
> >
> >
> >
> > Best regards,
> >
> > Tina le Grand.
> >
> >
> >
> > Tina le Grand
> > R&D Manager, Stockholm
> > Global IP Solutions
> > protected by the attorney-client or other legal privileges, and/or 
> > proprietary non-public information. If you are not an intended 
> > recipient of this message or an authorized assistant to an intended 
> > recipient, please do not read, copy, use or disclose this 
> > communication and notify the sender immediately. It should be noted 
> > that any review, retransmission, dissemination or other use of, or 
> > taking action or reliance upon, this information by persons or 
> > protected by the attorney-client or other legal privileges, and/or 
> > proprietary non-public information. If you are not an intended 
> > recipient of this message or an authorized assistant to an intended 
> > recipient, please do not read, copy, use or disclose this 
> > communication and notify the sender immediately. It should be noted 
> > that any review, retransmission, dissemination or other use of, or 
> > taking action or reliance upon, this information by persons or 
> > -------------- next part -------------- An HTML attachment was 
> > scrubbed...
> > URL:

---

From: Tom Taylor <[email-masked]>
Date: Mon, 15 Dec 2008 08:51:37 -0500

We have been going through a similar discussion for other codecs lately: SPEEX 
and UEMCLIP. RFC 4855 requires a description of the media encoding and a 
specification of the payload format. However, the part about "description of the 
media encoding" is qualified by the following sentence:

"A reference to a further description of the data compression format itself 
should be provided, if available."

I interpret this pragmatically to mean that the encoding has to be sufficiently 
well described that the payload description makes sense, but no more. 
Unfortunately I'm not the final arbiter -- the IESG is, and Roni may have a 
slightly different view. (Please cut in if you do, Roni.)

---

From: Magnus Westerlund <[email-masked]>
Date: Mon, 15 Dec 2008 16:53:03 +0100

Tom Taylor skrev:
> We have been going through a similar discussion for other codecs lately:
> SPEEX and UEMCLIP. RFC 4855 requires a description of the media encoding
> and a specification of the payload format. However, the part about
> "description of the media encoding" is qualified by the following sentence:
> 
> "A reference to a further description of the data compression format
> itself should be provided, if available."
> 
> I interpret this pragmatically to mean that the encoding has to be
> sufficiently well described that the payload description makes sense,
> but no more. Unfortunately I'm not the final arbiter -- the IESG is, and
> Roni may have a slightly different view. (Please cut in if you do, Roni.)

Hi,

As former AVT chair I would like to point to two cases:

Vorbis, which is an open source codec. They have a codec specification
that provide a description that is almost possible to implement from.
However, they also have source code for the codec which in their minds
is the normative description. That is why we previously have accepted
that as reference. But this did result in some discussion at IESG level
before being approved.

ATRAC, the codec is proprietary but Sony does offer to license it and do
have codec specification that to my understanding is possible to
implement from.

Getting more into my personal view and without any IETF formal hats on:

My view is that the codec reference for RTP payload formats that are
requesting media types on the standards tree is well specified. That you
have some possibility to implement based on that reference. Please note
that the reference does not need to be freely available, but if only
released after licensing then it should be released to at least a few
key persons that can review this and say that the payload format and the
codec data format isn't clashing in some way.

I also would like to point out that the argument that you like
audio/isac registered because you are using it, is confrontational. By
starting to use this name prior to haven formally been assigned it you
are basically squatting on an IETF resource. Where audio/vnd.gips.isac
is completely fine because that would be within your domain and within
your right to assign it. And by submitting that to the IANA you will
have ensured that you where the controller of the media type for certain.

In addition I see little gain in having IETF publish RTP payload formats
in RFCs that doesn't have a publicly available and stable specification.
If the codec is proprietary the vendor itself can publish the codec and
its payload format in any venue it choses and use the vendor tree for
identifying the format.

Cheers

Magnus Westerlund

IETF Transport Area Director & TSVWG Chair
----------------------------------------------------------------------
Multimedia Technologies, Ericsson Research EAB/TVM
----------------------------------------------------------------------
Ericsson AB                | Phone  +46 10 7148287
Färögatan 6                | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden| mailto: [email-masked]
----------------------------------------------------------------------
_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www.ietf.org/mailman/listinfo/avt