Subject: [AVT] Question on marker bit in RFC 3551

From: Andreas Byström (Polystar T & M) <[email-masked]>
Date: Sat, 28 Feb 2009 22:34:47 +0100

Hi all,

In RFC3551 I find the following regarding the marker bit setting for RTP packets carrying encoded speech data for codecs that have comfort noise/silence supression:

"For applications which send either no packets or occasional comfort-
   noise packets during silence, the first packet of a talkspurt, that
   is, the first packet after a silence period during which packets have
   not been transmitted contiguously, SHOULD be distinguished by setting
   the marker bit in the RTP data header to one.  The marker bit in all
   other packets is zero.
"

My question is how to define whats the first packet of a talkspurt? My first conclusion of the test above was the on a stream that uses silence suppression (like for example G729A annexB) the only packets to have marker bit set to 1 is:

-          The first packet that contains a speech frame (i.e not a comfort noise/SID packet). Usually this means the first packet of the stream

-          Packets that contains a speech frame that are sent after a period of no packets sent or some comfort noise packets.

However when I have tested different (SIP) applications I see that many of them sets marker bit to 1 in the following packets:

-          The first packet that contains a speech frame. Usually this means the first packet of the stream

-          Packets that contains a speech frame that are sent after a period of no packets sent or some comfort noise packets.

-          Comfort noise / SID packets

So... is my conclusion correct or should the marker bit be set to 1 also in the comfort noise packets?

Regards,
// Andreas

---

From: Colin Perkins <[email-masked]>
Date: Tue, 3 Mar 2009 08:51:23 +0000

On 28 Feb 2009, at 21:34, Andreas Byström (Polystar T & M) wrote:
...
> So… is my conclusion correct or should the marker bit be set to 1  
> also in the comfort noise packets?
>

My understanding matches yours, and I think your conclusion is  
correct, and the M bit should not be set on comfort noise packets.

-- 
Colin Perkins
http://csperkins.org/