Subject: [AVT] SRTP ROC question

From: Yuval Nissan <[email-masked]>
Date: Mon, 21 Sep 2009 23:15:56 +0300

I would like to get your opinion regarding the following issue:

RFC 4771 (Integrity Transform Carrying Roll-Over Counter for SRTP) defines a way how to carry the ROC inside SRTP packets in order to solve potential sync issues between the receiver and transmitter. However I couldn't find a standard way to use this RFC using SDP (isn't mentioned in RFC 4568).

Is there a way to do it? (If not I think it should be added)

Thanks,
Yuval

________________________________
This email and any files transmitted with it are confidential material. They are intended solely for the use of the designated individual or entity to whom they are addressed. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, use, distribution or copying of this communication is strictly prohibited and may be unlawful.

If you have received this email in error please immediately notify the sender and delete or destroy any copy of this message

---

From: Mats Näslund <[email-masked]>
Date: Tue, 22 Sep 2009 09:07:47 +0200

Hi Yuval,
 
RFC 4771 carries ROC _inband_, in the media stream.  The reason for this is that we found use-cases where sending
ROC out-of-band (e.g. in SDP) may cause problems. The typical example is that a receiver joins an ongoing session
and if the SDP is slighly delayed relative to the ongoing media session, the ROC may be "expired" as it is received.
 
The intended use of RFC4568 and 4771 are as follows:
 
RFC4568 takes care of the session _set-up_ parts of SRTP (using MIKEY). That is, the sender and receiver agrees on 
key material,  and parameters such as for instance the initial (or "recent") value of ROC.  But once you are up and running, 
RFC4771 carries ROC inside SRTP itself and does not require out-of-band signalling in SDP.
 
Best,
 
/Mats

	From: [email-masked] [mailto:[email-masked]] On Behalf Of Yuval Nissan
	Sent: den 21 september 2009 22:16
	To: [email-masked]
	Subject: [AVT] SRTP ROC question

	Thanks,

	Yuval