Subject: [AVT] MPEG2 preamble - are the drafts sufficiently complete to make a decision?

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Fri, 12 Mar 2010 12:43:56 +0100

(As WG cochair)

At the forthcoming face to face meeting in Anaheim, we will be trying to reach a decision on how to solve the sending of an MPEG2 preamble 

The two drafts are:

http://tools.ietf.org/id/draft-begen-avt-rtp-mpeg2ts-preamble-04.txt
http://tools.ietf.org/id/draft-xia-avt-mpeg2ts-preamble-02.txt

At the last meeting, there was an ad-hoc which reported that:

"One issue that was discussed, and remains unclear, is the exact behaviour of the Xia proposal when dealing with encrypted streams. This will need to be clarified.

Actions:

Authors of the Xia draft to update their draft for clarity of English and to reflect the discussion, especially with respect to the exact amount of data that has to be sent in the preamble, and to change to using the RFC 2250 format 
Authors of the Xia draft to clarify its behaviour when using an encrypted MPEG2-TS. 
 
Once an update to the Xia draft, and the Begen draft if the authors have any changes they wish to make, is available, we expect the working group will be able to review both proposals to make a decision whether it prefers extensibility and flexibility (the Begen draft) or a slightly lower overhead with less flexibility (the Xia draft)."

ACTION TO AVT WG MEMBERS
------------------------

Do AVT members believe the above action has been fulfilled, or additionally, is there some other issues that require clarification from the authors in order to make a decision.

If you believe a need exists for further clarification, please raise these issues well before the meeting starts, ideally in response to this message, as the clarifications will need to be made by the authors on list. 

There will not be time in the face to face meeting to seek further clarification at that point.

regards

Keith

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Fri, 12 Mar 2010 14:44:16 -0800

Hi Keith, All,

Regarding the action items on the preamble drafts: 

I believe the Xia draft did a good job in clarifying their approach. It
is now purely based on the 2250 format. In the mean time, we did one
minor revision to fix a few typos and the alignment of the fields in
TOLV elements.

I am hoping to send my comments on the drafts in a separate email soon.

-acbegen

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> DRAGE, Keith (Keith)
> Sent: Friday, March 12, 2010 6:44 AM
> To: [email-masked]
> Subject: [AVT] MPEG2 preamble - are the drafts sufficiently complete
to
> make a decision?
> 
> (As WG cochair)
> 
> At the forthcoming face to face meeting in Anaheim, we will be trying
> to reach a decision on how to solve the sending of an MPEG2 preamble
> 
> The two drafts are:
> 
> "One issue that was discussed, and remains unclear, is the exact
> behaviour of the Xia proposal when dealing with encrypted streams.
This
> will need to be clarified.
> 
> Actions:
> 
> Authors of the Xia draft to update their draft for clarity of English
> and to reflect the discussion, especially with respect to the exact
> amount of data that has to be sent in the preamble, and to change to
> using the RFC 2250 format
> Once an update to the Xia draft, and the Begen draft if the authors
> have any changes they wish to make, is available, we expect the
working
> group will be able to review both proposals to make a decision whether
> it prefers extensibility and flexibility (the Begen draft) or a
> slightly lower overhead with less flexibility (the Xia draft)."
> 
> ACTION TO AVT WG MEMBERS
> ------------------------
> 
> Do AVT members believe the above action has been fulfilled, or
> additionally, is there some other issues that require clarification
> from the authors in order to make a decision.
> 
> If you believe a need exists for further clarification, please raise
> these issues well before the meeting starts, ideally in response to
> this message, as the clarifications will need to be made by the
authors
> on list.
> _______________________________________________
> Audio/Video Transport Working Group
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avt