Subject: [AVT] MPEG2 TS preamble discussion in Thursday face to face meeting

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Thu, 25 Mar 2010 21:22:35 +0100

(as WG co-chair)

At the start of todays AVT session I intend putting up two slides:

Slide 1
-------

We have two solutions that essentially have the same capabilities and both are claimed to work - there is obviously detailed work that can be applied to both solutions
There are no other solutions on the table
There is no middle path taking the best of both solutions - one either uses A or B
The WG chairs need to know how to enable ongoing discussion

Slide 2
-------

Question to the WG
Should the WG attempt to find and document one solution to the MPEG2 TS preamble task?
OR
Should the WG accept that both solutions will exist (appropriate documentation to be determined), with the implication that either the RTP_Rx or the RS will have to support both?

We will then take a show of hands.

Some ground rules:

1)	The two questions are meant to be mutually exclusive. So we expect you to guide us to one or the other. There is not intended to be any third option other than "not interested".

2)	We have a crowded agenda today so we do not have time for any discussion of these. So please remember that the result indicates a direction to the chairs of the feeling of the working group as to where to concentrate their efforts.

3)	There are plenty of detailed clarifications on how to proceed with each of these once we have taken a direction. We will have those discussions on the list. So please wait for that discussion on list, rather than try and have it at the microphone.

4)	Even if we give one direction, we could still end up going in the other direction. For example if we direct that we want one solution, but still fail to select one, then we will still have to rediscuss the other. If we agree that both should exist, and one proves not to work, then essentially we end up back at one solution.

regards

Keith

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Fri, 26 Mar 2010 02:04:04 +0100

So the response in the face to face meeting was inconclusive on this. There was a slight majority in favour of handling both solutions (11 versus 14). 

While I suspect that the mailing list at the moment is not going to change that significantly, this is an invitation for those who have not made their views known already to email the chairs with their position.

In the absence of any clear direction at the moment, working group participants are encouraged to make suggestions on how the two solutions will be evaluated with regard to progressing the work.

This work is an informative reference from RAMS, so it does not prevent the RAMS solution from progressing. However it does mean that no IETF guidance can be given on the use of RAMS with an MPEG2 transport scheme until we resolve this.,

regards

Keith

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of DRAGE, Keith (Keith)
> Sent: Thursday, March 25, 2010 8:23 PM
> To: [email-masked]
> Subject: [AVT] MPEG2 TS preamble discussion in Thursday face 
> to face meeting
> 
> (as WG co-chair)
> 
> We have two solutions that essentially have the same 
> capabilities and both are claimed to work - there is 
> obviously detailed work that can be applied to both solutions 
> There are no other solutions on the table There is no middle 
> path taking the best of both solutions - one either uses A or 
> B The WG chairs need to know how to enable ongoing discussion
> 
> Slide 2
> -------
> 
> Question to the WG
> Should the WG accept that both solutions will exist 
> (appropriate documentation to be determined), with the 
> implication that either the RTP_Rx or the RS will have to 
> support both?
> 
> 1)	The two questions are meant to be mutually exclusive. 
> So we expect you to guide us to one or the other. There is 
> not intended to be any third option other than "not interested".
> 
> 2)	We have a crowded agenda today so we do not have time 
> for any discussion of these. So please remember that the 
> result indicates a direction to the chairs of the feeling of 
> the working group as to where to concentrate their efforts.
> 
> 3)	There are plenty of detailed clarifications on how to 
> proceed with each of these once we have taken a direction. We 
> will have those discussions on the list. So please wait for 
> that discussion on list, rather than try and have it at the 
> microphone.
> 
> 4)	Even if we give one direction, we could still end up 
> going in the other direction. For example if we direct that 
> we want one solution, but still fail to select one, then we 
> will still have to rediscuss the other. If we agree that both 
> should exist, and one proves not to work, then essentially we 
> end up back at one solution.
> 
> regards
> 
> Keith
> _______________________________________________
> Audio/Video Transport Working Group
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avt
>

---

From: Roni Even <[email-masked]>
Date: Fri, 26 Mar 2010 04:19:49 +0300

Hi Keith,

Just to be precise

"This work is an informative reference from RAMS, so it does not prevent the
RAMS solution from progressing. However it does mean that no IETF guidance
can be given on the use of RAMS with an MPEG2 transport scheme until we
resolve this.,"

Should be

"This work is an informative reference from RAMS, so it does not prevent the
RAMS solution from progressing. However it does mean that no IETF guidance
can be given on the use of RAMS with an MPEG2-TS preamble until we resolve
this."

Roni Even

AVT co-chair

> From: [email-masked] [mailto:[email-masked]] On Behalf Of

> DRAGE, Keith (Keith)

> Sent: Friday, March 26, 2010 4:04 AM

> To: DRAGE, Keith (Keith); [email-masked]

> Subject: Re: [AVT] MPEG2 TS preamble discussion in Thursday face to

> face meeting

> So the response in the face to face meeting was inconclusive on this.

> There was a slight majority in favour of handling both solutions (11

> versus 14).

> While I suspect that the mailing list at the moment is not going to

> change that significantly, this is an invitation for those who have not

> made their views known already to email the chairs with their position.

> In the absence of any clear direction at the moment, working group

> participants are encouraged to make suggestions on how the two

> solutions will be evaluated with regard to progressing the work.

> This work is an informative reference from RAMS, so it does not prevent

> the RAMS solution from progressing. However it does mean that no IETF

> guidance can be given on the use of RAMS with an MPEG2 transport scheme

> until we resolve this.,

> > Should the WG attempt to find and document one solution to

> > the MPEG2 TS preamble task?

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Fri, 26 Mar 2010 19:47:28 +0100

Correct

Thanks

Keith

________________________________
From: Roni Even [mailto:[email-masked]]
Sent: Friday, March 26, 2010 1:20 AM
To: DRAGE, Keith (Keith); [email-masked]
Subject: RE: [AVT] MPEG2 TS preamble discussion in Thursday face to face meeting

Hi Keith,

Just to be precise

"This work is an informative reference from RAMS, so it does not prevent the RAMS solution from progressing. However it does mean that no IETF guidance can be given on the use of RAMS with an MPEG2 transport scheme until we resolve this.,"

Should be

"This work is an informative reference from RAMS, so it does not prevent the RAMS solution from progressing. However it does mean that no IETF guidance can be given on the use of RAMS with an MPEG2-TS preamble until we resolve this."

Roni Even
AVT co-chair