Subject: [AVT] Advice on audio meta-data

From: Marc Petit-Huguenin <[email-masked]>
Date: Tue, 16 Mar 2010 11:21:56 -0700

Hi,

I would like an advice on what would be the best transport method for carrying
meta-data related to an audio stream.  Let's take for example a radio streaming
songs over RTP.  What is the best interoperable way of carrying the song name,
artist, etc... (the meta-data carried in the MP3 or OGG file), but also more
dynamic meta-data like the time until the end of the song.

One way I see would be to carry the song info in the RTCP packets (by defining
new SDES items) and using an RTP extension to carry the more dynamic values.
Another alternative could be to define a separate RTP format to carry the data
in a parallel session.

Opinions?  other suggestions?

Thanks.

-- 
Marc Petit-Huguenin
Personal email: [email-masked]
Professional email: [email-masked]
Blog: http://blog.marc.petit-huguenin.org

---

From: Gunnar Hellström <[email-masked]>
Date: Tue, 16 Mar 2010 19:58:51 +0100

Have a look at rfc 4396 Timed text. It might suit your needs.
/Gunnar

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Marc
Petit-Huguenin
Sent: Tuesday, March 16, 2010 7:22 PM
To: AVT WG
Subject: [AVT] Advice on audio meta-data

Hi,

I would like an advice on what would be the best transport method for
carrying
meta-data related to an audio stream.  Let's take for example a radio
streaming
songs over RTP.  What is the best interoperable way of carrying the song
name,
artist, etc... (the meta-data carried in the MP3 or OGG file), but also more
dynamic meta-data like the time until the end of the song.

One way I see would be to carry the song info in the RTCP packets (by
defining
new SDES items) and using an RTP extension to carry the more dynamic values.
Another alternative could be to define a separate RTP format to carry the
data
in a parallel session.

Thanks.

-- 
Marc Petit-Huguenin
Personal email: [email-masked]
Professional email: [email-masked]
Blog: http://blog.marc.petit-huguenin.org
_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www.ietf.org/mailman/listinfo/avt

__________ NOD32 4950 (20100316) Information __________

Detta meddelande dr genomsvkt av NOD32 Antivirus.
http://www.nod32.com

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Tue, 16 Mar 2010 12:17:52 -0700

> Have a look at rfc 4396 Timed text. It might suit your needs.

Thanks for the pointer.

It seems that this format is like RFC 4103 with the addition of some formatting
features.  I am more interested on a way of transporting structured data, where
the receiver can choose the presentation more than the sender deciding that one
presentation fits all.

---

From: David Singer <[email-masked]>
Date: Tue, 16 Mar 2010 15:29:39 -0400

The general header extension mechanism might be a way to go, in that you can set up in the SDP what the tags mean, and then spread them into the stream periodically.

>> Opinions?  other suggestions?

David Singer
Multimedia and Software Standards, Apple Inc.

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Tue, 16 Mar 2010 13:19:25 -0700

> The general header extension mechanism might be a way to go, in that you can set up in the SDP what the tags mean, and then spread them into the stream periodically.

Thanks, that seems a good choice for unicast.

For multicast a separate stream seems to be a better choice.

---

From: Colin Perkins <[email-masked]>
Date: Tue, 16 Mar 2010 20:26:19 +0000

On 16 Mar 2010, at 18:21, Marc Petit-Huguenin wrote:
> I would like an advice on what would be the best transport method  
> for carrying meta-data related to an audio stream.  Let's take for  
> example a radio streaming songs over RTP.  What is the best  
> interoperable way of carrying the song name, artist, etc... (the  
> meta-data carried in the MP3 or OGG file), but also more dynamic  
> meta-data like the time until the end of the song.
>
> One way I see would be to carry the song info in the RTCP packets  
> (by defining new SDES items) and using an RTP extension to carry the  
> more dynamic values. Another alternative could be to define a  
> separate RTP format to carry the data in a parallel session.
>

The combination of new RTCP SDES items for slowly changing values, and  
generic RTP header extensions for things that change more quickly  
would seem to make sense to me.

-- 
Colin Perkins
http://csperkins.org/

---

From: Roni Even <[email-masked]>
Date: Wed, 17 Mar 2010 18:36:16 +0200

Hi,
I believe that the requirement is to have the meta data, codec agnostic. In
this case either carrying it in combination of header extensions and RTCP
SDES like Colin mentioned or using a separate payload that can be ssrc
multiplexed with the audio stream can work. 

Is the time till the end of the song going to be sent continually or is it
sent once and calculated based on time stamps.

I suggest you start with the requirements and optional solutions in order to
select the better solution

Roni Even
As individual  

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Marc Petit-Huguenin
> Sent: Tuesday, March 16, 2010 8:22 PM
> To: AVT WG