Subject: Re: [AVT] [Fwd: I-D Action:draft-petithuguenin-avt-multiple-clock-rates-00.txt]

From: Colin Perkins <[email-masked]>
Date: Mon, 15 Mar 2010 15:00:08 +0000

[coming back to this very late...]

On 15 Oct 2009, at 16:51, Marc Petit-Huguenin wrote:
> Colin Perkins wrote:
>> It might be possible to eliminate the lip-synchronisation delay if  
>> the sender were to generate a compound RTCP packet containing two  
>> SRs, one for each SSRC, at the change-over, with each SR containing  
>> a mapping of its RTP timestamp to the same NTP time.
>
> That looks like a good solution to this problem, excepted that my  
> understanding of RFC 3550 is that the format of a compound RTCP  
> packet is this:
>
> compound = [encryption-prefix] ( SR | RR ) *RR 1*SDES *(APP | other)  
> *BYE
>
> Do you mean that in fact the format of a compound RTCP packet is  
> something like this? :
>
> compound = [encryption-prefix] ( SR | RR ) *RR 1*SDES *(APP | SR |  
> other) *BYE

My interpretation has always been even more relaxed than that: start  
with the SR/RR then SDES packets relating to the SSRC of the RTCP  
sender, then include other RTCP packets as required (including SR, RR,  
or SDES packets for other sources where necessary). I don't believe a  
BYE packet has to be the last in a compound packet, although it must  
be the last RTCP packet sent with a particular SSRC.

-- 
Colin Perkins
http://csperkins.org/

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Mon, 15 Mar 2010 09:51:26 -0700

On 03/15/2010 08:00 AM, Colin Perkins wrote:
>>> SRs, one for each SSRC, at the change-over, with each SR containing a
>>> mapping of its RTP timestamp to the same NTP time.
>>
>> understanding of RFC 3550 is that the format of a compound RTCP packet
>> is this:
>>
>> compound = [encryption-prefix] ( SR | RR ) *RR 1*SDES *(APP | other) *BYE
>>
> BYE packet has to be the last in a compound packet, although it must be
> the last RTCP packet sent with a particular SSRC.

OK, thanks.  I'll remove the note questioning the validity of multiple SRs in
the next release of the I-D.

-- 
Marc Petit-Huguenin
Personal email: [email-masked]
Professional email: [email-masked]
Blog: http://blog.marc.petit-huguenin.org