Subject: [AVT] Payload format specifications for adoption as WG items

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Wed, 7 Apr 2010 19:02:41 +0200

(As WG cochair)

We have set a number of milestones for the completion of payload formats, and for each of these we currently have one author draft. We need drafts to become WG items to progress the payload formats.

If people have issues with any of the drafts below where they would like to see something substantially different (or indeed see nothing at all), or it is currently premature to do this work, then they should answer "no" to the appropriate question. If we get any "no"s at this point, we can afford to take another round of discussion on those specific drafts, before a further call for adoption (it would be useful if you give the reason for saying no). To answer "yes" the drafts don't have to be perfect, but you believe they are heading in the right direction, and normal WG list discussion can take care of the issues.

This is therefore a formal call for the adoption of drafts as WG items against specific WG milestones.

Please respond either to the list ([email-masked]), or directly to the AVT chairs ([email-masked]) by close of business Wednesday 21st April (i.e. two weeks time).

Decision A
----------

Milestone: RTP Payload Format for the iSAC codec for Proposed Standard 

Question: Do you think the latest version of https://datatracker.ietf.org/doc/draft-legrand-rtp-isac/ provides an appropriate basis for fulfilling this charter item and should be be adopted as the working group text for this charter item.

YES [  ]		NO [  ]

Decision B
----------

Milestone: RTP Payload Format for Bluetooth's SBC audio codec for Proposed Standard 

Question: Do you think the latest version of https://datatracker.ietf.org/doc/draft-hoene-avt-rtp-sbc/ provides an appropriate basis for fulfilling this charter item and should be be adopted as the working group text for this charter item.

YES [  ]		NO [  ]

Decision C
----------

Milestone: RTP Payload Format for Enhanced Variable Rate Narrowband- Wideband Codec (EVRC-NW) for Proposed Standard 

Question: Do you think the latest version of https://datatracker.ietf.org/doc/draft-zfang-avt-rtp-evrc-nw/ provides an appropriate basis for fulfilling this charter item and should be be adopted as the working group text for this charter item.

YES [  ]		NO [  ]

Decision D
----------

Milestone: RTP profile for the carriage of SMPTE 336M data for Proposed Standard 

Question: Do you think the latest version of https://datatracker.ietf.org/doc/draft-arbeiter-rtp-klv/ provides an appropriate basis for fulfilling this charter item and should be be adopted as the working group text for this charter item.

YES [  ]		NO [  ]

Decision E
----------

Milestone: RTP Payload Format for the APTX codec for Proposed Standard

Question: Do you think the latest version of https://datatracker.ietf.org/doc/draft-trainor-avt-rtp-aptx/ provides an appropriate basis for fulfilling this charter item and should be be adopted as the working group text for this charter item.

YES [  ]		NO [  ]

Decision F
----------

Milestone: RTP Payload Format for the CELT codec for Proposed Standard

Question: Do you think the latest version of https://datatracker.ietf.org/doc/draft-valin-celt-rtp-profile/ provides an appropriate basis for fulfilling this charter item and should be be adopted as the working group text for this charter item.

YES [  ]		NO [  ]

Note: The above draft has expired but is available at the link given. Parallel author draft exists in the codec group.

Decision G
----------

Milestone: RTP Payload Format for MVC Video for Proposed Standard 

Question: Do you think the latest version of https://datatracker.ietf.org/doc/draft-wang-avt-rtp-mvc/ provides an appropriate basis for fulfilling this charter item and should be be adopted as the working group text for this charter item.

YES [  ]		NO [  ]

regards

Keith

---

From: Roni Even <[email-masked]>
Date: Thu, 08 Apr 2010 00:26:58 +0300

Hi,
Here is my feedback

A - Yes
B - Yes
C- Yes
D - no - need a new revision before accepting as WG document
E - no - it is using some aux channel not specified yet try to use the
payload parameter to signal its IP address. This is not inline with RTP
architecture
F-  no - the draft has expired, submit first an individual draft
G- was waiting for SVC, the question should go to the authors

Roni Even

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> DRAGE, Keith (Keith)
> Sent: Wednesday, April 07, 2010 8:03 PM
> To: [email-masked]
> Subject: [AVT] Payload format specifications for adoption as WG items
> 
> (As WG cochair)
> 
> We have set a number of milestones for the completion of payload
> formats, and for each of these we currently have one author draft. We
> need drafts to become WG items to progress the payload formats.
> 
> If people have issues with any of the drafts below where they would
> like to see something substantially different (or indeed see nothing at
> all), or it is currently premature to do this work, then they should
> answer "no" to the appropriate question. If we get any "no"s at this
> point, we can afford to take another round of discussion on those
> specific drafts, before a further call for adoption (it would be useful
> if you give the reason for saying no). To answer "yes" the drafts don't
> have to be perfect, but you believe they are heading in the right
> direction, and normal WG list discussion can take care of the issues.
> 
> Please respond either to the list ([email-masked]), or directly to the
> AVT chairs ([email-masked]) by close of business Wednesday
> 21st April (i.e. two weeks time).
> 
> 
> Decision A
> ----------
> 
> Question: Do you think the latest version of
> https://datatracker.ietf.org/doc/draft-legrand-rtp-isac/ provides an
> appropriate basis for fulfilling this charter item and should be be
> adopted as the working group text for this charter item.
> 
> YES [  ]		NO [  ]
> 
> 
> Decision B
> ----------
> 
> Question: Do you think the latest version of
> https://datatracker.ietf.org/doc/draft-hoene-avt-rtp-sbc/ provides an
> appropriate basis for fulfilling this charter item and should be be
> adopted as the working group text for this charter item.
> 
> YES [  ]		NO [  ]
> 
> 
> Decision C
> ----------
> 
> Milestone: RTP Payload Format for Enhanced Variable Rate Narrowband-
> Wideband Codec (EVRC-NW) for Proposed Standard
> 
> Question: Do you think the latest version of
> https://datatracker.ietf.org/doc/draft-zfang-avt-rtp-evrc-nw/ provides
> an appropriate basis for fulfilling this charter item and should be be
> adopted as the working group text for this charter item.
> 
> YES [  ]		NO [  ]
> 
> 
> Decision D
> ----------
> 
> Question: Do you think the latest version of
> https://datatracker.ietf.org/doc/draft-arbeiter-rtp-klv/ provides an
> appropriate basis for fulfilling this charter item and should be be
> adopted as the working group text for this charter item.
> 
> YES [  ]		NO [  ]
> 
> 
> Decision E
> ----------
> 
> Question: Do you think the latest version of
> https://datatracker.ietf.org/doc/draft-trainor-avt-rtp-aptx/ provides
> an appropriate basis for fulfilling this charter item and should be be
> adopted as the working group text for this charter item.
> 
> YES [  ]		NO [  ]
> 
> 
> Decision F
> ----------
> 
> Question: Do you think the latest version of
> https://datatracker.ietf.org/doc/draft-valin-celt-rtp-profile/ provides
> an appropriate basis for fulfilling this charter item and should be be
> adopted as the working group text for this charter item.
> 
> YES [  ]		NO [  ]
> 
> Note: The above draft has expired but is available at the link given.
> Parallel author draft exists in the codec group.
> 
> 
> Decision G
> ----------
> 
> Question: Do you think the latest version of
> https://datatracker.ietf.org/doc/draft-wang-avt-rtp-mvc/ provides an
> appropriate basis for fulfilling this charter item and should be be
> adopted as the working group text for this charter item.
> 
> YES [  ]		NO [  ]
> 
> 
> 
> regards
> 
> Keith
> _______________________________________________
> Audio/Video Transport Working Group
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avt

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Thu, 8 Apr 2010 03:35:31 +0200

(As WG cochair)

Regarding D (https://datatracker.ietf.org/doc/draft-arbeiter-rtp-klv/ ), I did not see anything in your comments earlier today that indicated that the document was going in completely the wrong direction, all these things looked like things that would sort themselves out as a result of normal WG discussion, and therefore not an issue for adopting as WG draft - that is of course a matter of judgement. However I would encourage the authors to submit a revised version of the author draft, and we'll give a few extra days for the adoption call for that document taking into the revision (unless there are other more major issues identified).

Regarding F, the document in its expired form is available at the link specified https://datatracker.ietf.org/doc/draft-valin-celt-rtp-profile/ even though it has expired, so I do expect AVT members to have access to the contents, and to be able to respond to the call.

Regarding G, https://datatracker.ietf.org/doc/draft-wang-avt-rtp-mvc/ I notice the authors have clarified offline that they are intending that SVC and MVC will proceed independently. Does the AVT WG regard that as an issue?

(I should have added in the first message that comments on the documents are also welcome to the list as you review them, but please may clear whether you expect them to be addressed as the document goes forward in the WG, or whether you think it is blocking on adoption).

regards

Keith

> From: Roni Even [mailto:[email-masked]] 
> Sent: Wednesday, April 07, 2010 10:27 PM
> To: DRAGE, Keith (Keith); [email-masked]
> Subject: RE: [AVT] Payload format specifications for adoption 
> as WG items
> 
> Hi,
> Here is my feedback
> 
> A - Yes
> B - Yes
> C- Yes
> E - no - it is using some aux channel not specified yet try 
> to use the payload parameter to signal its IP address. This 
> is not inline with RTP architecture
> > like to see something substantially different (or indeed 
> see nothing 
> > at all), or it is currently premature to do this work, then they 
> > should answer "no" to the appropriate question. If we get 
> any "no"s at 
> > this point, we can afford to take another round of 
> discussion on those 
> > specific drafts, before a further call for adoption (it would be 
> > useful if you give the reason for saying no). To answer "yes" the 
> > drafts don't have to be perfect, but you believe they are 
> heading in 
> > the right direction, and normal WG list discussion can take 
> care of the issues.
> > 
> > This is therefore a formal call for the adoption of drafts 
> as WG items 
> > against specific WG milestones.
> > 
> > https://datatracker.ietf.org/doc/draft-valin-celt-rtp-profile/ 
> > provides an appropriate basis for fulfilling this charter item and 
> > should be be adopted as the working group text for this 
> charter item.
> > 
> > YES [  ]		NO [  ]
> >

---

From: Ye-Kui Wang <[email-masked]>
Date: Thu, 08 Apr 2010 10:28:03 -0400

Thanks both Keith and Roni for the constructive initiative and comments. 

Regarding G, https://datatracker.ietf.org/doc/draft-wang-avt-rtp-mvc/, I
think it makes sense to adopt it as a WG item (as I don't see the progress
of the SVC draft being an issue for the MVC draft), and then we authors
update the draft and send the next revision as the first WG version.

For other items, as long as there are no major issues, and identified issues
can be resolved through normal WG discussions, I'd prefer them to be adopted
as WG items. 

BR, YK 

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of DRAGE, Keith (Keith)
> Sent: Wednesday, April 07, 2010 9:36 PM
> To: Roni Even; [email-masked]
> Subject: Re: [AVT] Payload format specifications for adoption 
> as WG items
> 
> (As WG cochair)
> 
> Regarding D 
> (https://datatracker.ietf.org/doc/draft-arbeiter-rtp-klv/ ), 
> I did not see anything in your comments earlier today that 
> indicated that the document was going in completely the wrong 
> direction, all these things looked like things that would 
> sort themselves out as a result of normal WG discussion, and 
> therefore not an issue for adopting as WG draft - that is of 
> course a matter of judgement. However I would encourage the 
> authors to submit a revised version of the author draft, and 
> we'll give a few extra days for the adoption call for that 
> document taking into the revision (unless there are other 
> more major issues identified).
> 
> Regarding F, the document in its expired form is available at 
> the link specified 
>  even though it has expired, so I do expect AVT members to 
> have access to the contents, and to be able to respond to the call.
> 
> Regarding G, 
> https://datatracker.ietf.org/doc/draft-wang-avt-rtp-mvc/ I 
> notice the authors have clarified offline that they are 
> intending that SVC and MVC will proceed independently. Does 
> the AVT WG regard that as an issue?
> 
> (I should have added in the first message that comments on 
> the documents are also welcome to the list as you review 
> them, but please may clear whether you expect them to be 
> addressed as the document goes forward in the WG, or whether 
> you think it is blocking on adoption).
> 
> regards
> 
> Keith
> 
> > Subject: RE: [AVT] Payload format specifications for adoption as WG 
> > items
> > 
> > Hi,
> > Here is my feedback
> > 
> > A - Yes
> > B - Yes
> > C- Yes
> > D - no - need a new revision before accepting as WG 
> document E - no - 
> > it is using some aux channel not specified yet try to use 
> the payload 
> > parameter to signal its IP address. This is not inline with RTP 
> > architecture

---

From: Roni Even <[email-masked]>
Date: Wed, 28 Apr 2010 10:17:34 +0300

Hi,
There were no objections to accept these payload specifications as WG items
except for APTX where the authors do not want to progress this payload.
I will send separate emails for each document to ask the authors to submit
them as WG documents
Thanks
Roni Even
AVT co-chair