Subject: [AVT] Question on private extensions (particularly response code 0) in draft-ietf-avt-rapid-acquisition-for-rtp-11

From: Robert Sparks <[email-masked]>
Date: Wed, 18 Aug 2010 15:03:20 -0500

What is an element that receives a RAM-I with a response of 0 and a bunch of TLVs it doesn't understand (possibly _all_ of them)
supposed to do?

I suspect we need more discussion on when using this response code of 0 is appropriate with an emphasis on interoperability.

RjS

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Wed, 18 Aug 2010 13:08:21 -0700

Private extensions are for private use only. If one does not understand the tlvs, it just ignores them. That is the intention. If interop is desired, they need to be registered. 

-acbegen

----- Original Message -----
From: [email-masked] <[email-masked]>
To: [email-masked] <[email-masked]>
Sent: Wed Aug 18 13:03:20 2010
Subject: [AVT] Question on private extensions (particularly response code 0)in draft-ietf-avt-rapid-acquisition-for-rtp-11

RjS

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www.ietf.org/mailman/listinfo/avt

---

From: Robert Sparks <[email-masked]>
Date: Wed, 18 Aug 2010 15:14:30 -0500

So you're saying that if I receive a RAMS-I  with a response of 0 and I don't implement whatever private things are in its payload, then what I do is exactly what
I would have done if I received no RAMS-I at all?

RjS

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Wed, 18 Aug 2010 13:22:38 -0700

There will certainly be public tlvs for you in the message. There are required elements in each rams-i. (if the response is zero, that means the response is a private extension not every element in that rams-i message). Each Rams client is supposed to work without any private extension. That's why we defined the essential ones in the draft.  

-acbegen

----- Original Message -----
From: Robert Sparks <[email-masked]>
To: Ali C. Begen (abegen)
Cc: [email-masked] <[email-masked]>
Sent: Wed Aug 18 13:14:30 2010
Subject: Re: [AVT] Question on private extensions (particularly response code 0)in draft-ietf-avt-rapid-acquisition-for-rtp-11

RjS

---

From: Roni Even <[email-masked]>
Date: Thu, 19 Aug 2010 00:23:09 +0300

Hi Ali,
This is a good question. Does it mean that there will be one RAMS-I with
response code 200 and there may be some more with response code 0 or 100.
Roni

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Ali C. Begen (abegen)
> Sent: Wednesday, August 18, 2010 11:23 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [AVT] Question on private extensions (particularly
> response code 0)in draft-ietf-avt-rapid-acquisition-for-rtp-11
> 
> There will certainly be public tlvs for you in the message. There are
> required elements in each rams-i. (if the response is zero, that means
> the response is a private extension not every element in that rams-i
> message). Each Rams client is supposed to work without any private
> extension. That's why we defined the essential ones in the draft.
> 
> 
> 
> -acbegen
> 
> Subject: Re: [AVT] Question on private extensions (particularly
> response code 0)in draft-ietf-avt-rapid-acquisition-for-rtp-11
> 
> So you're saying that if I receive a RAMS-I  with a response of 0 and I
> don't implement whatever private things are in its payload, then what I
> do is exactly what
> > Private extensions are for private use only. If one does not
> understand the tlvs, it just ignores them. That is the intention. If
> interop is desired, they need to be registered.
> >
> > -acbegen
> >
> > Subject: [AVT] Question on private extensions (particularly response
> code 0)in draft-ietf-avt-rapid-acquisition-for-rtp-11
> >
> > What is an element that receives a RAM-I with a response of 0 and a
> bunch of TLVs it doesn't understand (possibly _all_ of them)
> > supposed to do?
> >
> > I suspect we need more discussion on when using this response code of
> 0 is appropriate with an emphasis on interoperability.
> >
> > RjS
> >

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Wed, 18 Aug 2010 16:26:16 -0700

> response code 200 and there may be some more with response code 0 or 100.

Well, there could be multiple RAMS-I (sending one is a requirement, more is optional). Potentially, they can carry different response codes reflecting the latest from the server side.

In the case of a single RAMS-I is sent and it has a private response code the client does not understand, the client by default needs to process the TLVs it understands. That is the best it can do. However, note that normally a server is not supposed to send private responses to the clients who would not understand it. We have support for private responses but it is not there to abuse the clients.

HTH,
-acbegen

---

From: "Van Caenegem, Tom (Tom)" <[email-masked]>
Date: Thu, 19 Aug 2010 11:40:36 +0200

Hi,

I do agree with the view of Ali :

"In the case of a single RAMS-I is sent and it has a private response code the client does not understand, the client by default needs to process the TLVs it understands"

But I think it would be better to add such statement explicitly in the RAMS draft, section 7.3.

Tom

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ali C. Begen (abegen)
Sent: donderdag 19 augustus 2010 1:26
To: Roni Even; [email-masked]
Cc: [email-masked]
Subject: Re: [AVT] Question on private extensions (particularly response code 0)in draft-ietf-avt-rapid-acquisition-for-rtp-11

> Hi Ali,
> This is a good question. Does it mean that there will be one RAMS-I 
> with response code 200 and there may be some more with response code 0 or 100.
> Roni

HTH,
-acbegen

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Thu, 19 Aug 2010 02:44:47 -0700

Ok let's add it when we are updating the response codes. 

-acbegen

----- Original Message -----
From: Van Caenegem, Tom (Tom) <[email-masked]>
To: Ali C. Begen (abegen); Roni Even <[email-masked]>; [email-masked] <[email-masked]>
Cc: [email-masked] <[email-masked]>
Sent: Thu Aug 19 02:40:36 2010
Subject: RE: [AVT] Question on private extensions (particularly	responsecode 0)in draft-ietf-avt-rapid-acquisition-for-rtp-11

Hi,

Tom

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ali C. Begen (abegen)
Sent: donderdag 19 augustus 2010 1:26
To: Roni Even; [email-masked]
Cc: [email-masked]
Subject: Re: [AVT] Question on private extensions (particularly response code 0)in draft-ietf-avt-rapid-acquisition-for-rtp-11

HTH,
-acbegen

---

From: Roni Even <[email-masked]>
Date: Thu, 19 Aug 2010 13:30:05 +0300

Ali,
Just to see if I understand correctly,
The first RAMS-I positive (not reject) response will have either 200 or 0
response code?
Roni

> From: Ali C. Begen (abegen) [mailto:[email-masked]]
> Sent: Thursday, August 19, 2010 12:45 PM
> To: [email-masked]; [email-masked];
> [email-masked]
> Cc: [email-masked]
> responsecode 0)in draft-ietf-avt-rapid-acquisition-for-rtp-11
> 
> To: Ali C. Begen (abegen); Roni Even <[email-masked]>;
> [email-masked] <[email-masked]>
> Subject: RE: [AVT] Question on private extensions (particularly
> 	responsecode 0)in draft-ietf-avt-rapid-acquisition-for-rtp-11
> 
> 
> Hi,
> 
> "In the case of a single RAMS-I is sent and it has a private response
> code the client does not understand, the client by default needs to
> process the TLVs it understands"
> 
> Well, there could be multiple RAMS-I (sending one is a requirement,
> more is optional). Potentially, they can carry different response codes
> reflecting the latest from the server side.
> 
> In the case of a single RAMS-I is sent and it has a private response
> code the client does not understand, the client by default needs to
> process the TLVs it understands. That is the best it can do. However,
> note that normally a server is not supposed to send private responses
> to the clients who would not understand it. We have support for private
> responses but it is not there to abuse the clients.
> 
> HTH,
> -acbegen

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Thu, 19 Aug 2010 04:32:11 -0700

We cannot say that the first message has to be 200 level. But if it is not an error message, I expect it to be 200 level or 0. 

-acbegen

----- Original Message -----
From: Roni Even <[email-masked]>
To: Ali C. Begen (abegen); [email-masked] <[email-masked]>; [email-masked] <[email-masked]>
Cc: [email-masked] <[email-masked]>
Sent: Thu Aug 19 03:30:05 2010
Subject: RE: [AVT] Question on private extensions (particularly	responsecode 0)in draft-ietf-avt-rapid-acquisition-for-rtp-11

Ali,