Subject: [AVT] Question on the error-codes in draft-ietf-avt-rapid-acquisition-for-rtp-11

From: Robert Sparks <[email-masked]>
Date: Wed, 18 Aug 2010 14:52:18 -0500

Section 11.6 of the draft defines 20-ish error codes, but I can't find anything (other than each
brief line in the table that registers them) that describes when they should be sent and what a
receiver should do when it gets them.

I don't think this meets the requirement this draft is putting on registration of new requests codes
for a detailed description of what the code describes and how it shall be interpreted.

For instance, is there somewhere in the text that indicates when 511 should be sent?

What would a recipient do differently with a 501 and a 503?

Have I missed somewhere that this is described? If not, I think we need more text describing each of these codes.

RjS

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Wed, 18 Aug 2010 17:11:31 -0700

I will provide a draft text to the list. And if we agree on them, we can revise the draft quickly.

As a general remark, many of the codes are fairly straightforward. So explanations will not be more than a few lines. But, I do agree we should have provided such information in the draft. 

-acbegen

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Robert Sparks
> Sent: Wednesday, August 18, 2010 9:52 PM
> To: [email-masked]
> Subject: [AVT] Question on the error-codes indraft-ietf-avt-rapid-acquisition-for-rtp-11
> 
> _______________________________________________
> Audio/Video Transport Working Group
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avt