Subject: Re: [AVT] draft-ietf-avt-app-rtp-keepalive

From: Cullen Jennings <[email-masked]>
Date: Fri, 17 Sep 2010 14:07:31 -0600

With regrades to the a few of the discuss on the 08 version of this draft

For the TCP timeout, I recommend 7200 seconds. This matches the TCP keep alive used by default by many OS and will work well with the case I am aware of. 

For the DCCP timeout, I would suggest we have pretty much zero experience with firewalls and NATs with DCCP support so it would be premature to recommend anything here and we should make no recommendation for DCCP. 

For the topic or RTCP being out of scope. I would point out RTCP has existing ways of regularly sending packets covered by the RTCP spec and this specification makes no changes to theses.  I'm not disagreeing with Magnus, just saying that the RTCP is not a problem, it's the RTP we have problems with. 

I note that the WG had recommendation for what to do when the RTCP could not be used but the IESG has removed theses. This seems critical given the fact that a larger percentage of the deployed equipment does support RTCP. I think the specification needs to add back in what to do when there is not RTCP support or it needs to be brought back to the WG for discussion.

---

From: Xavier Marjou <[email-masked]>
Date: Fri, 24 Sep 2010 14:49:39 +0200

I have just posted an updated version of the draft with a TCP timeout of
7200 seconds and no indication about DCCP timeout.
This is inline with you first two comment below, as well as with the
feedback from the BEHAVE WG.

For RTCP, the original idea was indeed to make recommendations when RTCP is
not used. This raised a lot of concerns during the IESG review. The
discussion during the newt IETF (IETF-77) resulted in recommending only
RFC5761 and "only" recommending other mechanisms. This was reflected in
version -08 and was not changed in today's -09 version.

Cheers,
Xavier

On Fri, Sep 17, 2010 at 10:07 PM, Cullen Jennings <[email-masked]> wrote:

> For the TCP timeout, I recommend 7200 seconds. This matches the TCP keep
> alive used by default by many OS and will work well with the case I am aware
> of.
>
> For the DCCP timeout, I would suggest we have pretty much zero experience
> with firewalls and NATs with DCCP support so it would be premature to
> recommend anything here and we should make no recommendation for DCCP.
>
> For the topic or RTCP being out of scope. I would point out RTCP has
> existing ways of regularly sending packets covered by the RTCP spec and this
> specification makes no changes to theses.  I'm not disagreeing with Magnus,
> just saying that the RTCP is not a problem, it's the RTP we have problems
> with.
>
> I note that the WG had recommendation for what to do when the RTCP could
> not be used but the IESG has removed theses. This seems critical given the
> fact that a larger percentage of the deployed equipment does support RTCP. I
> think the specification needs to add back in what to do when there is not
> RTCP support or it needs to be brought back to the WG for discussion.
>
>
> _______________________________________________
> Audio/Video Transport Working Group
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avt
>

---

From: Xavier Marjou <[email-masked]>
Date: Fri, 24 Sep 2010 14:50:36 +0200

So I meant:
"The discussion during the next IETF (IETF-77) resulted in recommending only
RFC5761 and "only" documenting other mechanisms."

On Fri, Sep 24, 2010 at 2:49 PM, Xavier Marjou <
[email-masked]> wrote:

> On Fri, Sep 17, 2010 at 10:07 PM, Cullen Jennings <[email-masked]>wrote:
>
>>

---

From: Cullen Jennings <[email-masked]>
Date: Fri, 24 Sep 2010 07:16:31 -0600

Can you point me to the minutes from the IETF 77 discussion where this consensus was reached ?

On Sep 24, 2010, at 6:50 AM, Xavier Marjou wrote:

> So I meant:
> "The discussion during the next IETF (IETF-77) resulted in recommending only RFC5761 and "only" documenting other mechanisms." 
> 
> On Fri, Sep 24, 2010 at 2:49 PM, Xavier Marjou <[email-masked]> wrote:
> I have just posted an updated version of the draft with a TCP timeout of 7200 seconds and no indication about DCCP timeout.
> This is inline with you first two comment below, as well as with the feedback from the BEHAVE WG.
> 
> For RTCP, the original idea was indeed to make recommendations when RTCP is not used. This raised a lot of concerns during the IESG review. The discussion during the newt IETF (IETF-77) resulted in recommending only RFC5761 and "only" recommending other mechanisms. This was reflected in version -08 and was not changed in today's -09 version.
> 
> Cheers,
> Xavier
> 
> 
> 

Cullen Jennings
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/index.html

---

From: Xavier Marjou <[email-masked]>
Date: Fri, 24 Sep 2010 16:58:09 +0200

Extracted from http://tools.ietf.org/wg/avt/minutes?item=minutes77.html ,
here is the text I was referring to:

<http://tools.ietf.org/wg/avt/minutes?item=minutes77.html>

          Comment 2
          ---------
          The proposed resolution is to remove the recommendation for a
          fallback solution. Robert Sparks accepted this proposal.

          ...

          Keith Drage summed up: the proposal to remove the recommendation
          while retaining documentation of the alternative and associated
          drawbacks is accepted. The author should send a text proposal to the
          list and we would go on from there.

On Fri, Sep 24, 2010 at 3:16 PM, Cullen Jennings <[email-masked]> wrote:

> > "The discussion during the next IETF (IETF-77) resulted in recommending
> only RFC5761 and "only" documenting other mechanisms."
> >
> > For RTCP, the original idea was indeed to make recommendations when RTCP
> is not used. This raised a lot of concerns during the IESG review. The

---

From: Cullen Jennings <[email-masked]>
Date: Fri, 24 Sep 2010 10:43:30 -0600

Thanks. Sorry I missed that when I reviewed the minutes. When I read the minutes, I did not realize it meant the draft would be useless for places where RTCP mux does not work. 

On Sep 24, 2010, at 8:58 AM, Xavier Marjou wrote:

> Extracted from http://tools.ietf.org/wg/avt/minutes?item=minutes77.html , here is the text I was referring to:
> 
> 
>           Comment 2
>           ---------

Cullen Jennings