Subject: [AVT] Standardization work in draft-xia-avt-splicing-for-rtp-00

From: Cullen Jennings <[email-masked]>
Date: Sat, 6 Nov 2010 18:14:25 -0600

This is an interesting read but I'm missing what standardization work this needs. This seems like something where a vendor can easily do this and interoperate with existing systems. It might also be worth considering system that slowly rob frame out of the main video content session to make extra space to insert more adds. the more advanced systems support that and it does complicate things.

---

From: Jinwei Xia <[email-masked]>
Date: Mon, 08 Nov 2010 14:20:29 +0800

Hi Cullen,

Thank your comments.

I partly agree with you, this is the the reason that we try to bring up a informational draft rather than a standards track draft. According to 78th meeting minutes, we clarify the splicing issues on RTP layer and list the requirements of RTP splicing, then analyse whether one of several standard intermediate nodes can satisfy these requirements. If the answer is yes, this draft will be a informational document which explicitly directs vendors how to use the standard intermediate node to perfome splicing on RTP/RTCP layer. For examle, what's the value of packet loss fields in receiver reports should be set when inserted packets loss? The intermediate node also needs to distinguish that the lost packets are from priamry content or insertion content. 

Hope this can address your concern. Thank you!

Jinwei

----- Original Message ----- 
From: "Cullen Jennings" <[email-masked]>
To: "IETF AVT WG" <[email-masked]>
Sent: Sunday, November 07, 2010 8:14 AM
Subject: [AVT] Standardization work in draft-xia-avt-splicing-for-rtp-00

> _______________________________________________
> Audio/Video Transport Working Group
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avt

---

From: Colin Perkins <[email-masked]>
Date: Mon, 8 Nov 2010 15:25:11 +0800

> This is an interesting read but I'm missing what standardization work this needs. This seems like something where a vendor can easily do this and interoperate with existing systems. It might also b…

It might be useful to have an informational draft that explains how to use the existing mechanisms, to ensure consistent implementation?

-- 
Colin Perkins
http://csperkins.org/