Subject: [AVT] Do we want to kill the IANA "RTP Payload Format media types" registry?

From: Jonathan Lennox <[email-masked]>
Date: Wed, 10 Nov 2010 03:16:54 -0500

While reviewing another IETF spec, I ran across the IANA registry "RTP Payload Format media types": <http://www.iana.org/assignments/rtp-parameters>, second table.

This registry is badly incomplete -- a lot of significant recent codecs aren't listed in it (notably H.264).  RTP payload format specifications normally just register themselves in the "media types" registry <http://www.iana.org/assignments/media-types/index.html> instead.

Is there any desire to have a registry of RTP payload format media types, separate from the general list of (MIME) media types, and thus to do the work to clean up that registry and let IANA know everything that should be included in it?  Or should we just tell IANA to kill the redundant extra registry?

The table cites RFC 4855 as creating the table, but it's not clear to me reading that document that it actually intended to create a separate registry, as opposed to just defining how RTP payload formats should use the media types registry.

The RTP parameters registry page also has a table called "RTP Profile Names" which is also incomplete, and is a subset of the list of SDP proto fields in <http://www.iana.org/assignments/sdp-parameters> -- it's missing RTP/SAVPF, as well as all the TCP, DCCP, and DTLS-based profiles.  The same question applies: do we want to fix this registry, or kill it?  This registry is clearly defined by RFC 3550, though with the somewhat vaguer language IANA considerations had back then.

--
Jonathan Lennox
[email-masked]

---

From: Magnus Westerlund <[email-masked]>
Date: Wed, 10 Nov 2010 18:46:13 +0800

> Is there any desire to have a registry of RTP payload format media types, separate from the general list of (MIME) media types, and thus to do the work to clean up that registry and let IANA know e…

I would suggest to kill of the registry. It is a difficult to ensure
consistency and the media type registry is clearly the main registry.

> The table cites RFC 4855 as creating the table, but it's not clear to me reading that document that it actually intended to create a separate registry, as opposed to just defining how RTP payload f…

Which is interesting as there are no content of the IANA Considerations
in that RFC.

> The RTP parameters registry page also has a table called "RTP Profile Names" which is also incomplete, and is a subset of the list of SDP proto fields in <http://www.iana.org/assignments/sdp-parame…

It is a bit strange to have them marked as RTP/AVP etc. I think this
should simply list, AVP, AVPF, SAVP, SAVPF.

I think this one can be done, and do make some sense as it list the
actual profiles. I think we should fix this one.

Cheers

Magnus Westerlund

----------------------------------------------------------------------
Multimedia Technologies, Ericsson Research EAB/TVM
----------------------------------------------------------------------
Ericsson AB                | Phone  +46 10 7148287
Färögatan 6                | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden| mailto: [email-masked]
----------------------------------------------------------------------