Subject: [AVT] selection of a level in regards to the use of level-asymmetry-allowed in draft-ietf-avt-rtp-rfc3984bis-12

From: Guylain Lavoie <[email-masked]>
Date: Tue, 2 Nov 2010 15:35:00 -0400

Hi everyone,

While reviewing the specification, I stumbled upon what seems to be an ambiguity in the specification.
Please consider the following text and example:

      Otherwise ("level-asymmetry-allowed" equals to 1 in both the
      offer and the answer), level asymmetry is allowed.  In this case,
      the level to use in the offerer-to-answerer direction MUST be
      equal to the highest level the answerer supports for receiving,
      and the level to use in the answerer-to-offerer direction MUST
      be equal to the highest level the offerer supports for receiving.

...

   In the following example, the offer is accepted with level

   upgrading, and neither "sprop-parameter-sets" nor "sprop-level-

   parameter-sets" is present in the offer or the answer, meaning that

   there is no out-of-band transmission of parameter sets, which then

   have to be transported in-band.  The level to use in the offerer-

   to-answerer direction is Level 3.0, and the level to use in the

   answerer-to-offerer direction is Level 2.0.  The answerer is

   allowed to send at any level up to and including level 2.0, and the

   offerer is allowed to send at any level up to and including level

   3.0.

      Offer SDP:

      m=video 49170 RTP/AVP 98

      a=rtpmap:98 H264/90000

      a=fmtp:98 profile-level-id=42A014; //Baseline profile, Level 2.0

        packetization-mode=1; level-asymmetry-allowed=1

      Answer SDP:

      m=video 49170 RTP/AVP 98

      a=rtpmap:98 H264/90000

      a=fmtp:98 profile-level-id=42A01E; //Baseline profile, Level 3.0

        packetization-mode=1; level-asymmetry-allowed=1

The ambiguity is related to the fact that the above text says that the offerer must send its stream with a level equal to the highest level that the answerer support for receiving and answerer must send its stream with a level equal to the highest level that the offerer support for receiving, while the description of the example explicitly says the opposite. Which one is right?

      Otherwise ("level-asymmetry-allowed" equals to 1 in both the
      offer and the answer), level asymmetry is allowed.  In this case,
      the level to use in the offerer-to-answerer direction MUST be
      equal or less than the highest level the answerer supports for receiving,
      and the level to use in the answerer-to-offerer direction MUST
      be equal or less than the highest level the offerer supports for receiving.

Best Regards,
Guylain

Guylain Lavoie, B.Sc.
Technical Product Manager I Gestionnaire technique de produits
Media5 Corporation - Mediatrix, M5T, Media5Boss
T: + 1 819 829 8749 ext: 5662
www.media5corp.com<http://www.media5corp.com/>  I [email-masked]<mailto:[email-masked]>

Talk to the Boss!
Branch Office Secure Survivable Solutions
PAvant d'imprimer ce document, pensez à l'environnement! / Take care of our planet before printing this document
This e-mail may contain confidential information which may be protected by legal privilege. If you are not the intended recipient, please immediately notify us by reply e-mail or by telephone, delete this e-mail and destroy any copies.
Ce courriel pourrait contenir des informations confidentielles qui font l'objet d'un privilège juridique. Si vous n'êtres pas le destinataire visé du présent message, SVP avisez-nous immédiatement par courriel ou par téléphone, supprimez ce courriel et détruisez toutes les copies.

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Sun, 7 Nov 2010 18:52:13 -0800

You are not required to send at the highest level; rather, you are required to NOT send above the highest level. Sending at the highest level or at a lower level is OK.

Cheers,
Charles

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Guylain Lavoie
> Sent: Wednesday, November 03, 2010 3:35 AM
> To: [email-masked]
> Subject: [AVT] selection of a level in regards to the use of level-asymmetry-allowed in draft-ietf-
> avt-rtp-rfc3984bis-12
> 
> Hi everyone,
> 
> 
> 
> The ambiguity is related to the fact that the above text says that the offerer must send its stream
> with a level equal to the highest level that the answerer support for receiving and answerer must send
> its stream with a level equal to the highest level that the offerer support for receiving, while the
> description of the example explicitly says the opposite. Which one is right?
> 
> 
> 
> www.media5corp.com <http://www.media5corp.com/>   I [email-masked]
> <mailto:[email-masked]>
> 
> 
> 
> Talk to the Boss!
> 
> This e-mail may contain confidential information which may be protected by legal privilege. If you are
> not the intended recipient, please immediately notify us by reply e-mail or by telephone, delete this
> e-mail and destroy any copies.
> 
> Ce courriel pourrait contenir des informations confidentielles qui font l'objet d'un privilège
> juridique. Si vous n'êtres pas le destinataire visé du présent message, SVP avisez-nous immédiatement
> par courriel ou par téléphone, supprimez ce courriel et détruisez toutes les copies.
> 
>

---

From: Guylain Lavoie <[email-masked]>
Date: Mon, 8 Nov 2010 11:19:43 -0500

Thanks Charles,

Sending at a lower level implies that the sprop-level-parameter-sets that was sent contains an entry for that level and if not, that the sprop-parameter-set must be sent in-band.
Am I right?

Thanks,
Guylain

-----Original Message-----
From: Charles Eckel (eckelcu) [mailto:[email-masked]] 
Sent: 7 novembre 2010 21:52
To: Guylain Lavoie; [email-masked]
Subject: RE: [AVT] selection of a level in regards to the use of level-asymmetry-allowed in draft-ietf-avt-rtp-rfc3984bis-12

Cheers,
Charles

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Mon, 8 Nov 2010 22:09:55 -0800

I believe that is true. Furthermore, in my experience, the actual sprop-level-parameter-sets are always sent in-band.

Cheers,
Charles

> From: Guylain Lavoie [mailto:[email-masked]]
> Sent: Tuesday, November 09, 2010 12:20 AM
> To: Charles Eckel (eckelcu); [email-masked]
> Sending at a lower level implies that the sprop-level-parameter-sets that was sent contains an entry
> for that level and if not, that the sprop-parameter-set must be sent in-band.
> Am I right?
> 
> Thanks,
> Guylain
> 
> You are not required to send at the highest level; rather, you are required to NOT send above the
> highest level. Sending at the highest level or at a lower level is OK.
> 
> Cheers,
> Charles
>