Subject: Re: [AVT] RFC4733/2833 related: Should volume field value be used in regenerating DTMF tone?

From: "HE Bing" <[email-masked]>
Date: Tue, 2 Nov 2010 13:59:39 +0800

Hello *,
Could anybody share your opinion within the community?
Thanks a lot in advance!
BR/HB
> _____________________________________________ 
> From: 	HE Bing  
> Sent:	Friday, October 22, 2010 9:00 AM
> To:	[email-masked]'; [email-masked]';
> [email-masked]'; [email-masked]'
> Cc:	XU Hui N; Felizardo Jose
> Subject:	RFC4733/2833 related: Should volume field value be used
> in regenerating DTMF tone?
> 
> Hello Mr Schulzrinne, et. all
> 
> We got a different understanding from our DSP vendor regrading the
> DTMF relay based on NTE packet defined in RFC 2833 and later 4733,
> thus we need your help for clarification.
> 
> Our DSP vendor uses a hardcoded power level instead of the valid value
> carried by the volume field in NTE packet and declare this does not
> violate RFC 2833 and RFC 4733 due to no explicit statement telling
> that value SHALL or SHOULD be used.
> 
> We can say nothing bu we do think the volume field value SHALL be used
> in generating DTMF tone as long as it is valid. Each DSP vendor may
> have different implementation, but if support of RFC 2833 or 4733 is
> declared, use of volume field has to be supported at least as an
> option.
> We already run into problem in a customer project where the terminal
> expect DTMF signal with power level higher than the hardcoded value.
> 
> Could you share with your opinion? If the volume field is not used in
> reconstructing the relayed DTMF and other tone, then any other
> motivation to design such a field within NTE packet?
> 
> Thanks a lot for your clarification!
> Best regard.
> He Bing

---

From: Tom Taylor <[email-masked]>
Date: Tue, 2 Nov 2010 16:55:29 -0400

Please note my change of address, and also that Scott Petrack is 
probably unreachable.

Would your vendor argue that support of the Event field is also optional 
because there is no MUST associated with it?

As far as I am concerned, a vendor does not fully support an RFC unless 
they support all elements of the protocol except possibly those 
indicated as optional (either through explicit use of the word 
"optional" or the word "MAY).  "SHOULD" requirements can be argued, but 
one would expect them to be implemented/used unless there is a good 
argument against that.

On 02/11/2010 1:59 AM, HE Bing wrote:
> _______________________________________________
> Audio/Video Transport Working Group
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avt

---

From: "HE Bing" <[email-masked]>
Date: Mon, 15 Nov 2010 18:44:23 +0800

Hello Tom,
Sorry for my delayed reply because I thought no one will reply to the
mail after 10 days waiting :-)
Yes the vendor defend their implementation because of no MUST associated
to the use of volume field in regenerating the tone. They declare the
harded -13dBm0 level is safe enough.
When you design the volume field in the NTE packet, is there any other
purpose in mind besides regenerating tone?
Thanks a lot for your clarification!
BR/HB

-----Original Message-----
From: Tom Taylor [mailto:[email-masked]] 
Sent: Wednesday, November 03, 2010 4:55 AM
To: HE Bing
Cc: [email-masked]; [email-masked]; XU Hui N; Felizardo Jose
Subject: Re: [AVT] RFC4733/2833 related: Should volume field value be
used in regenerating DTMF tone?

On 02/11/2010 1:59 AM, HE Bing wrote:
>> Our DSP vendor uses a hardcoded power level instead of the valid 
>> value carried by the volume field in NTE packet and declare this does

>> not violate RFC 2833 and RFC 4733 due to no explicit statement 
>> telling that value SHALL or SHOULD be used.
>>
>> We can say nothing bu we do think the volume field value SHALL be 
>> used in generating DTMF tone as long as it is valid. Each DSP vendor 
>> may have different implementation, but if support of RFC 2833 or 4733

>> is declared, use of volume field has to be supported at least as an 
>> option.